summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNathan Phillip Brink <binki@gentoo.org>2011-11-09 18:13:51 +0000
committerNathan Phillip Brink <binki@gentoo.org>2011-11-09 18:13:51 +0000
commit1c5c21550dea6decf200bfdd4dd35bcae2660918 (patch)
tree36e07fac2299caa4f225d2f832e76b32264f91fc /net-irc/unrealircd
parentVersion bump. Add opencl use flag. (diff)
downloadgentoo-2-1c5c21550dea6decf200bfdd4dd35bcae2660918.tar.gz
gentoo-2-1c5c21550dea6decf200bfdd4dd35bcae2660918.tar.bz2
gentoo-2-1c5c21550dea6decf200bfdd4dd35bcae2660918.zip
Fix bug 389949 (by scribeofthenile) where compilation failed in unrealircd-3.2.9 and unrealircd-3.2.9_rc2 when USE=-extban-stacking.
(Portage version: 2.2.0_alpha71-r1/cvs/Linux x86_64)
Diffstat (limited to 'net-irc/unrealircd')
-rw-r--r--net-irc/unrealircd/ChangeLog8
-rw-r--r--net-irc/unrealircd/files/unrealircd-3.2.9-disabled-stacked-extbans.patch22
-rw-r--r--net-irc/unrealircd/unrealircd-3.2.9.ebuild4
-rw-r--r--net-irc/unrealircd/unrealircd-3.2.9_rc2.ebuild6
4 files changed, 36 insertions, 4 deletions
diff --git a/net-irc/unrealircd/ChangeLog b/net-irc/unrealircd/ChangeLog
index 874a8c4d24b7..752b86941998 100644
--- a/net-irc/unrealircd/ChangeLog
+++ b/net-irc/unrealircd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-irc/unrealircd
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/unrealircd/ChangeLog,v 1.88 2011/11/06 02:58:47 binki Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/unrealircd/ChangeLog,v 1.89 2011/11/09 18:13:51 binki Exp $
+
+ 09 Nov 2011; Nathan Phillip Brink <binki@gentoo.org>
+ unrealircd-3.2.9_rc2.ebuild, unrealircd-3.2.9.ebuild,
+ +files/unrealircd-3.2.9-disabled-stacked-extbans.patch:
+ Fix bug 389949 (by scribeofthenile) where compilation failed in
+ unrealircd-3.2.9 and unrealircd-3.2.9_rc2 when USE=-extban-stacking.
*unrealircd-3.2.9 (06 Nov 2011)
diff --git a/net-irc/unrealircd/files/unrealircd-3.2.9-disabled-stacked-extbans.patch b/net-irc/unrealircd/files/unrealircd-3.2.9-disabled-stacked-extbans.patch
new file mode 100644
index 000000000000..447f674e00ac
--- /dev/null
+++ b/net-irc/unrealircd/files/unrealircd-3.2.9-disabled-stacked-extbans.patch
@@ -0,0 +1,22 @@
+# HG changeset patch
+# User Nathan Phillip Brink <ohnobinki@ohnopublishing.net>
+# Date 1320859299 0
+# Node ID 110ba58ecd56ad5debb00726e5e3ca8d5df135bf
+# Parent a673dd0f7b377ec35ce26fffc4affc9c7563c7b1
+- Fix compilation issue when disabling stacked extbans. https://bugs.gentoo.org/389949
+
+diff -r a673dd0f7b37 -r 110ba58ecd56 Changes
+diff -r a673dd0f7b37 -r 110ba58ecd56 src/extbans.c
+--- a/src/extbans.c Wed Nov 09 17:16:55 2011 +0000
++++ b/src/extbans.c Wed Nov 09 17:21:39 2011 +0000
+@@ -533,9 +533,9 @@
+ req.conv_param = extban_conv_param_nuh;
+ #else
+ req.conv_param = extban_conv_param_nuh_or_extban;
++ req.is_ok = extban_is_ok_nuh_extban;
+ #endif
+ req.is_banned = extban_modej_is_banned;
+- req.is_ok = extban_is_ok_nuh_extban;
+ req.options = EXTBOPT_ACTMODIFIER;
+ ExtbanAdd(NULL, req);
+
diff --git a/net-irc/unrealircd/unrealircd-3.2.9.ebuild b/net-irc/unrealircd/unrealircd-3.2.9.ebuild
index 2f062326eac9..958bb944674e 100644
--- a/net-irc/unrealircd/unrealircd-3.2.9.ebuild
+++ b/net-irc/unrealircd/unrealircd-3.2.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/unrealircd/unrealircd-3.2.9.ebuild,v 1.1 2011/11/06 02:58:47 binki Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/unrealircd/unrealircd-3.2.9.ebuild,v 1.2 2011/11/09 18:13:51 binki Exp $
EAPI=4
@@ -34,6 +34,8 @@ pkg_setup() {
}
src_prepare() {
+ epatch "${FILESDIR}"/${P}-disabled-stacked-extbans.patch
+
# QA check against bundled pkgs
rm extras/*.gz || die
diff --git a/net-irc/unrealircd/unrealircd-3.2.9_rc2.ebuild b/net-irc/unrealircd/unrealircd-3.2.9_rc2.ebuild
index ed80ed6b5e20..461dcb5a43c8 100644
--- a/net-irc/unrealircd/unrealircd-3.2.9_rc2.ebuild
+++ b/net-irc/unrealircd/unrealircd-3.2.9_rc2.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/unrealircd/unrealircd-3.2.9_rc2.ebuild,v 1.1 2011/07/27 12:41:19 binki Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/unrealircd/unrealircd-3.2.9_rc2.ebuild,v 1.2 2011/11/09 18:13:51 binki Exp $
EAPI=4
-inherit eutils autotools ssl-cert versionator multilib
+inherit eutils ssl-cert versionator multilib
MY_P=Unreal${PV/_/-}
@@ -34,6 +34,8 @@ pkg_setup() {
}
src_prepare() {
+ epatch "${FILESDIR}"/${PN}-3.2.9-disabled-stacked-extbans.patch
+
# QA check against bundled pkgs
rm extras/*.gz || die