summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2006-07-24 18:45:08 +0000
committerAlastair Tse <liquidx@gentoo.org>2006-07-24 18:45:08 +0000
commit30d188687e43749733477baa017eaec955cfa710 (patch)
tree9e95bdd39f1c27ad5a1d4c36151ca8a42ab8135a /net-irc/supybot
parentversion bump (#140328) (diff)
downloadgentoo-2-30d188687e43749733477baa017eaec955cfa710.tar.gz
gentoo-2-30d188687e43749733477baa017eaec955cfa710.tar.bz2
gentoo-2-30d188687e43749733477baa017eaec955cfa710.zip
version bump (#141606)
(Portage version: 2.1.1_pre3-r4)
Diffstat (limited to 'net-irc/supybot')
-rw-r--r--net-irc/supybot/ChangeLog10
-rw-r--r--net-irc/supybot/files/digest-supybot-0.83.23
-rw-r--r--net-irc/supybot/supybot-0.83.1.ebuild6
-rw-r--r--net-irc/supybot/supybot-0.83.2.ebuild38
4 files changed, 52 insertions, 5 deletions
diff --git a/net-irc/supybot/ChangeLog b/net-irc/supybot/ChangeLog
index 9a21d37606f6..5f48ac99f8ab 100644
--- a/net-irc/supybot/ChangeLog
+++ b/net-irc/supybot/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-irc/supybot
-# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/supybot/ChangeLog,v 1.13 2005/11/05 16:13:02 liquidx Exp $
+# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/supybot/ChangeLog,v 1.14 2006/07/24 18:45:08 liquidx Exp $
+
+*supybot-0.83.2 (24 Jul 2006)
+
+ 24 Jul 2006; Alastair Tse <liquidx@gentoo.org> supybot-0.83.1.ebuild,
+ +supybot-0.83.2.ebuild:
+ version bump (#141606)
*supybot-0.83.1 (05 Nov 2005)
diff --git a/net-irc/supybot/files/digest-supybot-0.83.2 b/net-irc/supybot/files/digest-supybot-0.83.2
new file mode 100644
index 000000000000..67cf9ef3df28
--- /dev/null
+++ b/net-irc/supybot/files/digest-supybot-0.83.2
@@ -0,0 +1,3 @@
+MD5 514c23a3388b65da81b9b6f1990a1912 Supybot-0.83.2.tar.bz2 376652
+RMD160 43a802691c4eac23375b3fabcd2f8d6fc5ff49ad Supybot-0.83.2.tar.bz2 376652
+SHA256 205ae6df58f70679373d81b8d4ddb634257665de6601eb9a0c2092c4d68ccd6b Supybot-0.83.2.tar.bz2 376652
diff --git a/net-irc/supybot/supybot-0.83.1.ebuild b/net-irc/supybot/supybot-0.83.1.ebuild
index 843ac93656c2..e70104dc4415 100644
--- a/net-irc/supybot/supybot-0.83.1.ebuild
+++ b/net-irc/supybot/supybot-0.83.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/supybot/supybot-0.83.1.ebuild,v 1.1 2005/11/05 16:13:02 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/supybot/supybot-0.83.1.ebuild,v 1.2 2006/07/24 18:45:08 liquidx Exp $
inherit distutils eutils
@@ -13,7 +13,7 @@ SRC_URI="mirror://sourceforge/supybot/${MY_P}.tar.bz2"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~x86 ~ppc"
+KEYWORDS="~ppc x86"
IUSE="sqlite"
DEPEND=">=dev-lang/python-2.3
diff --git a/net-irc/supybot/supybot-0.83.2.ebuild b/net-irc/supybot/supybot-0.83.2.ebuild
new file mode 100644
index 000000000000..2909e8ce28db
--- /dev/null
+++ b/net-irc/supybot/supybot-0.83.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/supybot/supybot-0.83.2.ebuild,v 1.1 2006/07/24 18:45:08 liquidx Exp $
+
+inherit distutils eutils
+
+MY_P=${P/supybot/Supybot}
+MY_P=${MY_P/_rc/rc}
+
+DESCRIPTION="Python based extensible IRC infobot and channel bot"
+HOMEPAGE="http://supybot.sf.net/"
+SRC_URI="mirror://sourceforge/supybot/${MY_P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+IUSE="sqlite"
+
+DEPEND=">=dev-lang/python-2.3
+ >=dev-python/twisted-1.2.0
+ sqlite? ( <dev-python/pysqlite-1.1 )"
+
+S=${WORKDIR}/${MY_P}
+
+PYTHON_MODNAME="supybot"
+DOCS="ACKS BUGS DEVS README RELNOTES TODO"
+
+src_install() {
+ distutils_src_install
+ doman docs/man/*
+ dodoc docs/*
+}
+
+pkg_postinst() {
+ einfo "Use supybot-wizard to create a configuration file"
+ use sqlite || \
+ einfo "Some plugins may require emerge with USE=\"sqlite\" to work."
+}