summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Hadaway <raker@gentoo.org>2002-10-22 05:01:11 +0000
committerNick Hadaway <raker@gentoo.org>2002-10-22 05:01:11 +0000
commit37c4dde05be3deac18777062b84b71eed884bf1a (patch)
tree0157c3caa983330ccd02019ee8cd220f80cfa245 /net-irc/quirc
parentnew version (diff)
downloadgentoo-2-37c4dde05be3deac18777062b84b71eed884bf1a.tar.gz
gentoo-2-37c4dde05be3deac18777062b84b71eed884bf1a.tar.bz2
gentoo-2-37c4dde05be3deac18777062b84b71eed884bf1a.zip
Version bump. Marked as unstable. Please comment on bug #9303.
Patched c++ code to compile properly and added CXX="g++" to the ebuild.
Diffstat (limited to 'net-irc/quirc')
-rw-r--r--net-irc/quirc/ChangeLog10
-rw-r--r--net-irc/quirc/files/0.9.83-gentoo.diff35
-rw-r--r--net-irc/quirc/files/digest-quirc-0.9.831
-rw-r--r--net-irc/quirc/quirc-0.9.83.ebuild56
4 files changed, 100 insertions, 2 deletions
diff --git a/net-irc/quirc/ChangeLog b/net-irc/quirc/ChangeLog
index 82c58aa1fb0e..fb5d30f07357 100644
--- a/net-irc/quirc/ChangeLog
+++ b/net-irc/quirc/ChangeLog
@@ -1,10 +1,16 @@
# ChangeLog for net-irc/quirc
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-irc/quirc/ChangeLog,v 1.1 2002/04/25 20:40:20 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/quirc/ChangeLog,v 1.2 2002/10/22 05:01:11 raker Exp $
+
+*quirc-0.9.83 (21 Oct 2002)
+
+ 21 Oct 20002; Nick Hadaway <raker@gentoo.org> quirc-0.9.83.ebuild,
+ files/digest-quirc-0.9.83, files/0.9.83-gentoo.diff :
+ Version bump to fix some minor bugs. Added a diff to fix c++ code.
+ Currently marked unstable. See bug #9303
*quirc-0.9.82 (25 Apr 2002)
25 Apr 2002; Semant Kulleen <seemant@gentoo.org> quirc-0.9.82.ebuild
files/digest-quirc-0.9.82
-
New package added to portage.
diff --git a/net-irc/quirc/files/0.9.83-gentoo.diff b/net-irc/quirc/files/0.9.83-gentoo.diff
new file mode 100644
index 000000000000..d798a57fba23
--- /dev/null
+++ b/net-irc/quirc/files/0.9.83-gentoo.diff
@@ -0,0 +1,35 @@
+diff -urN quirc-0.9.83/server.cc quirc-0.9.83-modified/server.cc
+--- quirc-0.9.83/server.cc 2002-10-02 01:19:22.000000000 -0500
++++ quirc-0.9.83-modified/server.cc 2002-10-21 23:54:37.000000000 -0500
+@@ -11,7 +11,8 @@
+ #include <ctype.h>
+ #include <netdb.h>
+ #include <stdarg.h>
+-#include <iostream.h>
++
++using namespace std;
+
+ #include "config.h"
+
+diff -urN quirc-0.9.83/servertcl.cc quirc-0.9.83-modified/servertcl.cc
+--- quirc-0.9.83/servertcl.cc 2002-10-02 01:18:59.000000000 -0500
++++ quirc-0.9.83-modified/servertcl.cc 2002-10-21 23:53:04.000000000 -0500
+@@ -1,6 +1,7 @@
+ #include <sys/types.h>
+ #include <netinet/in.h>
+ #include <arpa/inet.h>
++#include <ctype.h>
+
+ #ifdef DMALLOC
+ #include <dmalloc.h>
+diff -urN quirc-0.9.83/tcl.cc quirc-0.9.83-modified/tcl.cc
+--- quirc-0.9.83/tcl.cc 2002-10-01 03:32:32.000000000 -0500
++++ quirc-0.9.83-modified/tcl.cc 2002-10-21 23:52:06.000000000 -0500
+@@ -1,6 +1,7 @@
+ #include <sys/time.h>
+ #include <unistd.h>
+ #include <sys/socket.h>
++#include <ctype.h>
+
+ #ifdef DMALLOC
+ #include <dmalloc.h>
diff --git a/net-irc/quirc/files/digest-quirc-0.9.83 b/net-irc/quirc/files/digest-quirc-0.9.83
new file mode 100644
index 000000000000..0bae9897cdb1
--- /dev/null
+++ b/net-irc/quirc/files/digest-quirc-0.9.83
@@ -0,0 +1 @@
+MD5 27f357aac1f305682ae79c9f0163c069 quirc-0.9.83.tar.gz 297139
diff --git a/net-irc/quirc/quirc-0.9.83.ebuild b/net-irc/quirc/quirc-0.9.83.ebuild
new file mode 100644
index 000000000000..6f66a67ce056
--- /dev/null
+++ b/net-irc/quirc/quirc-0.9.83.ebuild
@@ -0,0 +1,56 @@
+# Copyright 2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/quirc/quirc-0.9.83.ebuild,v 1.1 2002/10/22 05:01:11 raker Exp $
+
+S=${WORKDIR}/${P}
+
+DESCRIPTION="A GUI IRC client scriptable in Tcl/Tk"
+SRC_URI="http://quirc.org/${P}.tar.gz"
+HOMEPAGE="http://quirc.org/"
+
+DEPEND="dev-lang/tcl
+ dev-lang/tk"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}
+ patch -p1 < ${FILESDIR}/0.9.83-gentoo.diff || die "patch failed"
+
+}
+
+src_compile() {
+
+ export CXX="g++"
+
+ econf \
+ --datadir=/usr/share/quirc \
+ || die "./configure failed"
+
+ emake || die
+
+}
+
+src_install () {
+
+ exeinto /usr/bin
+ doexe quirc
+
+ insinto /usr/share/quirc
+ doins data/*.tcl data/quedit data/fontsel data/servers data/VERSION
+
+ insinto /usr/share/quirc/common
+ doins ${S}/data/common/*.tcl
+
+ insinto /usr/share/quirc/themes
+ doins ${S}/data/themes/*.tcl
+
+ # this package installs docs, but we would rather do that ourselves
+ dodoc README NEWS INSTALL FAQ ChangeLog* COPYING AUTHORS
+ dodoc doc/*.txt
+
+}