summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2008-11-25 00:24:42 +0000
committerJeremy Olexa <darkside@gentoo.org>2008-11-25 00:24:42 +0000
commit70cd03f9316226af35fbf9bd9febc010d3b84d9c (patch)
treee065421c434905ec316cfb39136afd27961c0a2d /net-irc/quassel
parentGo eapi-2. Most of the ebuilds pulling this are eapi-2 anyway, and this way I... (diff)
downloadgentoo-2-70cd03f9316226af35fbf9bd9febc010d3b84d9c.tar.gz
gentoo-2-70cd03f9316226af35fbf9bd9febc010d3b84d9c.tar.bz2
gentoo-2-70cd03f9316226af35fbf9bd9febc010d3b84d9c.zip
cosmetic cleanups for bug #248217 by Daniel Pielmeier (billie). Add myself to metadata until jokey is free again
(Portage version: 2.2_rc15/cvs/Linux 2.6.27.6 x86_64)
Diffstat (limited to 'net-irc/quassel')
-rw-r--r--net-irc/quassel/ChangeLog7
-rw-r--r--net-irc/quassel/metadata.xml6
-rw-r--r--net-irc/quassel/quassel-0.3.0.3.ebuild42
-rw-r--r--net-irc/quassel/quassel-9999.ebuild51
4 files changed, 64 insertions, 42 deletions
diff --git a/net-irc/quassel/ChangeLog b/net-irc/quassel/ChangeLog
index 78bfbe8ad595..9c1c3e10ffbb 100644
--- a/net-irc/quassel/ChangeLog
+++ b/net-irc/quassel/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-irc/quassel
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/quassel/ChangeLog,v 1.33 2008/10/26 13:22:39 jokey Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/quassel/ChangeLog,v 1.34 2008/11/25 00:24:42 darkside Exp $
+
+ 25 Nov 2008; Jeremy Olexa <darkside@gentoo.org> metadata.xml,
+ quassel-0.3.0.3.ebuild, quassel-9999.ebuild:
+ cosmetic cleanups for bug #248217 by Daniel Pielmeier (billie). Add myself
+ to metadata until jokey is free again
*quassel-0.3.0.3 (26 Oct 2008)
diff --git a/net-irc/quassel/metadata.xml b/net-irc/quassel/metadata.xml
index e023b10a7444..14cdc661a4c2 100644
--- a/net-irc/quassel/metadata.xml
+++ b/net-irc/quassel/metadata.xml
@@ -3,12 +3,12 @@
<pkgmetadata>
<herd>net-irc</herd>
<maintainer>
- <email>jokey@gentoo.org</email>
- </maintainer>
- <maintainer>
<email>daniel.pielmeier@googlemail.com</email>
<name>Daniel Pielmeier</name>
</maintainer>
+ <maintainer>
+ <email>darkside@gentoo.org</email>
+ </maintainer>
<use>
<flag name="X">
Build the Qt 4 GUI client for quassel. If this USE flag is
diff --git a/net-irc/quassel/quassel-0.3.0.3.ebuild b/net-irc/quassel/quassel-0.3.0.3.ebuild
index 65223a4d3531..ffc9a5b978c4 100644
--- a/net-irc/quassel/quassel-0.3.0.3.ebuild
+++ b/net-irc/quassel/quassel-0.3.0.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/quassel/quassel-0.3.0.3.ebuild,v 1.1 2008/10/26 13:22:39 jokey Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/quassel/quassel-0.3.0.3.ebuild,v 1.2 2008/11/25 00:24:42 darkside Exp $
EAPI=1
@@ -55,22 +55,30 @@ pkg_setup() {
}
src_compile() {
- local MY_LANGUAGES=""
- for ling in ${LINGUAS}; do
- if has $ling ${LANGS}; then
- MY_LANGUAGES="${ling} ${MY_LANGUAGES}"
- fi
- done
-
- local mycmakeargs="
- $(cmake-utils_use_want server CORE)
- $(cmake-utils_use_want X QTCLIENT)
- $(cmake-utils_use_with dbus DBUS)
- $(cmake-utils_use_with ssl OPENSSL)
- -DLINGUAS="${MY_LANGUAGES}"
- -DWANT_MONO=OFF"
-
- cmake-utils_src_compile
+# Comment this out and invoke _common_configure_code, cmake and cmake-utils_src_make
+# manually until cmake-utils.eclass supports space separated strings as arguments for cmake
+# options. Until now multiple languages are not passed to -DLINGUAS and only the first
+# language is considered.
+#
+# local mycmakeargs=(
+# "$(cmake-utils_use_want server CORE)"
+# "$(cmake-utils_use_want X QTCLIENT)"
+# "$(cmake-utils_use_with dbus DBUS)"
+# "$(cmake-utils_use_with ssl OPENSSL)"
+# "-DLINGUAS=\"${LINGUAS}\""
+# '-DWANT_MONO=OFF' )
+#
+# cmake-utils_src_compile
+
+ _common_configure_code
+
+ cmake -C "${TMPDIR}/gentoo_common_config.cmake" \
+ $(cmake-utils_use_want server CORE) $(cmake-utils_use_want X QTCLIENT) \
+ $(cmake-utils_use_with dbus DBUS) $(cmake-utils_use_with ssl OPENSSL) \
+ -DLINGUAS="${LINGUAS}" -DWANT_MONO=OFF \
+ "${S}" || die "Cmake failed"
+
+ cmake-utils_src_make
}
src_install() {
diff --git a/net-irc/quassel/quassel-9999.ebuild b/net-irc/quassel/quassel-9999.ebuild
index d7e81041d35c..350673a42a1b 100644
--- a/net-irc/quassel/quassel-9999.ebuild
+++ b/net-irc/quassel/quassel-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/quassel/quassel-9999.ebuild,v 1.10 2008/10/07 20:37:45 jokey Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/quassel/quassel-9999.ebuild,v 1.11 2008/11/25 00:24:42 darkside Exp $
EAPI=1
@@ -17,7 +17,7 @@ KEYWORDS=""
SLOT="0"
IUSE="+dbus debug +server +ssl +X"
-LANGS="nb_NO da de fr"
+LANGS="nb_NO da de fr ru"
for l in ${LANGS}; do
IUSE="${IUSE} linguas_${l}"
done
@@ -56,25 +56,34 @@ pkg_setup() {
}
src_compile() {
- local MY_LANGUAGES=""
- for ling in ${LINGUAS}; do
- if has $ling ${LANGS}; then
- MY_LANGUAGES="${ling} ${MY_LANGUAGES}"
- fi
- done
-
- local mycmakeargs="
- $(cmake-utils_use_want server CORE)
- $(cmake-utils_use_want X QTCLIENT)
- $(cmake-utils_use_with X WEBKIT)
- $(cmake-utils_use_with dbus DBUS)
- $(cmake-utils_use_with ssl OPENSSL)
- -DLINGUAS="${MY_LANGUAGES}"
- -DOXYGEN_ICONS=Builtin
- -DQUASSEL_ICONS=Builtin
- -DWANT_MONO=OFF"
-
- cmake-utils_src_compile
+# Comment this out and invoke _common_configure_code, cmake and cmake-utils_src_make
+# manually until cmake-utils.eclass supports space separated strings as arguments for cmake
+# options. Until now multiple languages are not passed to -DLINGUAS and only the first
+# language is considered.
+#
+# local mycmakeargs=(
+# "$(cmake-utils_use_want server CORE)"
+# "$(cmake-utils_use_want X QTCLIENT)"
+# "$(cmake-utils_use_with X WEBKIT)"
+# "$(cmake-utils_use_with dbus DBUS)"
+# "$(cmake-utils_use_with ssl OPENSSL)"
+# "-DLINGUAS=\"${LINGUAS}\""
+# '-DOXYGEN_ICONS=Builtin'
+# '-DQUASSEL_ICONS=Builtin'
+# '-DWANT_MONO=OFF' )
+#
+# cmake-utils_src_compile
+
+ _common_configure_code
+
+ cmake -C "${TMPDIR}/gentoo_common_config.cmake" \
+ $(cmake-utils_use_want server CORE) $(cmake-utils_use_want X QTCLIENT) \
+ $(cmake-utils_use_with X WEBKIT) $(cmake-utils_use_with dbus DBUS) \
+ $(cmake-utils_use_with ssl OPENSSL) -DLINGUAS="${LINGUAS}" \
+ -DOXYGEN_ICONS=Builtin -DQUASSEL_ICONS=Builtin -DWANT_MONO=OFF \
+ "${S}" || die "Cmake failed"
+
+ cmake-utils_src_make
}
src_install() {