summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDawid Węgliński <cla@gentoo.org>2007-10-29 22:45:09 +0000
committerDawid Węgliński <cla@gentoo.org>2007-10-29 22:45:09 +0000
commit24b254cf56e35aa70d8328d39fb0b69905efd7a4 (patch)
tree0893c7adb07cda77819e2390514b646d49f41f9d /net-irc/mistbot/mistbot-0.9.ebuild
parentSparc stable, Bug #195261 -- tests pass; sparc has been good a couple weeks. (diff)
downloadgentoo-2-24b254cf56e35aa70d8328d39fb0b69905efd7a4.tar.gz
gentoo-2-24b254cf56e35aa70d8328d39fb0b69905efd7a4.tar.bz2
gentoo-2-24b254cf56e35aa70d8328d39fb0b69905efd7a4.zip
Initial import, fixing bug #197211, thanks to Alexander Graf for submitting
(Portage version: 2.1.3.16)
Diffstat (limited to 'net-irc/mistbot/mistbot-0.9.ebuild')
-rw-r--r--net-irc/mistbot/mistbot-0.9.ebuild69
1 files changed, 69 insertions, 0 deletions
diff --git a/net-irc/mistbot/mistbot-0.9.ebuild b/net-irc/mistbot/mistbot-0.9.ebuild
new file mode 100644
index 000000000000..f5ad1d7a262e
--- /dev/null
+++ b/net-irc/mistbot/mistbot-0.9.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/mistbot/mistbot-0.9.ebuild,v 1.1 2007/10/29 22:45:09 cla Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A modular IRC-Bot written in C++"
+HOMEPAGE="http://kuja.in/mistbot/"
+
+SRC_URI="http://znc.in/~psychon/mistbot/downloads/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="doc xml nls debug ssl"
+
+RDEPEND="virtual/libc
+ dev-libs/confuse
+ net-dns/c-ares
+ xml? ( dev-libs/libxml2 )"
+
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+src_compile() {
+ ebegin "Change build.conf to fit needs"
+
+ if ! use xml; then
+ sed -e '/^MODS\ +=\ rss$/d' -i build.conf || die "sed failed"
+ fi
+
+ if ! use nls; then
+ sed -e '/^NLS = nls$/d' -i build.conf || die "sed failed"
+ fi
+
+ if ! use debug; then
+ sed -e '/^DEBUG = debug$/d' -i build.conf || die "sed failed"
+ fi
+
+ if ! use ssl; then
+ sed -e '/^SSL = ssl$/d' -i build.conf || die "sed failed"
+ fi
+
+ sed -e 's/^#ONCE\ =\ yes$/ONCE\ =\ yes/' -i build.conf || die "sed failed"
+
+ echo "CXXFLAGS=${CXXFLAGS}" >> build.conf
+ echo "CXX=$(tc-getCXX)" >> build.conf
+ echo "PREFIX=/usr" >> build.conf
+
+ ebegin "compiling source"
+
+ emake all-oneGo || die "emake failed"
+
+ if use doc; then
+ ebegin "generate documentation"
+ make doc || die "make doc failed"
+ fi
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die "make install failed"
+ dodoc AUTHORS mistbot.conf
+
+ if use doc; then
+ dodoc doc/userdoc.html
+ insinto /usr/share/doc/${PF}/api
+ doins doc/api/* || die "install API docs failed"
+ fi
+}