summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDane Smith <c1pher@gentoo.org>2011-05-11 11:51:29 +0000
committerDane Smith <c1pher@gentoo.org>2011-05-11 11:51:29 +0000
commit94d5cce44f64d9a136fdbf68abc8ff992bc08808 (patch)
tree5f73b5dfa267f9903633accda9a04b736da48df6 /net-irc/inspircd
parentCreate a menu entry. Require version >=2.26 for glib-2 for GUnixSocketAddress... (diff)
downloadgentoo-2-94d5cce44f64d9a136fdbf68abc8ff992bc08808.tar.gz
gentoo-2-94d5cce44f64d9a136fdbf68abc8ff992bc08808.tar.bz2
gentoo-2-94d5cce44f64d9a136fdbf68abc8ff992bc08808.zip
net-irc/inspircd: Remove use of die in a subshell.
(Portage version: 2.2.0_alpha32/cvs/Linux x86_64)
Diffstat (limited to 'net-irc/inspircd')
-rw-r--r--net-irc/inspircd/ChangeLog5
-rw-r--r--net-irc/inspircd/inspircd-2.0.3.ebuild9
2 files changed, 9 insertions, 5 deletions
diff --git a/net-irc/inspircd/ChangeLog b/net-irc/inspircd/ChangeLog
index da3845a66580..e3c40031c505 100644
--- a/net-irc/inspircd/ChangeLog
+++ b/net-irc/inspircd/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-irc/inspircd
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/inspircd/ChangeLog,v 1.36 2011/05/11 08:35:40 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/inspircd/ChangeLog,v 1.37 2011/05/11 11:51:29 c1pher Exp $
+
+ 11 May 2011; Dane Smith <c1pher@gentoo.org> inspircd-2.0.3.ebuild:
+ Fix use of || die in subshell in ebuild. No revbump.
11 May 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org> inspircd-2.0.3.ebuild:
x86 stable wrt bug #364905
diff --git a/net-irc/inspircd/inspircd-2.0.3.ebuild b/net-irc/inspircd/inspircd-2.0.3.ebuild
index edaede690eb7..a6b19de943e5 100644
--- a/net-irc/inspircd/inspircd-2.0.3.ebuild
+++ b/net-irc/inspircd/inspircd-2.0.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/inspircd/inspircd-2.0.3.ebuild,v 1.5 2011/05/11 08:35:40 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/inspircd/inspircd-2.0.3.ebuild,v 1.6 2011/05/11 11:51:29 c1pher Exp $
EAPI=2
inherit eutils multilib flag-o-matic
@@ -61,9 +61,10 @@ src_configure() {
# allow inspircd to be built by root
touch .force-root-ok || die
- [ ${extras} ] && ( ./configure --disable-interactive \
- --enable-extras=${extras} \
- || die "configure failed" )
+ if [ -n "${extras}" ]; then
+ ./configure --disable-interactive \
+ --enable-extras=${extras} || die "configure failed"
+ fi
./configure \
$(use_enable openssl) \