summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2013-05-08 23:53:14 +0000
committerJulian Ospald <hasufell@gentoo.org>2013-05-08 23:53:14 +0000
commit1105b6f739794f123363c903b9f20cff98561778 (patch)
tree0838c6da28505368883b51c6467bec7297a0ed3a /net-irc/hexchat
parentDrop ffmpeg patch applied by upstream in 6.0 (diff)
downloadgentoo-2-1105b6f739794f123363c903b9f20cff98561778.tar.gz
gentoo-2-1105b6f739794f123363c903b9f20cff98561778.tar.bz2
gentoo-2-1105b6f739794f123363c903b9f20cff98561778.zip
fix build time error wrt #469122
(Portage version: 2.2.0_alpha174/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'net-irc/hexchat')
-rw-r--r--net-irc/hexchat/ChangeLog6
-rw-r--r--net-irc/hexchat/files/hexchat-2.9.5-gobject.patch31
-rw-r--r--net-irc/hexchat/hexchat-2.9.5.ebuild5
3 files changed, 39 insertions, 3 deletions
diff --git a/net-irc/hexchat/ChangeLog b/net-irc/hexchat/ChangeLog
index 1e7826f111a0..c66a5aca42c0 100644
--- a/net-irc/hexchat/ChangeLog
+++ b/net-irc/hexchat/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-irc/hexchat
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/hexchat/ChangeLog,v 1.39 2013/04/03 18:10:31 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/hexchat/ChangeLog,v 1.40 2013/05/08 23:53:14 hasufell Exp $
+
+ 08 May 2013; Julian Ospald <hasufell@gentoo.org> hexchat-2.9.5.ebuild,
+ +files/hexchat-2.9.5-gobject.patch:
+ fix build time error wrt #469122
*hexchat-2.9.5 (03 Apr 2013)
diff --git a/net-irc/hexchat/files/hexchat-2.9.5-gobject.patch b/net-irc/hexchat/files/hexchat-2.9.5-gobject.patch
new file mode 100644
index 000000000000..6393f70e5f23
--- /dev/null
+++ b/net-irc/hexchat/files/hexchat-2.9.5-gobject.patch
@@ -0,0 +1,31 @@
+From: Julian Ospald <hasufell@gentoo.org>
+Date: Wed May 8 23:22:23 UTC 2013
+Subject: fix build time error
+
+https://bugs.gentoo.org/show_bug.cgi?id=469122
+https://github.com/hexchat/hexchat/pull/580
+
+--- hexchat-2.9.5/configure.ac
++++ hexchat-2.9.5/configure.ac
+@@ -190,9 +190,10 @@
+ if test "$glib" = no; then
+ AC_MSG_ERROR(Cannot find GLib!)
+ fi
++PKG_CHECK_MODULES([GOBJECT], [gobject-2.0], [], [AC_MSG_ERROR(Cannot find gobject-2.0!)])
+
+-COMMON_CFLAGS="$GLIB_CFLAGS"
+-COMMON_LIBS="$GLIB_LIBS"
++COMMON_CFLAGS="$GLIB_CFLAGS $GOBJECT_CFLAGS"
++COMMON_LIBS="$GLIB_LIBS $GOBJECT_LIBS"
+ COMMON_LIBS="$COMMON_LIBS -lgmodule-2.0"
+
+ dnl *********************************************************************
+@@ -213,8 +214,6 @@
+
+ if test "$gtkfe" != yes; then
+ gnome=no
+- COMMON_LIBS="$GLIB_LIBS"
+- COMMON_CFLAGS="$GLIB_CFLAGS"
+ fi
+
+ dnl *********************************************************************
diff --git a/net-irc/hexchat/hexchat-2.9.5.ebuild b/net-irc/hexchat/hexchat-2.9.5.ebuild
index c99ed323c4ec..c687dd5e1cf9 100644
--- a/net-irc/hexchat/hexchat-2.9.5.ebuild
+++ b/net-irc/hexchat/hexchat-2.9.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/hexchat/hexchat-2.9.5.ebuild,v 1.1 2013/04/03 18:10:31 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/hexchat/hexchat-2.9.5.ebuild,v 1.2 2013/05/08 23:53:14 hasufell Exp $
EAPI=5
@@ -49,7 +49,8 @@ src_prepare() {
epatch \
"${FILESDIR}"/${PN}-2.9.1-input-box.patch \
"${FILESDIR}"/${PN}-2.9.5-cflags.patch \
- "${FILESDIR}"/${PN}-2.9.5-gettextize.patch
+ "${FILESDIR}"/${PN}-2.9.5-gettextize.patch \
+ "${FILESDIR}"/${PN}-2.9.5-gobject.patch
cp $(type -p gettextize) "${T}"/ || die
sed -i -e 's:read dummy < /dev/tty::' "${T}/gettextize" || die