summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-12-28 21:01:45 +0000
committerMike Frysinger <vapier@gentoo.org>2005-12-28 21:01:45 +0000
commit60c97973aa70eadc9b110e27977f8445dc516204 (patch)
tree560ad88ffae0b710f2bff743e7564fb6f763af7d /net-irc/ezbounce
parentDisabled stricter for all versions because the upstream binaries have text re... (diff)
downloadgentoo-2-60c97973aa70eadc9b110e27977f8445dc516204.tar.gz
gentoo-2-60c97973aa70eadc9b110e27977f8445dc516204.tar.bz2
gentoo-2-60c97973aa70eadc9b110e27977f8445dc516204.zip
Cleanup ebuild and fix broken C++ code #116999 by Markus Ullmann.
(Portage version: 2.1_pre2)
Diffstat (limited to 'net-irc/ezbounce')
-rw-r--r--net-irc/ezbounce/ChangeLog8
-rw-r--r--net-irc/ezbounce/ezbounce-1.04a.ebuild24
-rw-r--r--net-irc/ezbounce/files/ezbounce-1.04a-c++.patch23
3 files changed, 40 insertions, 15 deletions
diff --git a/net-irc/ezbounce/ChangeLog b/net-irc/ezbounce/ChangeLog
index c8d4bfd45699..4382ed9fd789 100644
--- a/net-irc/ezbounce/ChangeLog
+++ b/net-irc/ezbounce/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-irc/ezbounce
-# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/ezbounce/ChangeLog,v 1.6 2004/09/12 17:05:54 swegener Exp $
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/ezbounce/ChangeLog,v 1.7 2005/12/28 21:01:45 vapier Exp $
+
+ 28 Dec 2005; Mike Frysinger <vapier@gentoo.org>
+ +files/ezbounce-1.04a-c++.patch, ezbounce-1.04a.ebuild:
+ Cleanup ebuild and fix broken C++ code #116999 by Markus Ullmann.
12 Sep 2004; Sven Wegener <swegener@gentoo.org> ezbounce-1.04a.ebuild:
Modified ebuild to install sample configuration files. Closes bug #63780.
diff --git a/net-irc/ezbounce/ezbounce-1.04a.ebuild b/net-irc/ezbounce/ezbounce-1.04a.ebuild
index bc7bbd0cfe35..06c445d2f763 100644
--- a/net-irc/ezbounce/ezbounce-1.04a.ebuild
+++ b/net-irc/ezbounce/ezbounce-1.04a.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/ezbounce/ezbounce-1.04a.ebuild,v 1.7 2004/09/12 17:05:54 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/ezbounce/ezbounce-1.04a.ebuild,v 1.8 2005/12/28 21:01:45 vapier Exp $
inherit eutils
@@ -10,29 +10,27 @@ SRC_URI="http://druglord.freelsd.org/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86 ~ppc"
-
+KEYWORDS="~amd64 ~ppc ~x86"
IUSE="ssl"
+
DEPEND=">=net-misc/mdidentd-1.04a
ssl? ( dev-libs/openssl )"
src_unpack() {
unpack ${A}
-
- epatch ${FILESDIR}/${P}-crash-fix.patch
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-crash-fix.patch
+ epatch "${FILESDIR}"/${P}-c++.patch
}
src_compile() {
- local myconf
-
- use ssl && myconf="${myconf} --with-ssl"
-
- econf ${myconf} || die
- emake || die
+ econf $(use_with ssl) || die
+ emake CXX_OPTIMIZATIONS="${CXXFLAGS}" || die
}
src_install() {
- dobin ezbounce
+ dobin ezbounce || die
+ dosym ezbounce /usr/bin/ezb
dodoc CHANGES TODO README ezb.conf sample.*
doman misc/ezbounce.1
}
diff --git a/net-irc/ezbounce/files/ezbounce-1.04a-c++.patch b/net-irc/ezbounce/files/ezbounce-1.04a-c++.patch
new file mode 100644
index 000000000000..a40f078e0040
--- /dev/null
+++ b/net-irc/ezbounce/files/ezbounce-1.04a-c++.patch
@@ -0,0 +1,23 @@
+Fix some broken C++ code ... __list_iter doesn't implement get(), nor
+does __list_core implement insert() ...
+
+http://bugs.gentoo.org/116999
+
+--- ezbounce-1.04a/lib/linkedlist.h
++++ ezbounce-1.04a/lib/linkedlist.h
+@@ -89,7 +89,6 @@ public:
+ list_iterator(__list_core * x) : __list_iter(x) { }
+ T * next() { return (T *) __list_iter::next(); }
+ T * remove() { return (T *) __list_iter::remove(); }
+- T * get(void) { return (T *) __list_iter::get(); }
+ T * set(int x) { return (T *) __list_iter::set(x); }
+ };
+
+@@ -97,7 +96,6 @@ template <class T> class list : public _
+ {
+ public:
+ int add(T *x) { return __list_core::add((void *) x); }
+- int add(int w, T * x) { return __list_core::insert(w, (void *) x); }
+ T * get(int idx) { return (T *) __list_core::get(idx); }
+ T * remove(int idx) { return (T *) __list_core::remove(idx); }
+ bool remove(T * d) { return __list_core::remove(d); }