summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2008-06-06 09:30:45 +0000
committerRaúl Porcel <armin76@gentoo.org>2008-06-06 09:30:45 +0000
commit72d8e281e702e0b21295667cd3f06b6989e68669 (patch)
treec0b5078cb364396cde2f00ee58afe858d70379d2 /net-irc/ezbounce/ezbounce-1.99.14.ebuild
parentVersion bump wrt #223413, remove old (diff)
downloadgentoo-2-72d8e281e702e0b21295667cd3f06b6989e68669.tar.gz
gentoo-2-72d8e281e702e0b21295667cd3f06b6989e68669.tar.bz2
gentoo-2-72d8e281e702e0b21295667cd3f06b6989e68669.zip
Version bump
(Portage version: 2.1.4.4)
Diffstat (limited to 'net-irc/ezbounce/ezbounce-1.99.14.ebuild')
-rw-r--r--net-irc/ezbounce/ezbounce-1.99.14.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/net-irc/ezbounce/ezbounce-1.99.14.ebuild b/net-irc/ezbounce/ezbounce-1.99.14.ebuild
new file mode 100644
index 000000000000..59576f959957
--- /dev/null
+++ b/net-irc/ezbounce/ezbounce-1.99.14.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/ezbounce/ezbounce-1.99.14.ebuild,v 1.1 2008/06/06 09:30:45 armin76 Exp $
+
+inherit eutils
+
+DESCRIPTION="ezbounce is a small IRC bouncer"
+HOMEPAGE="http://www.linuxftw.com/ezbounce/"
+SRC_URI="http://www.linuxftw.com/${PN}/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="ssl boost"
+RESTRICT="test"
+
+DEPEND=">=net-misc/mdidentd-1.04c
+ ssl? ( dev-libs/openssl )
+ boost? ( dev-libs/boost )"
+
+src_compile() {
+ econf $(use_with ssl) \
+ $(use_with boost) \
+ || die
+ emake CXX_OPTIMIZATIONS="${CXXFLAGS}" || die
+}
+
+src_install() {
+ dobin ezbounce || die
+ dosym ezbounce /usr/bin/ezb
+ dodoc CHANGES TODO README ezb.conf sample.*
+ doman misc/ezbounce.1
+}