summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2007-04-10 14:11:40 +0000
committerRaúl Porcel <armin76@gentoo.org>2007-04-10 14:11:40 +0000
commit7f8230cad9ad40393b4cc53281005fe523e6a78e (patch)
treefbc0d0cb767ba8bcc99fb72352d92678197ad4da /net-irc/ezbounce/ezbounce-1.04c.ebuild
parentAdded patch for uclibc. The patch is already included upstream and fixed in (diff)
downloadgentoo-2-7f8230cad9ad40393b4cc53281005fe523e6a78e.tar.gz
gentoo-2-7f8230cad9ad40393b4cc53281005fe523e6a78e.tar.bz2
gentoo-2-7f8230cad9ad40393b4cc53281005fe523e6a78e.zip
Version bump, drop old
(Portage version: 2.1.2.3)
Diffstat (limited to 'net-irc/ezbounce/ezbounce-1.04c.ebuild')
-rw-r--r--net-irc/ezbounce/ezbounce-1.04c.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/net-irc/ezbounce/ezbounce-1.04c.ebuild b/net-irc/ezbounce/ezbounce-1.04c.ebuild
new file mode 100644
index 000000000000..5cefa4a2bbc5
--- /dev/null
+++ b/net-irc/ezbounce/ezbounce-1.04c.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/ezbounce/ezbounce-1.04c.ebuild,v 1.1 2007/04/10 14:11:40 armin76 Exp $
+
+inherit eutils
+
+DESCRIPTION="ezbounce is a small IRC bouncer"
+HOMEPAGE="http://druglord.freelsd.org/ezbounce/"
+SRC_URI="http://druglord.freelsd.org/${PN}/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="ssl"
+
+DEPEND=">=net-misc/mdidentd-1.04c
+ ssl? ( dev-libs/openssl )"
+
+src_compile() {
+ econf $(use_with ssl) || die
+ emake CXX_OPTIMIZATIONS="${CXXFLAGS}" || die
+}
+
+src_install() {
+ dobin ezbounce || die
+ dosym ezbounce /usr/bin/ezb
+ dodoc CHANGES TODO README ezb.conf sample.*
+ doman misc/ezbounce.1
+}