summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNathan Phillip Brink <binki@gentoo.org>2011-06-01 14:45:08 +0000
committerNathan Phillip Brink <binki@gentoo.org>2011-06-01 14:45:08 +0000
commitec03cd5a197aa028e854c1bf2a10ecc8690aaa72 (patch)
treeea7bed421031e2d59b9dc7c8a9e881848b6e07d8 /net-irc/epic5
parenthttp://my.opera.com/desktopteam/blog/2011/06/01/a-couple-of-improvements-sinc... (diff)
downloadgentoo-2-ec03cd5a197aa028e854c1bf2a10ecc8690aaa72.tar.gz
gentoo-2-ec03cd5a197aa028e854c1bf2a10ecc8690aaa72.tar.bz2
gentoo-2-ec03cd5a197aa028e854c1bf2a10ecc8690aaa72.zip
Bump to epic5-1.1.2 for bug #258144. Includes patches for a lot of automagic problems and LDFLAGS abuses (which were breaking LDFLAGS=-Wl,--as-needed) and adds new archive and valgrind useflags.
(Portage version: 2.2.0_alpha34-r1/cvs/Linux x86_64)
Diffstat (limited to 'net-irc/epic5')
-rw-r--r--net-irc/epic5/ChangeLog13
-rw-r--r--net-irc/epic5/epic5-1.1.2.ebuild74
-rw-r--r--net-irc/epic5/files/epic5-1.1.2-libarchive-automagic.patch53
-rw-r--r--net-irc/epic5/files/epic5-1.1.2-perl-automagic-as-needed.patch114
-rw-r--r--net-irc/epic5/files/epic5-1.1.2-ruby-automagic-as-needed.patch126
-rw-r--r--net-irc/epic5/files/epic5-1.1.2-tcl-automagic-as-needed.patch116
-rw-r--r--net-irc/epic5/metadata.xml6
7 files changed, 500 insertions, 2 deletions
diff --git a/net-irc/epic5/ChangeLog b/net-irc/epic5/ChangeLog
index da32d5c69262..742b3bea80c9 100644
--- a/net-irc/epic5/ChangeLog
+++ b/net-irc/epic5/ChangeLog
@@ -1,6 +1,17 @@
# ChangeLog for net-irc/epic5
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/epic5/ChangeLog,v 1.17 2011/05/15 22:27:43 binki Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/epic5/ChangeLog,v 1.18 2011/06/01 14:45:08 binki Exp $
+
+*epic5-1.1.2 (01 Jun 2011)
+
+ 01 Jun 2011; Nathan Phillip Brink <binki@gentoo.org> +epic5-1.1.2.ebuild,
+ +files/epic5-1.1.2-libarchive-automagic.patch,
+ +files/epic5-1.1.2-perl-automagic-as-needed.patch,
+ +files/epic5-1.1.2-ruby-automagic-as-needed.patch,
+ +files/epic5-1.1.2-tcl-automagic-as-needed.patch, metadata.xml:
+ Bump to epic5-1.1.2 for bug #258144. Includes patches for a lot of
+ automagic problems and LDFLAGS abuses (which were breaking
+ LDFLAGS=-Wl,--as-needed) and adds new archive and valgrind useflags.
15 May 2011; Nathan Phillip Brink <binki@gentoo.org> epic5-1.0.ebuild:
Slight cleanup and hopefully fix bug 367359.
diff --git a/net-irc/epic5/epic5-1.1.2.ebuild b/net-irc/epic5/epic5-1.1.2.ebuild
new file mode 100644
index 000000000000..a1afc8cbc2d9
--- /dev/null
+++ b/net-irc/epic5/epic5-1.1.2.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/epic5/epic5-1.1.2.ebuild,v 1.1 2011/06/01 14:45:08 binki Exp $
+
+EAPI=4
+
+USE_RUBY=ruby18
+RUBY_OPTIONAL=yes
+inherit autotools eutils multilib ruby-ng toolchain-funcs
+
+DESCRIPTION="Epic5 IRC Client"
+SRC_URI="ftp://ftp.epicsol.org/pub/epic/EPIC5-PRODUCTION/${P}.tar.bz2"
+HOMEPAGE="http://epicsol.org/"
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="archive ipv6 perl tcl ruby socks5 valgrind"
+
+RDEPEND="virtual/libiconv
+ >=dev-libs/openssl-0.9.8e-r3
+ >=sys-libs/ncurses-5.6-r2
+ archive? ( app-arch/libarchive )
+ perl? ( >=dev-lang/perl-5.8.8-r2 )
+ tcl? ( dev-lang/tcl )
+ socks5? ( net-proxy/dante )
+ ruby? ( $(ruby_implementation_depend ${USE_RUBY}) )"
+DEPEND="${RDEPEND}
+ valgrind? ( dev-util/valgrind )"
+
+S=${WORKDIR}/${P}
+
+# Don't use ruby-ng's separated sources support:
+src_unpack() {
+ default
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-libarchive-automagic.patch \
+ "${FILESDIR}"/${P}-ruby-automagic-as-needed.patch \
+ "${FILESDIR}"/${P}-tcl-automagic-as-needed.patch \
+ "${FILESDIR}"/${P}-perl-automagic-as-needed.patch
+ eautoconf
+}
+
+src_configure() {
+ econf \
+ --libexecdir="${EPREFIX}"/usr/lib/misc \
+ $(use_with archive libarchive) \
+ $(use_with ipv6) \
+ $(use_with perl) \
+ $(use_with ruby ruby "$(ruby_implementation_command ${USE_RUBY})") \
+ $(use_with socks5) \
+ $(use_with tcl tcl "${EPREFIX}"/usr/$(get_libdir)/tclConfig.sh) \
+ $(use_with valgrind valgrind)
+}
+
+src_compile() {
+ # parallel build failure
+ emake -j1
+}
+
+src_install () {
+ einstall \
+ sharedir="${D}"/usr/share \
+ libexecdir="${D}"/usr/lib/misc
+
+ dodoc BUG_FORM COPYRIGHT EPIC4-USERS-README README KNOWNBUGS VOTES
+
+ cd "${S}"/doc || die
+ docinto doc
+ dodoc \
+ *.txt colors EPIC* IRCII_VERSIONS local_vars missing new-load \
+ nicknames outputhelp README.SSL SILLINESS TS4
+}
diff --git a/net-irc/epic5/files/epic5-1.1.2-libarchive-automagic.patch b/net-irc/epic5/files/epic5-1.1.2-libarchive-automagic.patch
new file mode 100644
index 000000000000..522610f9fb57
--- /dev/null
+++ b/net-irc/epic5/files/epic5-1.1.2-libarchive-automagic.patch
@@ -0,0 +1,53 @@
+From: Nathan Phillip Brink <binki@gentoo.org>
+Subject: Prevent libarchive check from being automagic.
+
+--- a/configure.in
++++ b/configure.in
+@@ -231,22 +231,28 @@
+ dnl XXX I don't understand why this is even necessary.
+-have_libarchive=""
+-orig_LIBS="$LIBS"
+-AC_CHECK_LIB(archive, archive_read_new, [LIBS="$LIBS -larchive"])
+-AC_MSG_CHECKING(whether libarchive works the way I expect)
+-AC_TRY_LINK([#include <archive.h>], [
+- struct archive *x;
+- const char *s = "bogus.zip";
+- x = archive_read_new();
+- archive_read_support_format_all(x);
+- archive_read_open_file(x, s, 10240);
+-], have_libarchive="yes")
+-if test "x$have_libarchive" = "x"; then
+- LIBS="$orig_LIBS"
+- AC_MSG_RESULT(no)
+-else
+- AC_MSG_RESULT(yes)
+- AC_DEFINE(HAVE_LIBARCHIVE)
+-fi
++AC_ARG_WITH([libarchive], [AS_HELP_STRING([--without-libarchive], [Disable libarchive support.])],
++ [], [with_libarchive=maybe])
++AS_IF([test "x$with_libarchive" != "xno"],
++ [
++ have_libarchive=""
++ orig_LIBS="$LIBS"
++ AC_CHECK_LIB(archive, archive_read_new, [LIBS="$LIBS -larchive"])
++ AC_MSG_CHECKING(whether libarchive works the way I expect)
++ AC_TRY_LINK([#include <archive.h>], [
++ struct archive *x;
++ const char *s = "bogus.zip";
++ x = archive_read_new();
++ archive_read_support_format_all(x);
++ archive_read_open_file(x, s, 10240);
++ ], have_libarchive="yes")
++ if test "x$have_libarchive" = "x"; then
++ LIBS="$orig_LIBS"
++ AC_MSG_RESULT(no)
++ AS_IF([test "x$with_libarchive" = "xyes"],
++ [AC_MSG_ERROR([--with-libarchive was specified but libarchive could not be found. Please do not specify --with-libarchive or install libarchive.])])
++ else
++ AC_MSG_RESULT(yes)
++ AC_DEFINE(HAVE_LIBARCHIVE)
++ fi])
+
+ dnl -----
+ AC_ARG_WITH(ssl,
+
diff --git a/net-irc/epic5/files/epic5-1.1.2-perl-automagic-as-needed.patch b/net-irc/epic5/files/epic5-1.1.2-perl-automagic-as-needed.patch
new file mode 100644
index 000000000000..e211fa14b275
--- /dev/null
+++ b/net-irc/epic5/files/epic5-1.1.2-perl-automagic-as-needed.patch
@@ -0,0 +1,114 @@
+From: Nathan Phillip Brink <binki@gentoo.org>
+Subject: Fix perl being automagic and to be safe with
+ LDFLAGS=-Wl,--as-needed.
+
+--- a/configure.in
++++ b/configure.in
+@@ -1033,37 +1033,38 @@
+ dnl
+ dnl Perl support?
+ dnl
+-AC_ARG_WITH(perl,
+-[ --with-perl[=PATH_TO_PERL_EXE] Compile with perl support.],
+-[
+- perlexe=$withval
+-],
+- perlexe=yes
+-)
+-
+-if test "x$perlexe" = "xyes"; then
+- perlexe=perl
+-fi
+-
+-if test "x$perlexe" = "xno"; then
++AC_ARG_WITH([perl], [AS_HELP_STRING([--with-perl=[PATH_TO_PERL_EXE]], [Compile with perl support.])],
++ [], [with_perl=maybe])
++AS_IF([test "x$with_perl" = "xno"],
++ [
+ AC_MSG_CHECKING(whether to support Perl)
+ AC_MSG_RESULT(no)
+-else
+- AC_CHECK_PROG(PERLPROG, $perlexe, "yes", "no")
+- AC_MSG_CHECKING(whether to support Perl)
+- if test $PERLPROG != "yes" ; then
++ ],
++ [
++ with_perl_errormsg="You specified --with-perl=$with_perl but I could not find a working perl. Please run ./configure with --without-perl or specify a path to a working perl executable."
++ AS_IF([test "x$with_perl" = "xyes" -o "x$with_perl" = "xmaybe"],
++ [perlexe=perl],
++ [perlexe="$with_perl"])
++ dnl Allow a full path to be specified in --with-perl
++ AS_IF([test -x "$perlexe"],
++ [PERLPROG=yes],
++ [AC_CHECK_PROG(PERLPROG, $perlexe, "yes", "no")])
++ AC_MSG_CHECKING([whether to support Perl])
++ if test $PERLPROG != "yes" ; then
++ AS_IF([test "x$with_perl" != "xmaybe"],
++ [AC_MSG_ERROR([$with_perl_errormsg])])
+ AC_MSG_RESULT(no)
+ else
+ AC_MSG_RESULT(yes)
+ PERLCFLAGS=`$perlexe -MExtUtils::Embed -e ccopts`
+- PERLLDFLAGS=`$perlexe -MExtUtils::Embed -e ldopts`
++ PERLLIBS=`$perlexe -MExtUtils::Embed -e ldopts`
+
+ AC_MSG_CHECKING(whether embedded perl works the way I expect)
+ have_embedded_perl="no"
+ old_CFLAGS="$CFLAGS"
+- old_LDFLAGS="$LDFLAGS"
++ old_LIBS="$LIBS"
+ CFLAGS="$CFLAGS $PERLCFLAGS"
+- LDFLAGS="$LDFLAGS $PERLLDFLAGS"
++ LIBS="$LIBS $PERLLIBS"
+ AC_TRY_RUN([
+ #include <EXTERN.h>
+ #include <perl.h>
+@@ -1101,20 +1102,22 @@
+ have_embedded_perl="no",:)
+
+ CFLAGS="$old_CFLAGS"
+- LDFLAGS="$old_LDFLAGS"
++ LIBS="$old_LIBS"
+ if test $have_embedded_perl = "yes" ; then
+ AC_MSG_RESULT(yes)
+ AC_DEFINE(HAVE_PERL)
+ AC_DEFINE(PERLCFLAGS)
+- AC_DEFINE(PERLLDFLAGS)
++ AC_DEFINE(PERLLIBS)
+ PERLDOTOH="perl.o"
+ else
++ AS_IF([test "x$with_perl" != "xmaybe"],
++ [AC_MSG_ERROR([$with_perl_errormsg])])
+ PERLCFLAGS=""
+- PERLLDFLAGS=""
++ PERLLIBS=""
+ AC_MSG_RESULT(no, sorry)
+ PERLCFLAGS=""
+- PERLLDFLAGS=""
++ PERLLIBS=""
+ fi
+ fi
+-fi
++ ])
+
+@@ -1392,7 +1395,7 @@
+ AC_SUBST(TCLLIBS)
+ AC_SUBST(PERLDOTOH)
+ AC_SUBST(PERLCFLAGS)
+-AC_SUBST(PERLLDFLAGS)
++AC_SUBST(PERLLIBS)
+ AC_SUBST(WSERV_BIN)
+ AC_SUBST(WSERV_INSTALL)
+ AC_SUBST(bindir)
+
+--- a/source/Makefile.in
++++ b/source/Makefile.in
+@@ -38,7 +38,7 @@
+ epic5: $(OBJECTS)
+ sh info.c.sh
+ $(CC) $(CFLAGS) $(INCLUDES) -c info.c
+- $(CC) $(CFLAGS) $(LDFLAGS) -o epic5 $(OBJECTS) info.o @PERLLDFLAGS@ @TCLLIBS@ @RUBYLIBS@ $(LIBS)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o epic5 $(OBJECTS) info.o @PERLLIBS@ @TCLLIBS@ @RUBYLIBS@ $(LIBS)
+ $(RM) info.c info.o
+ clean::
+ $(RM) epic5 $(OBJECTS)
diff --git a/net-irc/epic5/files/epic5-1.1.2-ruby-automagic-as-needed.patch b/net-irc/epic5/files/epic5-1.1.2-ruby-automagic-as-needed.patch
new file mode 100644
index 000000000000..be3568593b90
--- /dev/null
+++ b/net-irc/epic5/files/epic5-1.1.2-ruby-automagic-as-needed.patch
@@ -0,0 +1,126 @@
+From: Nathan Phillip Brink <binki@gentoo.org>
+Subject: Fix up linking against libruby when using
+ LDFLAGS=-Wl,--as-needed. Also allow ruby to be a non-automagic
+ dependency.
+
+--- a/configure.in
++++ b/configure.in
+@@ -1191,34 +1191,32 @@
+ dnl
+ dnl Ruby support?
+ dnl
+-AC_ARG_WITH(ruby,
+-[ --with-ruby[=PATH_TO_RUBY_EXE] Compile with ruby support.],
+-[
+- rubyexe=$withval
+-],
+- rubyexe=yes
+-)
+-
+-if test "x$rubyexe" = "xyes"; then
+- rubyexe=ruby
+-fi
++AC_ARG_WITH([ruby],
++ [AS_HELP_STRING([--with-ruby[=PATH_TO_RUBY_EXE]], [Compile with ruby support.])],
++ [], [with_ruby=maybe])
+
++with_ruby_errormsg="--with-ruby was specified but I could not locate ruby. Please try specifying --with-ruby=/path/to/ruby or --without-ruby."
++AC_MSG_CHECKING([whether to support Ruby])
++if test "x$with_ruby" = "xno" ; then
+-if test "x$rubyexe" = "xno"; then
+- AC_MSG_CHECKING(whether to support Ruby)
+ AC_MSG_RESULT(no)
+ else
++ AC_MSG_RESULT(yes)
++ AS_IF([test "x$with_ruby" = "xyes" -o "x$with_ruby" = "xmaybe"],
++ [rubyexe=ruby],
++ [rubyexe="$with_ruby"])
++ dnl Support --with-ruby being passed a full path instead of just an executable name.
++ AS_IF([test -x "$rubyexe"],
++ [RUBYPROG=yes],
++ [AC_CHECK_PROG([RUBYPROG], [$rubyexe], [yes], [no])])
++ if test "x$RUBYPROG" = xno ; then
++ AS_IF([test "x$with_ruby" != "xmaybe"],
++ [AC_MSG_ERROR([$with_ruby_errormsg])])
+- AC_CHECK_PROG(RUBYPROG, $rubyexe, "yes", "no")
+- AC_MSG_CHECKING(whether to support Ruby)
+- if test $RUBYPROG != "yes" ; then
+- AC_MSG_RESULT(no)
+ else
+- AC_MSG_RESULT(yes)
+-
+ incdir=`$rubyexe -rrbconfig -e 'puts Config::CONFIG[["archdir"]]'`
+ rubylibs=`$rubyexe -rrbconfig -e 'puts Config::CONFIG[["LIBRUBYARG"]]'`
+ extralibs=`$rubyexe -rrbconfig -e 'puts Config::CONFIG[["LIBS"]]'`
+ RUBYCFLAGS="-I$incdir"
+- RUBYLDFLAGS="$rubylibs $extralibs"
++ RUBYLIBS="$rubylibs $extralibs"
+ RUBYDOTOH="ruby.o"
+
+ AC_MSG_CHECKING(whether embedded ruby works the way I expect)
+@@ -1226,7 +1220,7 @@
+ old_CFLAGS="$CFLAGS"
+- old_LDFLAGS="$LDFLAGS"
++ old_LIBS="$LIBS"
+ CFLAGS="$CFLAGS $RUBYCFLAGS"
+- LDFLAGS="$LDFLAGS $RUBYLDFLAGS"
++ LIBS="$LDFLAGS $RUBYLIBS"
+ AC_TRY_LINK([
+ #include <ruby.h>
+ VALUE epic_echo (VALUE module, VALUE string)
+@@ -1251,9 +1245,9 @@
+ AC_MSG_RESULT(no)
+ AC_MSG_CHECKING(whether ruby requires -pthread to link)
+ RUBYCFLAGS="$RUBYCFLAGS -pthread"
+- RUBYLDFLAGS="$RUBYLDFLAGS -pthread"
++ RUBYLIBS="$RUBYLIBS -pthread"
+- CFLAGS="$CFLAGS $RUBYCFLAGS"
+- LDFLAGS="$LDFLAGS $RUBYLDFLAGS"
++ CFLAGS="$old_CFLAGS $RUBYCFLAGS"
++ LIBS="$old_LIBS $RUBYLIBS"
+
+ AC_TRY_LINK([
+ #include <ruby.h>
+@@ -1279,16 +1273,18 @@
+
+ CFLAGS="$old_CFLAGS"
+- LDFLAGS="$old_LDFLAGS"
++ LIBS="$old_LIBS"
+ if test $have_embedded_ruby = "yes" ; then
+ AC_MSG_RESULT(yes)
+ AC_DEFINE(HAVE_RUBY)
+ AC_DEFINE(RUBYCFLAGS)
+- AC_DEFINE(RUBYLDFLAGS)
++ AC_DEFINE(RUBYLIBS)
+ else
++ AS_IF([test "x$with_ruby" != "xmaybe"],
++ [AC_MSG_ERROR([$with_ruby_errormsg])])
+ RUBYDOTOH=""
+ HAVE_RUBY=""
+ RUBYCFLAGS=""
+- RUBYLDFLAGS=""
++ RUBYLIBS=""
+ AC_MSG_RESULT(no, sorry)
+ fi
+ fi
+@@ -1386,7 +1380,7 @@
+ AC_SUBST(LDFLAGS)
+ AC_SUBST(RUBYDOTOH)
+ AC_SUBST(RUBYCFLAGS)
+-AC_SUBST(RUBYLDFLAGS)
++AC_SUBST(RUBYLIBS)
+ AC_SUBST(TCLDOTOH)
+ AC_SUBST(TCLCFLAGS)
+ AC_SUBST(TCLLDFLAGS)
+
+--- a/source/Makefile.in
++++ b/source/Makefile.in
+@@ -38,7 +38,7 @@
+ epic5: $(OBJECTS)
+ sh info.c.sh
+ $(CC) $(CFLAGS) $(INCLUDES) -c info.c
+- $(CC) $(CFLAGS) $(LDFLAGS) -o epic5 $(OBJECTS) info.o @PERLLDFLAGS@ @TCLLDFLAGS@ @RUBYLDFLAGS@ $(LIBS)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o epic5 $(OBJECTS) info.o @PERLLDFLAGS@ @TCLLDFLAGS@ @RUBYLIBS@ $(LIBS)
+ $(RM) info.c info.o
+ clean::
+ $(RM) epic5 $(OBJECTS)
diff --git a/net-irc/epic5/files/epic5-1.1.2-tcl-automagic-as-needed.patch b/net-irc/epic5/files/epic5-1.1.2-tcl-automagic-as-needed.patch
new file mode 100644
index 000000000000..94bf16ef3100
--- /dev/null
+++ b/net-irc/epic5/files/epic5-1.1.2-tcl-automagic-as-needed.patch
@@ -0,0 +1,116 @@
+From: Nathan Phillip Brink <binki@gentoo.org>
+Subject: Make dependence on TCL not be automagic (so that --with-tcl
+ errors out if TCL can't be found and not specifying --with-tcl
+ does the normal automagic behavior). Support
+ LDFLAGS=-Wl,--as-needed by using LIBS instead of LDFLAGS for
+ -ltcl as appropriate.
+
+--- a/configure.in
++++ b/configure.in
+@@ -1122,43 +1122,41 @@
+ dnl
+ dnl Tcl support?
+ dnl
+-AC_ARG_WITH(tcl,
+-[ --with-tcl[=PATH_TO_tclConfig.sh] Compile with tcl support.],
+-[
+- tclconfig=$withval
+-],
+- tclconfig="yes"
+-)
+-
+-if test "x$tclconfig" = "xyes" ; then
+- for i in /usr/lib /usr/local/lib /usr/local/lib/tcl8.4 ; do
+- if test -r $i/tclConfig.sh ; then
+- tclconfig=$i/tclConfig.sh
+- break;
+- fi
+- done
+-fi
++AC_ARG_WITH([tcl], [AS_HELP_STRING([--with-tcl[=PATH_TO_tclConfig.sh]], [Compile with tcl support.])],
++ [], [with_tcl=maybe])
+
+ AC_MSG_CHECKING(whether to support TCL)
+-if test "x$tclconfig" = "xno"; then
++if test "x$with_tcl" = "xno"; then
+ AC_MSG_RESULT(no)
+ else
+- if test ! -r $tclconfig ; then
++ with_tcl_errormsg="You specified --with-tcl=$with_tcl but I could not find TCL. Please specify --with-tcl=/path/to/tclConfig.sh or remove --with-tcl from ./configure's commandline."
++ if test "x$with_tcl" = "xmaybe" -o "x$with_tcl" = "xyes"; then
++ for i in /usr/lib /usr/local/lib /usr/local/lib/tcl8.4 ; do
++ if test -r "$i"/tclConfig.sh ; then
++ tclconfig="$i"/tclConfig.sh
++ break;
++ fi
++ done
++ else
++ tclconfig="$with_tcl"
++ fi
++ if test ! -r "$tclconfig" ; then
++ dnl Avoid being automagic unless if the user wants us to be.
++ AS_IF([test "x$with_tcl" != "xmaybe"],
++ [AC_MSG_ERROR([$with_tcl_errormsg])])
+ AC_MSG_RESULT(no)
+ else
+ AC_MSG_RESULT(yes)
+- TCLCFLAGS=`(. $tclconfig && echo $TCL_INCLUDE_SPEC)`
+- TCLLDFLAGS1=`(. $tclconfig && echo $TCL_LIB_SPEC)`
+- TCLLDFLAGS2=`(. $tclconfig && echo $TCL_LIBS)`
+- TCLLDFLAGS=$(eval echo "$TCLLDFLAGS1 $TCLLDFLAGS2")
++ TCLCFLAGS=`(. "$tclconfig" && echo $TCL_INCLUDE_SPEC)`
++ TCLLIBS=`(. "$tclconfig" && echo $TCL_LIB_SPEC $TCL_LIBS)`
+ TCLDOTOH="tcl.o"
+
+ AC_MSG_CHECKING(whether embedded tcl works the way I expect)
+ have_embedded_tcl="no"
+ old_CFLAGS="$CFLAGS"
+- old_LDFLAGS="$LDFLAGS"
++ old_LIBS="$LIBS"
+ CFLAGS="$CFLAGS $TCLCFLAGS"
+- LDFLAGS="$LDFLAGS $TCLLDFLAGS"
++ LIBS="$LIBS $TCLLIBS"
+ AC_TRY_LINK([
+ #include <tcl.h>
+ Tcl_Interp *my_tcl;
+@@ -1175,14 +1173,16 @@
+ ], have_embedded_tcl="yes")
+
+ CFLAGS="$old_CFLAGS"
+- LDFLAGS="$old_LDFLAGS"
++ LIBS="$old_LIBS"
+ if test $have_embedded_tcl = "yes" ; then
+ AC_MSG_RESULT(yes)
+ AC_DEFINE(HAVE_TCL)
+ AC_DEFINE(TCLCFLAGS)
+- AC_DEFINE(TCLLDFLAGS)
++ AC_DEFINE(TCLLIBS)
+ else
+- AC_MSG_RESULT(no, sorry)
++ AS_IF([test "$with_tcl" != "xmaybe"],
++ [AC_MSG_ERROR([$with_tcl_errormsg])])
++ AC_MSG_RESULT(no, sorry)
+ fi
+ fi
+ fi
+@@ -1383,7 +1383,7 @@
+ AC_SUBST(RUBYLIBS)
+ AC_SUBST(TCLDOTOH)
+ AC_SUBST(TCLCFLAGS)
+-AC_SUBST(TCLLDFLAGS)
++AC_SUBST(TCLLIBS)
+ AC_SUBST(PERLDOTOH)
+ AC_SUBST(PERLCFLAGS)
+ AC_SUBST(PERLLDFLAGS)
+
+--- a/source/Makefile.in
++++ b/source/Makefile.in
+@@ -38,7 +38,7 @@
+ epic5: $(OBJECTS)
+ sh info.c.sh
+ $(CC) $(CFLAGS) $(INCLUDES) -c info.c
+- $(CC) $(CFLAGS) $(LDFLAGS) -o epic5 $(OBJECTS) info.o @PERLLDFLAGS@ @TCLLDFLAGS@ @RUBYLIBS@ $(LIBS)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o epic5 $(OBJECTS) info.o @PERLLDFLAGS@ @TCLLIBS@ @RUBYLIBS@ $(LIBS)
+ $(RM) info.c info.o
+ clean::
+ $(RM) epic5 $(OBJECTS)
diff --git a/net-irc/epic5/metadata.xml b/net-irc/epic5/metadata.xml
index 6ef15e900f17..5e6a8dbf6cd0 100644
--- a/net-irc/epic5/metadata.xml
+++ b/net-irc/epic5/metadata.xml
@@ -1,5 +1,9 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>net-irc</herd>
+ <herd>net-irc</herd>
+ <use>
+ <flag name="archive">Use <pkg>app-arch/libarchive</pkg> to use zip and tar archives from scripts.</flag>
+ <flag name="valgrind">Compile against <pkg>dev-util/valgrind</pkg> headers to improve memory-leak checking when running epic5 under valgrind.</flag>
+ </use>
</pkgmetadata>