summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-05-30 02:01:33 +0000
committerMike Frysinger <vapier@gentoo.org>2004-05-30 02:01:33 +0000
commit9f29553cc61aca975a5d7f7f1891a7dac80987f4 (patch)
treebcc1e4c1d93b92e4481229b9d691c8811993d887 /net-irc/epic4
parentversion bump (Manifest recommit) (diff)
downloadgentoo-2-9f29553cc61aca975a5d7f7f1891a7dac80987f4.tar.gz
gentoo-2-9f29553cc61aca975a5d7f7f1891a7dac80987f4.tar.bz2
gentoo-2-9f29553cc61aca975a5d7f7f1891a7dac80987f4.zip
old
Diffstat (limited to 'net-irc/epic4')
-rw-r--r--net-irc/epic4/epic4-1.1.10.ebuild77
-rw-r--r--net-irc/epic4/epic4-1.1.11.ebuild78
-rw-r--r--net-irc/epic4/epic4-1.1.12.ebuild84
-rw-r--r--net-irc/epic4/files/digest-epic4-1.1.102
-rw-r--r--net-irc/epic4/files/digest-epic4-1.1.112
-rw-r--r--net-irc/epic4/files/digest-epic4-1.1.122
6 files changed, 0 insertions, 245 deletions
diff --git a/net-irc/epic4/epic4-1.1.10.ebuild b/net-irc/epic4/epic4-1.1.10.ebuild
deleted file mode 100644
index a9f234092e40..000000000000
--- a/net-irc/epic4/epic4-1.1.10.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2004 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/epic4/epic4-1.1.10.ebuild,v 1.9 2004/05/29 16:16:27 pvdabeel Exp $
-
-IUSE="ipv6 perl ssl"
-
-DESCRIPTION="Epic4 IRC Client"
-SRC_URI="ftp://prbh.org/pub/epic/EPIC4-ALPHA/${P}.tar.bz2
- ftp://prbh.org/pub/epic/EPIC4-PRODUCTION/epic4-help-20030114.tar.gz"
-HOMEPAGE="http://epicsol.org"
-
-SLOT="0"
-LICENSE="as-is"
-KEYWORDS="x86 ppc"
-
-DEPEND=">=sys-libs/ncurses-5.2
- perl? ( >=dev-lang/perl-5.6.1 )
- ssl? ( >=dev-libs/openssl-0.9.5 )"
-inherit flag-o-matic
-replace-flags "-O?" "-O"
-
-src_compile() {
- myconf=""
-
- use ipv6 \
- && myconf="${myconf} --with-ipv6" \
- || myconf="${myconf} --without-ipv6"
-
- use perl \
- && myconf="${myconf} --with-perl" \
- || myconf="${myconf} --without-perl"
-
- use ssl \
- && myconf="${myconf} --with-ssl" \
- || myconf="${myconf} --without-ssl"
-
-# tcl support not fully functional in 1.1.10 (it is in the latest cvs
-# repository, but that doesn't help us much here.)
-
- myconf="${myconf} --without-tcl"
-
- econf \
- --libexecdir=/usr/lib/misc \
- ${myconf} || die
-
- make || die
-}
-
-src_install () {
- einstall \
- sharedir=${D}/usr/share \
- libexecdir=${D}/usr/lib/misc || die
-
- rm -f ${D}/usr/bin/epic
- dosym epic-EPIC4-${PV} /usr/bin/epic
-
- dodoc BUG_FORM COPYRIGHT README KNOWNBUGS VOTES
- docinto doc
- cd doc
- dodoc *.txt colors EPIC* IRCII_VERSIONS local_vars missing new-load
- dodoc nicknames outputhelp server_groups SILLINESS TS4
-
- dodir /usr/share/epic
- tar zxvf ${DISTDIR}/epic4-help-20030114.tar.gz -C ${D}/usr/share/epic
-}
-
-pkg_postinst() {
- einfo "If /usr/share/epic/script/local does not exist, I will now"
- einfo "create it. If you do not like the look/feel of this file, or"
- einfo "if you'd prefer to use your own script, simply remove this"
- einfo "file. If you want to prevent this file from being installed"
- einfo "in the future, simply create an empty file with this name."
-
- if [ ! -e /usr/share/epic/script/local ]; then
- cp ${FILESDIR}/local /usr/share/epic/script/
- fi
-}
diff --git a/net-irc/epic4/epic4-1.1.11.ebuild b/net-irc/epic4/epic4-1.1.11.ebuild
deleted file mode 100644
index 5e57397d36ff..000000000000
--- a/net-irc/epic4/epic4-1.1.11.ebuild
+++ /dev/null
@@ -1,78 +0,0 @@
-# Copyright 1999-2004 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/epic4/epic4-1.1.11.ebuild,v 1.7 2004/05/29 16:16:27 pvdabeel Exp $
-
-IUSE="ipv6 perl ssl tcltk"
-
-DESCRIPTION="Epic4 IRC Client"
-SRC_URI="ftp://prbh.org/pub/epic/EPIC4-ALPHA/${P}.tar.bz2
- ftp://prbh.org/pub/epic/EPIC4-PRODUCTION/epic4-help-20030114.tar.gz"
-HOMEPAGE="http://epicsol.org"
-
-SLOT="0"
-LICENSE="as-is"
-KEYWORDS="x86 ppc"
-
-DEPEND=">=sys-libs/ncurses-5.2
- perl? ( >=dev-lang/perl-5.6.1 )
- ssl? ( >=dev-libs/openssl-0.9.5 )
- tcltk? ( dev-lang/tcl )"
-
-inherit flag-o-matic
-replace-flags "-O?" "-O"
-
-src_compile() {
- myconf=""
-
- use ipv6 \
- && myconf="${myconf} --with-ipv6" \
- || myconf="${myconf} --without-ipv6"
-
- use perl \
- && myconf="${myconf} --with-perl" \
- || myconf="${myconf} --without-perl"
-
- use ssl \
- && myconf="${myconf} --with-ssl" \
- || myconf="${myconf} --without-ssl"
-
- use tcltk \
- && myconf="${myconf} --with-tcl" \
- || myconf="${myconf} --without-tcl"
-
- econf \
- --libexecdir=/usr/lib/misc \
- ${myconf} || die
-
- make || die
-}
-
-src_install () {
- einstall \
- sharedir=${D}/usr/share \
- libexecdir=${D}/usr/lib/misc || die
-
- rm -f ${D}/usr/bin/epic
- dosym epic-EPIC4-${PV} /usr/bin/epic
-
- dodoc BUG_FORM COPYRIGHT README KNOWNBUGS VOTES
- docinto doc
- cd doc
- dodoc *.txt colors EPIC* IRCII_VERSIONS local_vars missing new-load
- dodoc nicknames outputhelp server_groups SILLINESS TS4
-
- dodir /usr/share/epic
- tar zxvf ${DISTDIR}/epic4-help-20030114.tar.gz -C ${D}/usr/share/epic
-}
-
-pkg_postinst() {
- einfo "If /usr/share/epic/script/local does not exist, I will now"
- einfo "create it. If you do not like the look/feel of this file, or"
- einfo "if you'd prefer to use your own script, simply remove this"
- einfo "file. If you want to prevent this file from being installed"
- einfo "in the future, simply create an empty file with this name."
-
- if [ ! -e /usr/share/epic/script/local ]; then
- cp ${FILESDIR}/local /usr/share/epic/script/
- fi
-}
diff --git a/net-irc/epic4/epic4-1.1.12.ebuild b/net-irc/epic4/epic4-1.1.12.ebuild
deleted file mode 100644
index 96c1dae11cef..000000000000
--- a/net-irc/epic4/epic4-1.1.12.ebuild
+++ /dev/null
@@ -1,84 +0,0 @@
-# Copyright 1999-2004 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/epic4/epic4-1.1.12.ebuild,v 1.10 2004/05/29 16:16:27 pvdabeel Exp $
-
-IUSE="ipv6 perl ssl tcltk"
-
-DESCRIPTION="Epic4 IRC Client"
-SRC_URI="ftp://prbh.org/pub/epic/EPIC4-ALPHA/${P}.tar.bz2
- ftp://prbh.org/pub/epic/EPIC4-PRODUCTION/epic4-help-20030114.tar.gz"
-HOMEPAGE="http://epicsol.org"
-
-SLOT="0"
-LICENSE="as-is"
-KEYWORDS="x86 ppc ia64 ~alpha hppa"
-
-DEPEND=">=sys-libs/ncurses-5.2
- perl? ( >=dev-lang/perl-5.6.1 )
- ssl? ( >=dev-libs/openssl-0.9.5 )
- tcltk? ( dev-lang/tcl )"
-
-inherit flag-o-matic
-replace-flags "-O?" "-O"
-
-src_compile() {
- myconf=""
-
- use ipv6 \
- && myconf="${myconf} --with-ipv6" \
- || myconf="${myconf} --without-ipv6"
-
- use perl \
- && myconf="${myconf} --with-perl" \
- || myconf="${myconf} --without-perl"
-
- use ssl \
- && myconf="${myconf} --with-ssl" \
- || myconf="${myconf} --without-ssl"
-
- use tcltk \
- && myconf="${myconf} --with-tcl" \
- || myconf="${myconf} --without-tcl"
-
- econf \
- --libexecdir=/usr/lib/misc \
- ${myconf} || die
-
- make || die
-}
-
-src_install () {
- einstall \
- sharedir=${D}/usr/share \
- libexecdir=${D}/usr/lib/misc || die
-
- rm -f ${D}/usr/bin/epic
- dosym epic-EPIC4-${PV} /usr/bin/epic
-
- dodoc BUG_FORM COPYRIGHT README KNOWNBUGS VOTES
- docinto doc
- cd doc
- dodoc *.txt colors EPIC* IRCII_VERSIONS local_vars missing new-load
- dodoc nicknames outputhelp server_groups SILLINESS TS4
-
- dodir /usr/share/epic
- tar zxvf ${DISTDIR}/epic4-help-20030114.tar.gz -C ${D}/usr/share/epic
-
- # Fix for bug 33235.
- rm -rf ${D}/usr/share/epic/help/CVS
- rm -f ${D}/usr/share/epic/help/Makefile
-
- chown -R root:root ${D}/usr/share/epic/help
-}
-
-pkg_postinst() {
- einfo "If /usr/share/epic/script/local does not exist, I will now"
- einfo "create it. If you do not like the look/feel of this file, or"
- einfo "if you'd prefer to use your own script, simply remove this"
- einfo "file. If you want to prevent this file from being installed"
- einfo "in the future, simply create an empty file with this name."
-
- if [ ! -e /usr/share/epic/script/local ]; then
- cp ${FILESDIR}/local /usr/share/epic/script/
- fi
-}
diff --git a/net-irc/epic4/files/digest-epic4-1.1.10 b/net-irc/epic4/files/digest-epic4-1.1.10
deleted file mode 100644
index ab53c75c5b32..000000000000
--- a/net-irc/epic4/files/digest-epic4-1.1.10
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 57f91ca05406ad9ac04f4cd7b385c93d epic4-1.1.10.tar.bz2 557196
-MD5 f4220b4cf989e320fbbd6051c5117307 epic4-help-20030114.tar.gz 287157
diff --git a/net-irc/epic4/files/digest-epic4-1.1.11 b/net-irc/epic4/files/digest-epic4-1.1.11
deleted file mode 100644
index 3a766b955f7e..000000000000
--- a/net-irc/epic4/files/digest-epic4-1.1.11
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 5d2099866d1fc4cb697ef6939cfa9a14 epic4-1.1.11.tar.bz2 574742
-MD5 f4220b4cf989e320fbbd6051c5117307 epic4-help-20030114.tar.gz 287157
diff --git a/net-irc/epic4/files/digest-epic4-1.1.12 b/net-irc/epic4/files/digest-epic4-1.1.12
deleted file mode 100644
index c3b5400b2cb2..000000000000
--- a/net-irc/epic4/files/digest-epic4-1.1.12
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 dd56e54e3530c281e25929924911fd46 epic4-1.1.12.tar.bz2 578986
-MD5 f4220b4cf989e320fbbd6051c5117307 epic4-help-20030114.tar.gz 287157