summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Legler <a3li@gentoo.org>2009-08-02 19:27:35 +0000
committerAlex Legler <a3li@gentoo.org>2009-08-02 19:27:35 +0000
commite0520721ee983f178b922854b17e53421a2f5834 (patch)
tree1b40781eeabc852c88e7c52190bec7f76d043672 /net-irc/eggdrop
parentVersion bump (diff)
downloadgentoo-2-e0520721ee983f178b922854b17e53421a2f5834.tar.gz
gentoo-2-e0520721ee983f178b922854b17e53421a2f5834.tar.bz2
gentoo-2-e0520721ee983f178b922854b17e53421a2f5834.zip
Non-maintainer commit: Version bump for security bug 270221. Also closes bump request 222483.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'net-irc/eggdrop')
-rw-r--r--net-irc/eggdrop/ChangeLog8
-rw-r--r--net-irc/eggdrop/eggdrop-1.6.19.ebuild111
2 files changed, 118 insertions, 1 deletions
diff --git a/net-irc/eggdrop/ChangeLog b/net-irc/eggdrop/ChangeLog
index ac1242237688..e860813d0072 100644
--- a/net-irc/eggdrop/ChangeLog
+++ b/net-irc/eggdrop/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-irc/eggdrop
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/eggdrop/ChangeLog,v 1.79 2009/07/30 17:09:31 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/eggdrop/ChangeLog,v 1.80 2009/08/02 19:27:35 a3li Exp $
+
+*eggdrop-1.6.19 (02 Aug 2009)
+
+ 02 Aug 2009; Alex Legler <a3li@gentoo.org> +eggdrop-1.6.19.ebuild:
+ Non-maintainer commit: Version bump for security bug 270221. Also closes
+ bump request 222483.
30 Jul 2009; Diego E. Pettenò <flameeyes@gentoo.org>
eggdrop-1.6.18-r3.ebuild:
diff --git a/net-irc/eggdrop/eggdrop-1.6.19.ebuild b/net-irc/eggdrop/eggdrop-1.6.19.ebuild
new file mode 100644
index 000000000000..63158b4cbaa5
--- /dev/null
+++ b/net-irc/eggdrop/eggdrop-1.6.19.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/eggdrop/eggdrop-1.6.19.ebuild,v 1.1 2009/08/02 19:27:35 a3li Exp $
+
+inherit eutils
+
+MY_P="eggdrop${PV}"
+PATCHSET_V="1.0"
+
+DESCRIPTION="An IRC bot extensible with C or Tcl."
+HOMEPAGE="http://www.eggheads.org/"
+SRC_URI="ftp://ftp.eggheads.org/pub/eggdrop/source/1.6/${MY_P}.tar.bz2
+ mirror://gentoo/${P}-patches-${PATCHSET_V}.tar.bz2"
+KEYWORDS="~alpha ~amd64 ~ia64 ~mips ~ppc ~sparc ~x86"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="debug static mysql postgres ssl vanilla"
+
+DEPEND="dev-lang/tcl
+ !vanilla? (
+ mysql? ( virtual/mysql )
+ postgres? ( virtual/postgresql-server )
+ ssl? ( dev-libs/openssl )
+ )"
+
+S="${WORKDIR}"/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ if use vanilla
+ then
+ elog "Excluding patches, that install additional modules. This effectively"
+ elog "disables the mysql, postgres and ssl USE flags."
+ echo
+ rm -f "${WORKDIR}"/patch/[1-8]*.patch
+ fi
+
+ EPATCH_SUFFIX="patch" epatch || die "epatch failed"
+}
+
+src_compile() {
+ local target=""
+
+ use mysql || ( echo mysql ; echo mystats ) >>disabled_modules
+ use postgres || echo pgstats >>disabled_modules
+ use static && ( echo rijndael ; echo twofish ) >>disabled_modules
+
+ econf $(use_with ssl) || die "econf failed"
+
+ make config || die "module config failed"
+
+ if use static && use debug
+ then
+ target="sdebug"
+ elif use static
+ then
+ target="static"
+ elif use debug
+ then
+ target="debug"
+ fi
+
+ emake -j1 ${target} || die "emake ${target} failed"
+}
+
+src_install() {
+ local a b
+ emake -j1 DEST="${D}"/opt/eggdrop install || die "make install failed"
+
+ for a in doc/*
+ do
+ [ -f ${a} ] && dodoc ${a}
+ done
+
+ cd "${S}"/src/mod
+ for a in *.mod
+ do
+ for b in README UPDATES INSTALL TODO CONTENTS
+ do
+ [[ -f ${a}/${b} ]] && newdoc ${a}/${b} ${b}.${a}
+ done
+ done
+
+ cd "${S}"
+
+ dodoc text/motd.*
+
+ use vanilla || dodoc \
+ src/mod/botnetop.mod/botnetop.conf \
+ src/mod/gseen.mod/gseen.conf \
+ src/mod/mc_greet.mod/mc_greet.conf \
+ src/mod/stats.mod/stats.conf \
+ src/mod/away.mod/away.doc \
+ src/mod/rcon.mod/matchbot.tcl \
+ src/mod/mystats.mod/tools/mystats.{conf,sql} \
+ src/mod/pgstats.mod/tools/{pgstats.conf,setup.sql}
+
+ dohtml doc/html/*.html
+
+ dobin "${FILESDIR}"/eggdrop-installer
+ doman doc/man1/eggdrop.1
+}
+
+pkg_postinst() {
+ elog
+ elog "NOTE: IPV6 support has been dropped by upstream maintainers."
+ elog "Please run /usr/bin/eggdrop-installer to install your eggdrop bot."
+ elog
+}