summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2009-06-16 23:26:45 +0000
committerTony Vroon <chainsaw@gentoo.org>2009-06-16 23:26:45 +0000
commit2a6bce26ae618c37f3b6b847f9edbb1ee9737e1a (patch)
treefc9c2a1011d46f6fec50dbbc6b3eb09be727f8fe /net-irc/conspire
parentAdd Conspire to the atheme alpha/beta mask, move it up to the start where it ... (diff)
downloadgentoo-2-2a6bce26ae618c37f3b6b847f9edbb1ee9737e1a.tar.gz
gentoo-2-2a6bce26ae618c37f3b6b847f9edbb1ee9737e1a.tar.bz2
gentoo-2-2a6bce26ae618c37f3b6b847f9edbb1ee9737e1a.zip
Masked beta release, containing DCC64 support, a more extensive CTCP command set and new tango icons.
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'net-irc/conspire')
-rw-r--r--net-irc/conspire/ChangeLog10
-rw-r--r--net-irc/conspire/conspire-1.0_beta1.ebuild44
2 files changed, 52 insertions, 2 deletions
diff --git a/net-irc/conspire/ChangeLog b/net-irc/conspire/ChangeLog
index 98dfaabeb267..eb197ca9fae6 100644
--- a/net-irc/conspire/ChangeLog
+++ b/net-irc/conspire/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-irc/conspire
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/conspire/ChangeLog,v 1.10 2008/10/31 13:14:41 chainsaw Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/conspire/ChangeLog,v 1.11 2009/06/16 23:26:45 chainsaw Exp $
+
+*conspire-1.0_beta1 (16 Jun 2009)
+
+ 16 Jun 2009; <chainsaw@gentoo.org> +conspire-1.0_beta1.ebuild:
+ Masked beta release, containing DCC64 support, a more extensive CTCP
+ command set and new tango icons.
31 Oct 2008; <chainsaw@gentoo.org> +files/0.20-de798c3d89ea.diff,
conspire-0.20.ebuild:
diff --git a/net-irc/conspire/conspire-1.0_beta1.ebuild b/net-irc/conspire/conspire-1.0_beta1.ebuild
new file mode 100644
index 000000000000..02c26ccf6798
--- /dev/null
+++ b/net-irc/conspire/conspire-1.0_beta1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/conspire/conspire-1.0_beta1.ebuild,v 1.1 2009/06/16 23:26:45 chainsaw Exp $
+
+inherit eutils
+
+MY_P="${P/_/-}"
+S="${WORKDIR}/${MY_P}"
+DESCRIPTION="A high quality IRC client which uses a multitude of interfaces"
+HOMEPAGE="http://www.nenolod.net/conspire/"
+SRC_URI="http://distfiles.atheme.org/${MY_P}.tgz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~sparc ~x86"
+IUSE="python gnutls ipv6 nls mmx socks5 dbus"
+DEPEND="nls? ( dev-util/intltool )
+ dev-util/pkgconfig"
+RDEPEND=">=dev-libs/libmowgli-0.6.0
+ >=x11-libs/gtk+-2.10
+ >=dev-libs/glib-2.14
+ x11-libs/libnotify
+ x11-libs/libsexy
+ dbus? ( >=dev-libs/dbus-glib-0.60 )
+ python? ( >=dev-lang/python-2.2 )"
+
+src_compile() {
+ econf \
+ $(use_enable socks5 socks) \
+ $(use_enable ipv6) \
+ $(use_enable gnutls) \
+ $(use_enable python) \
+ $(use_enable mmx) \
+ $(use_enable nls) \
+ $(use_enable dbus) \
+ --enable-spell=libsexy \
+ --enable-regex \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc NEWS TODO
+}