summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Ullmann <jokey@gentoo.org>2007-09-06 13:46:22 +0000
committerMarkus Ullmann <jokey@gentoo.org>2007-09-06 13:46:22 +0000
commiteeb1f894a7eed3d49b8b58b3502ddf6357d34830 (patch)
tree2054cac0bcf5ecad46115045b8e4dbfb65393862 /net-irc/charybdis/charybdis-2.1.5.ebuild
parentVersion bump (diff)
downloadgentoo-2-eeb1f894a7eed3d49b8b58b3502ddf6357d34830.tar.gz
gentoo-2-eeb1f894a7eed3d49b8b58b3502ddf6357d34830.tar.bz2
gentoo-2-eeb1f894a7eed3d49b8b58b3502ddf6357d34830.zip
Version bump and cleanup
(Portage version: 2.1.3.7)
Diffstat (limited to 'net-irc/charybdis/charybdis-2.1.5.ebuild')
-rw-r--r--net-irc/charybdis/charybdis-2.1.5.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/net-irc/charybdis/charybdis-2.1.5.ebuild b/net-irc/charybdis/charybdis-2.1.5.ebuild
new file mode 100644
index 000000000000..4b2d814914c8
--- /dev/null
+++ b/net-irc/charybdis/charybdis-2.1.5.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/charybdis/charybdis-2.1.5.ebuild,v 1.1 2007/09/06 13:46:22 jokey Exp $
+
+inherit eutils
+
+DESCRIPTION="A non-monolithic ircd loosely based on ircd-ratbox"
+HOMEPAGE="http://www.ircd-charybdis.org/"
+SRC_URI="http://www.ircd-charybdis.org/release/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="ipv6 ssl debug smallnet zlib static"
+
+DEPEND="zlib? ( sys-libs/zlib )
+ ssl? ( dev-libs/openssl )"
+
+pkg_setup() {
+ enewuser ircd
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-dircreate.patch
+}
+
+src_compile() {
+ econf \
+ $(use_enable ipv6) \
+ $(use_enable ssl openssl) \
+ $(use_enable debug assert) \
+ $(use_enable smallnet small-net) \
+ $(use_enable zlib) \
+ $(use_enable !static shared-modules) \
+ --with-confdir=/etc/charybdis \
+ --with-logdir=/var/log/charybdis \
+ --with-helpdir=/usr/share/charybdis/help \
+ --with-moduledir=/usr/lib/charybdis \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+}