summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Legler <a3li@gentoo.org>2009-08-27 18:44:57 +0000
committerAlex Legler <a3li@gentoo.org>2009-08-27 18:44:57 +0000
commit8ffa2bcc1289e4a743b06b95e7a3f7d7d87bd1d9 (patch)
tree0d4fac74365c32bcd1529d7ccdea67985df9d420 /net-irc/bip
parentMark -sparc since it needs xulrunner-1.9.1 and doesn't compile on sparc (diff)
downloadgentoo-2-8ffa2bcc1289e4a743b06b95e7a3f7d7d87bd1d9.tar.gz
gentoo-2-8ffa2bcc1289e4a743b06b95e7a3f7d7d87bd1d9.tar.bz2
gentoo-2-8ffa2bcc1289e4a743b06b95e7a3f7d7d87bd1d9.zip
Version bump.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'net-irc/bip')
-rw-r--r--net-irc/bip/ChangeLog9
-rw-r--r--net-irc/bip/bip-0.8.1.ebuild4
-rw-r--r--net-irc/bip/bip-0.8.2.ebuild (renamed from net-irc/bip/bip-0.8.0.ebuild)15
-rw-r--r--net-irc/bip/files/bip-configure-oidentd.patch (renamed from net-irc/bip/files/bip-0.8.1-configure-oidentd.patch)0
4 files changed, 20 insertions, 8 deletions
diff --git a/net-irc/bip/ChangeLog b/net-irc/bip/ChangeLog
index 40bd7dd8b6cf..7ee7507d949f 100644
--- a/net-irc/bip/ChangeLog
+++ b/net-irc/bip/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-irc/bip
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/bip/ChangeLog,v 1.7 2009/07/31 18:51:29 a3li Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/bip/ChangeLog,v 1.8 2009/08/27 18:44:57 a3li Exp $
+
+*bip-0.8.2 (27 Aug 2009)
+
+ 27 Aug 2009; Alex Legler <a3li@gentoo.org> -bip-0.8.0.ebuild,
+ bip-0.8.1.ebuild, -files/bip-0.8.1-configure-oidentd.patch,
+ +bip-0.8.2.ebuild, +files/bip-configure-oidentd.patch:
+ Version bump, renaming patch, removing old version.
*bip-0.8.1 (31 Jul 2009)
diff --git a/net-irc/bip/bip-0.8.1.ebuild b/net-irc/bip/bip-0.8.1.ebuild
index 4af1a2ba8619..ea200bff9b55 100644
--- a/net-irc/bip/bip-0.8.1.ebuild
+++ b/net-irc/bip/bip-0.8.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/bip/bip-0.8.1.ebuild,v 1.1 2009/07/31 18:51:29 a3li Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/bip/bip-0.8.1.ebuild,v 1.2 2009/08/27 18:44:57 a3li Exp $
EAPI="2"
@@ -23,7 +23,7 @@ RDEPEND="${DEPEND}
src_prepare() {
# configure broken: --disable-oidentd enables it, too
- epatch "${FILESDIR}/${P}-configure-oidentd.patch"
+ epatch "${FILESDIR}/${PN}-configure-oidentd.patch"
eautoreconf
}
diff --git a/net-irc/bip/bip-0.8.0.ebuild b/net-irc/bip/bip-0.8.2.ebuild
index 86c355a7bdb8..9d002fca9030 100644
--- a/net-irc/bip/bip-0.8.0.ebuild
+++ b/net-irc/bip/bip-0.8.2.ebuild
@@ -1,9 +1,11 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/bip/bip-0.8.0.ebuild,v 1.1 2009/03/23 15:58:15 a3li Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/bip/bip-0.8.2.ebuild,v 1.1 2009/08/27 18:44:57 a3li Exp $
EAPI="2"
+inherit autotools
+
DESCRIPTION="Multiuser IRC proxy with ssl support"
HOMEPAGE="http://bip.t1r.net/"
SRC_URI="http://bip.t1r.net/downloads/${P}.tar.gz"
@@ -19,15 +21,18 @@ RDEPEND="${DEPEND}
app-editors/gvim ) )
oidentd? ( >=net-misc/oidentd-2.0 )"
-src_configure() {
+src_prepare() {
# configure broken: --disable-oidentd enables it, too
- local my_conf
- use oidentd && my_conf="--enable-oidentd"
+ epatch "${FILESDIR}/${PN}-configure-oidentd.patch"
+ eautoreconf
+}
+
+src_configure() {
econf \
$(use_enable ssl openssl)\
$(use_enable debug)\
- ${my_conf}
+ $(use_enable oidentd)
}
src_compile() {
diff --git a/net-irc/bip/files/bip-0.8.1-configure-oidentd.patch b/net-irc/bip/files/bip-configure-oidentd.patch
index 787129981658..787129981658 100644
--- a/net-irc/bip/files/bip-0.8.1-configure-oidentd.patch
+++ b/net-irc/bip/files/bip-configure-oidentd.patch