summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeff Horelick <jdhore@gentoo.org>2012-02-21 00:11:34 +0000
committerJeff Horelick <jdhore@gentoo.org>2012-02-21 00:11:34 +0000
commit962486c7aaecec62a84b7e7c2f8a9e9286a5d1b0 (patch)
treeae6fb3cb35d5d4981f02e2b4ecf40e6531a2b0f1 /net-irc/atheme-services
parentWe only use libappindicator if building against gtk3. (diff)
downloadgentoo-2-962486c7aaecec62a84b7e7c2f8a9e9286a5d1b0.tar.gz
gentoo-2-962486c7aaecec62a84b7e7c2f8a9e9286a5d1b0.tar.bz2
gentoo-2-962486c7aaecec62a84b7e7c2f8a9e9286a5d1b0.zip
Added live ebuild. So many Atheme users run from git (including myself), this way they can have a convenient way to do so.
(Portage version: 2.2.0_alpha88/cvs/Linux i686)
Diffstat (limited to 'net-irc/atheme-services')
-rw-r--r--net-irc/atheme-services/ChangeLog8
-rw-r--r--net-irc/atheme-services/atheme-services-9999.ebuild116
2 files changed, 123 insertions, 1 deletions
diff --git a/net-irc/atheme-services/ChangeLog b/net-irc/atheme-services/ChangeLog
index d56733a48a93..1453d941dc10 100644
--- a/net-irc/atheme-services/ChangeLog
+++ b/net-irc/atheme-services/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-irc/atheme-services
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/atheme-services/ChangeLog,v 1.32 2012/02/08 21:46:13 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/atheme-services/ChangeLog,v 1.33 2012/02/21 00:11:34 jdhore Exp $
+
+*atheme-services-9999 (21 Feb 2012)
+
+ 21 Feb 2012; Jeff Horelick <jdhore@gentoo.org> +atheme-services-9999.ebuild:
+ Added live ebuild. So many Atheme users run from git (including myself), this
+ way they can have a convenient way to do so.
08 Feb 2012; Jeff Horelick <jdhore@gentoo.org>
atheme-services-6.0.9-r1.ebuild:
diff --git a/net-irc/atheme-services/atheme-services-9999.ebuild b/net-irc/atheme-services/atheme-services-9999.ebuild
new file mode 100644
index 000000000000..440663628da6
--- /dev/null
+++ b/net-irc/atheme-services/atheme-services-9999.ebuild
@@ -0,0 +1,116 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/atheme-services/atheme-services-9999.ebuild,v 1.1 2012/02/21 00:11:34 jdhore Exp $
+
+EAPI=4
+
+inherit git-2 user flag-o-matic perl-module
+
+MY_P=${P/_/-}
+
+DESCRIPTION="A portable and secure set of open-source and modular IRC services"
+HOMEPAGE="http://atheme.net/"
+EGIT_REPO_URI="git://git.atheme.org/atheme.git"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS=""
+IUSE="cracklib largenet ldap nls +pcre perl profile ssl"
+
+RDEPEND="=dev-libs/libmowgli-9999:2
+ cracklib? ( sys-libs/cracklib )
+ ldap? ( net-nds/openldap )
+ nls? ( sys-devel/gettext )
+ perl? ( dev-lang/perl )
+ pcre? ( dev-libs/libpcre )
+ ssl? ( dev-libs/openssl )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+pkg_setup() {
+ # the dependency calculation puts all of the .c files together and
+ # overwhelms cc1 with this flag :-(
+ filter-flags -combine
+
+ if use profile; then
+ # bug #371119
+ ewarn "USE=\"profile\" is incompatible with the hardened profile's -pie flag."
+ ewarn "Disabling PIE. Please ignore any warning messages about -nopie being invalid."
+ append-flags -nopie
+ fi
+
+ enewgroup ${PN}
+ enewuser ${PN} -1 -1 /var/lib/atheme ${PN}
+}
+
+# To stop perl-module overriding this function
+src_unpack() {
+ git-2_src_unpack
+}
+
+src_prepare() {
+ # fix docdir
+ sed -i -e 's/\(^DOCDIR.*=.\)@DOCDIR@/\1@docdir@/' extra.mk.in || die
+
+ # basic logging config directive fix
+ sed -i -e '/^logfile/s;var/\(.*\.log\);'"${EPREFIX}"'/var/log/atheme/\1;g' dist/* || die
+
+ # QA against bundled libs.
+ # But comment it out in the live ebuild
+ # because it only contains a git submodule
+ # and removing it MAY break everything.
+ #rm -rf libmowgli-2 || die
+
+ # Get useful information into build.log
+ sed -i -e '/^\.SILENT:$/d' buildsys.mk.in || die
+}
+
+src_configure() {
+ econf \
+ atheme_cv_c_gcc_w_error_implicit_function_declaration=no \
+ --sysconfdir="${EPREFIX}"/etc/${PN} \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF} \
+ --localstatedir="${EPREFIX}"/var \
+ --enable-fhs-paths \
+ --disable-warnings \
+ --enable-contrib \
+ $(use_enable largenet large-net) \
+ $(use_with cracklib) \
+ $(use_with ldap) \
+ $(use_with nls) \
+ $(use_enable profile) \
+ $(use_with perl) \
+ $(use_with pcre) \
+ $(use_enable ssl)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ insinto /etc/${PN}
+ for conf in dist/*.example; do
+ # The .cron file isn't meant to live in /etc/${PN}, so only
+ # install a .example version.
+ [[ ${conf} == *cron* ]] && continue
+
+ newins ${conf} $(basename ${conf} .example)
+ done
+
+ fowners -R 0:${PN} /etc/${PN}
+ keepdir /var/{lib,log}/atheme
+ fowners ${PN}:${PN} /var/{lib,log,run}/atheme
+ fperms -R go-w,o-rx /etc/${PN}
+ fperms 750 /etc/${PN} /var/{lib,log,run}/atheme
+
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+
+ # contributed scripts and such:
+ insinto /usr/share/doc/${PF}/contrib
+ doins contrib/*.{c,pl,php,py,rb}
+
+ if use perl; then
+ perlinfo
+ insinto "${VENDOR_LIB#${EPREFIX}}"
+ doins -r contrib/Atheme{,.pm}
+ fi
+}