summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNathan Phillip Brink <binki@gentoo.org>2011-06-08 00:45:35 +0000
committerNathan Phillip Brink <binki@gentoo.org>2011-06-08 00:45:35 +0000
commit8a320f2a71cb51ffaa69077debfd05d4e9c8c533 (patch)
tree899665ebabac56a51361d44dea9df7208b358d7e /net-irc/atheme-services
parentVersion bumped. Fixed static-libs handling. Added lzo and gcrypt USE flags. (diff)
downloadgentoo-2-8a320f2a71cb51ffaa69077debfd05d4e9c8c533.tar.gz
gentoo-2-8a320f2a71cb51ffaa69077debfd05d4e9c8c533.tar.bz2
gentoo-2-8a320f2a71cb51ffaa69077debfd05d4e9c8c533.zip
Rename net-irc/atheme to net-irc/atheme-services to follow upstream's package name change.
(Portage version: 2.2.0_alpha37-r1/cvs/Linux x86_64)
Diffstat (limited to 'net-irc/atheme-services')
-rw-r--r--net-irc/atheme-services/ChangeLog15
-rw-r--r--net-irc/atheme-services/atheme-services-0.2.2.ebuild89
-rw-r--r--net-irc/atheme-services/atheme-services-1.2.1.ebuild86
-rw-r--r--net-irc/atheme-services/files/atheme-1.2.1-postgresl.patch99
-rw-r--r--net-irc/atheme-services/files/atheme.initd20
-rw-r--r--net-irc/atheme-services/files/make-postgresql-support-optional.patch99
-rw-r--r--net-irc/atheme-services/files/makefile-DESTDIR-support.patch145
-rw-r--r--net-irc/atheme-services/metadata.xml8
8 files changed, 561 insertions, 0 deletions
diff --git a/net-irc/atheme-services/ChangeLog b/net-irc/atheme-services/ChangeLog
new file mode 100644
index 000000000000..dbe6316d6146
--- /dev/null
+++ b/net-irc/atheme-services/ChangeLog
@@ -0,0 +1,15 @@
+# ChangeLog for net-irc/atheme-services
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/atheme-services/ChangeLog,v 1.1 2011/06/08 00:45:34 binki Exp $
+
+*atheme-services-1.2.1 (08 Jun 2011)
+*atheme-services-0.2.2 (08 Jun 2011)
+
+ 08 Jun 2011; Nathan Phillip Brink <binki@gentoo.org>
+ +atheme-services-0.2.2.ebuild, +atheme-services-1.2.1.ebuild,
+ +files/atheme-1.2.1-postgresl.patch, +files/atheme.initd,
+ +files/make-postgresql-support-optional.patch,
+ +files/makefile-DESTDIR-support.patch, +metadata.xml:
+ Rename net-irc/atheme to net-irc/atheme-services to follow upstream's
+ package name change.
+
diff --git a/net-irc/atheme-services/atheme-services-0.2.2.ebuild b/net-irc/atheme-services/atheme-services-0.2.2.ebuild
new file mode 100644
index 000000000000..150e1da2f8c9
--- /dev/null
+++ b/net-irc/atheme-services/atheme-services-0.2.2.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/atheme-services/atheme-services-0.2.2.ebuild,v 1.1 2011/06/08 00:45:34 binki Exp $
+
+inherit eutils autotools
+
+DESCRIPTION="A portable, secure set of open source, and modular IRC services"
+HOMEPAGE="http://www.atheme.net/"
+SRC_URI="http://distfiles.atheme.org/atheme-${PV}.tgz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~sparc ~x86 ~x86-fbsd"
+IUSE="largenet postgres"
+
+RDEPEND="postgres? ( dev-db/postgresql-server )"
+DEPEND="${RDEPEND}
+ >=sys-devel/autoconf-2.59"
+
+S=${WORKDIR}/atheme-${PV}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch ${FILESDIR}/make-postgresql-support-optional.patch || die "epacth failed"
+ epatch ${FILESDIR}/makefile-DESTDIR-support.patch || die "epatch failed"
+
+ eautoreconf
+}
+
+src_compile() {
+ econf \
+ --prefix=/var/lib/atheme \
+ $(use_with postgresql) \
+ $(use_with largenet large-net) \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ local dir
+
+ make DESTDIR="${D}" install || die "make install failed"
+
+ dodir /{etc,usr/{lib,share}}/atheme
+ keepdir /var/lib/atheme/var
+ fowners atheme:atheme /etc/atheme /var/lib/atheme/var
+ fperms 750 /etc/atheme /var/lib/atheme/var
+
+ for dir in backend contrib modules protocol
+ do
+ mv "${D}"/var/lib/atheme/${dir} "${D}"/usr/lib/atheme
+ dosym /usr/lib/atheme/${dir} /var/lib/atheme
+ done
+
+ mv "${D}"/var/lib/atheme/help "${D}"/usr/share/atheme
+ dosym /usr/share/atheme/help /var/lib/atheme
+
+ mv "${D}"/var/lib/atheme/etc/example.conf ${D}/etc/atheme/atheme.conf
+ fowners root:atheme /etc/atheme/atheme.conf
+ fperms 640 /etc/atheme/atheme.conf
+
+ rm -rf "${D}"/var/lib/atheme/etc
+ dosym /etc/atheme /var/lib/atheme/etc
+
+ dobin "${D}"/var/lib/atheme/bin/atheme || die "dobin failed"
+
+ dodoc \
+ ChangeLog INSTALL README \
+ doc/{example_module.c,LICENSE,POSTGRESQL,RELEASE,ROADMAP} \
+ || die "dodoc failed"
+
+ newinitd "${FILESDIR}"/atheme.initd atheme
+
+ # And remove stuff we don't need
+ rm -rf "${D}"/var/lib/atheme/{bin,doc}
+}
+
+pkg_setup() {
+ enewgroup atheme
+ enewuser atheme -1 -1 /var/lib/atheme atheme
+}
+
+pkg_postinst() {
+ elog
+ elog "Don't forget to edit /etc/atheme/atheme.conf!"
+ elog
+}
diff --git a/net-irc/atheme-services/atheme-services-1.2.1.ebuild b/net-irc/atheme-services/atheme-services-1.2.1.ebuild
new file mode 100644
index 000000000000..a38d4c7b9ade
--- /dev/null
+++ b/net-irc/atheme-services/atheme-services-1.2.1.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/atheme-services/atheme-services-1.2.1.ebuild,v 1.1 2011/06/08 00:45:34 binki Exp $
+
+inherit eutils autotools
+
+DESCRIPTION="A portable, secure set of open source, and modular IRC services"
+HOMEPAGE="http://www.atheme.net/"
+SRC_URI="http://distfiles.atheme.org/atheme-${PV}.tgz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~sparc ~x86 ~x86-fbsd"
+IUSE="largenet postgres"
+
+RDEPEND="postgres? ( dev-db/postgresql-server )"
+DEPEND="${RDEPEND}
+ >=sys-devel/autoconf-2.59"
+
+S=${WORKDIR}/atheme-${PV}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/atheme-1.2.1-postgresl.patch
+
+ eautoreconf
+}
+
+src_compile() {
+ econf \
+ --prefix=/var/lib/atheme \
+ $(use_enable postgresql) \
+ $(use_with largenet large-net) \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make prefix="${D}"/var/lib/atheme install || die "make install failed"
+
+ dodir /usr/{lib,share}/atheme /etc
+ keepdir /var/lib/atheme/var
+ fowners atheme:atheme /var/lib/atheme/var
+ fperms 750 /var/lib/atheme/var
+
+ local dir
+ for dir in backend crypto modules protocol
+ do
+ mv "${D}"/var/lib/atheme/${dir} "${D}"/usr/lib/atheme
+ dosym /usr/lib/atheme/${dir} /var/lib/atheme/${dir}
+ done
+
+ mv "${D}"/var/lib/atheme/help "${D}"/usr/share/atheme
+ dosym /usr/share/atheme/help /var/lib/atheme/help
+
+ mv "${D}"/var/lib/atheme/etc "${D}"/etc/atheme
+ cp "${D}"/etc/atheme/example.conf "${D}"/etc/atheme/atheme.conf
+ fowners root:atheme /etc/atheme/atheme.conf
+ fperms 640 /etc/atheme/atheme.conf
+ dosym /etc/atheme /var/lib/atheme/etc
+
+ dobin "${D}"/var/lib/atheme/bin/atheme || die "dobin failed"
+
+ dodoc \
+ ChangeLog INSTALL README \
+ doc/{example_module.c,LICENSE,SQL,RELEASE} \
+ || die "dodoc failed"
+
+ newinitd "${FILESDIR}"/atheme.initd atheme
+
+ # And remove stuff we don't need
+ rm -rf "${D}"/var/lib/atheme/{bin,doc}
+}
+
+pkg_setup() {
+ enewgroup atheme
+ enewuser atheme -1 -1 /var/lib/atheme atheme
+}
+
+pkg_postinst() {
+ elog
+ elog "Don't forget to edit /etc/atheme/atheme.conf!"
+ elog
+}
diff --git a/net-irc/atheme-services/files/atheme-1.2.1-postgresl.patch b/net-irc/atheme-services/files/atheme-1.2.1-postgresl.patch
new file mode 100644
index 000000000000..a5ffdcb3d249
--- /dev/null
+++ b/net-irc/atheme-services/files/atheme-1.2.1-postgresl.patch
@@ -0,0 +1,99 @@
+diff -Nur atheme-1.2.1.orig/configure.ac atheme-1.2.1/configure.ac
+--- atheme-1.2.1.orig/configure.ac 2006-07-10 13:23:14.000000000 +0000
++++ atheme-1.2.1/configure.ac 2006-10-22 11:52:40.281188612 +0000
+@@ -196,43 +196,61 @@
+
+ POSTGRESQL="yes"
+
+-AC_MSG_CHECKING(for PostgreSQL include directory)
+-if test -d /usr/include/pgsql ; then
+- pg_inc_dir="/usr/include/pgsql"
+-elif test -f /usr/local/include/libpq-fe.h ; then
+-# kludge for freebsd ports, found on liveharmony boxes. --nenolod
+- pg_inc_dir="/usr/local/include"
+- LDFLAGS="-L/usr/local/lib"
+-elif test -d /usr/include/postgresql ; then
+- pg_inc_dir="/usr/include/postgresql"
+-elif test -d /usr/local/psql/include ; then
+- pg_inc_dir="/usr/local/psql/include"
+-elif test -d /usr/local/include/postgresql ; then
+- pg_inc_dir="/usr/local/include/postgresql"
+-elif test -d /usr/local/pgsql/include ; then
+- pg_inc_dir="/usr/local/pgsql/include"
+-elif test -d /usr/local/include/psql ; then
+- pg_inc_dir="/usr/local/include/psql"
+-elif test -d /opt/psql/include ; then
+- pg_inc_dir="/opt/psql/include"
+-else
+- pg_inc_dir="no"
+- PQLIB=""
+- POSTGRESQL="no"
+-fi
++AC_ARG_ENABLE(postgresql,
++AC_HELP_STRING([--enable-postgresql], [Enables PostgreSQL backend support.]),
++[
++ case "$enableval" in
++ yes|no)
++ POSTGRESQL="$enableval"
++ ;;
++ *)
++ AC_MSG_ERROR([Invalid argument to --enable-postgresql (expecting either 'yes' or 'no')])
++ ;;
++ esac
++])
++
++AC_MSG_CHECKING([whether to enable PostgreSQL backend support])
++AC_MSG_RESULT($POSTGRESQL)
++
++if test "x$POSTGRESQL" = xyes; then
++ AC_MSG_CHECKING(for PostgreSQL include directory)
++ if test -d /usr/include/pgsql ; then
++ pg_inc_dir="/usr/include/pgsql"
++ elif test -f /usr/local/include/libpq-fe.h ; then
++ # kludge for freebsd ports, found on liveharmony boxes. --nenolod
++ pg_inc_dir="/usr/local/include"
++ LDFLAGS="-L/usr/local/lib"
++ elif test -d /usr/include/postgresql ; then
++ pg_inc_dir="/usr/include/postgresql"
++ elif test -d /usr/local/psql/include ; then
++ pg_inc_dir="/usr/local/psql/include"
++ elif test -d /usr/local/include/postgresql ; then
++ pg_inc_dir="/usr/local/include/postgresql"
++ elif test -d /usr/local/pgsql/include ; then
++ pg_inc_dir="/usr/local/pgsql/include"
++ elif test -d /usr/local/include/psql ; then
++ pg_inc_dir="/usr/local/include/psql"
++ elif test -d /opt/psql/include ; then
++ pg_inc_dir="/opt/psql/include"
++ else
++ pg_inc_dir="no"
++ PQLIB=""
++ POSTGRESQL="no"
++ fi
+
+-POSTGRESQL_C=""
++ POSTGRESQL_C=""
+
+-AC_MSG_RESULT($pg_inc_dir)
++ AC_MSG_RESULT($pg_inc_dir)
+
+-if test "$pg_inc_dir" != "no"; then
+- AC_CHECK_HEADER($pg_inc_dir/libpq-fe.h, [
+- PGINC="-I$pg_inc_dir"
+- AC_CHECK_LIB(pq, PQconnectdb, [PQLIB="-lpq"
+- POSTGRESQL_C="postgresql.c"])
+- ])
+-else
+- POSTGRESQL="no"
++ if test "$pg_inc_dir" != "no"; then
++ AC_CHECK_HEADER($pg_inc_dir/libpq-fe.h, [
++ PGINC="-I$pg_inc_dir"
++ AC_CHECK_LIB(pq, PQconnectdb, [PQLIB="-lpq"
++ POSTGRESQL_C="postgresql.c"])
++ ])
++ else
++ POSTGRESQL="no"
++ fi
+ fi
+
+ AC_SUBST(POSTGRESQL_C)
diff --git a/net-irc/atheme-services/files/atheme.initd b/net-irc/atheme-services/files/atheme.initd
new file mode 100644
index 000000000000..8853da092267
--- /dev/null
+++ b/net-irc/atheme-services/files/atheme.initd
@@ -0,0 +1,20 @@
+#!/sbin/runscript
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/atheme-services/files/atheme.initd,v 1.1 2011/06/08 00:45:35 binki Exp $
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting atheme"
+ start-stop-daemon --start --quiet --chuid atheme --exec /usr/bin/atheme &>/dev/null
+ eend $? "Failed to start atheme"
+}
+
+stop() {
+ ebegin "Stopping atheme"
+ start-stop-daemon --stop --quiet --pidfile /var/lib/atheme/var/atheme.pid
+ eend $? "Failed to stop atheme"
+}
diff --git a/net-irc/atheme-services/files/make-postgresql-support-optional.patch b/net-irc/atheme-services/files/make-postgresql-support-optional.patch
new file mode 100644
index 000000000000..edd0d2a9939b
--- /dev/null
+++ b/net-irc/atheme-services/files/make-postgresql-support-optional.patch
@@ -0,0 +1,99 @@
+diff -Nup -r atheme-0.2.2/configure.ac atheme-0.2.2.patched/configure.ac
+--- atheme-0.2.2/configure.ac 2005-09-03 21:17:30.000000000 +0000
++++ atheme-0.2.2.patched/configure.ac 2005-09-04 02:16:20.000000000 +0000
+@@ -95,43 +95,61 @@ echo " "
+
+ POSTGRESQL="yes"
+
+-AC_MSG_CHECKING(for PostgreSQL include directory)
+-if test -d /usr/include/pgsql ; then
+- pg_inc_dir="/usr/include/pgsql"
+-elif test -f /usr/local/include/libpq-fe.h ; then
+-# kludge for freebsd ports, found on liveharmony boxes. --nenolod
+- pg_inc_dir="/usr/local/include"
+- LDFLAGS="-L/usr/local/lib"
+-elif test -d /usr/include/postgresql ; then
+- pg_inc_dir="/usr/include/postgresql"
+-elif test -d /usr/local/psql/include ; then
+- pg_inc_dir="/usr/local/psql/include"
+-elif test -d /usr/local/include/postgresql ; then
+- pg_inc_dir="/usr/local/include/postgresql"
+-elif test -d /usr/local/pgsql/include ; then
+- pg_inc_dir="/usr/local/include/psql"
+-elif test -d /usr/local/include/psql ; then
+- pg_inc_dir="/usr/local/include/psql"
+-elif test -d /opt/psql/include ; then
+- pg_inc_dir="/opt/psql/include"
+-else
+- pg_inc_dir="no"
+- PQLIB=""
+- POSTGRESQL="no"
+-fi
++AC_ARG_WITH(postgresql,
++AC_HELP_STRING([--with-postgresql],[ Enables PostgreSQL backend support.]),
++[
++ case "$withval" in
++ yes|no)
++ POSTGRESQL="$withval"
++ ;;
++ *)
++ AC_MSG_ERROR([Invalid argument to --with-postgresql (expecting either 'yes' or 'no')])
++ ;;
++ esac
++])
+
+-POSTGRESQL_C=""
++AC_MSG_CHECKING([whether to enable PostgreSQL backend support])
++AC_MSG_RESULT($POSTGRESQL)
+
+-AC_MSG_RESULT($pg_inc_dir)
++if test "x$POSTGRESQL" = xyes; then
++ AC_MSG_CHECKING(for PostgreSQL include directory)
++ if test -d /usr/include/pgsql ; then
++ pg_inc_dir="/usr/include/pgsql"
++ elif test -f /usr/local/include/libpq-fe.h ; then
++ # kludge for freebsd ports, found on liveharmony boxes. --nenolod
++ pg_inc_dir="/usr/local/include"
++ LDFLAGS="-L/usr/local/lib"
++ elif test -d /usr/include/postgresql ; then
++ pg_inc_dir="/usr/include/postgresql"
++ elif test -d /usr/local/psql/include ; then
++ pg_inc_dir="/usr/local/psql/include"
++ elif test -d /usr/local/include/postgresql ; then
++ pg_inc_dir="/usr/local/include/postgresql"
++ elif test -d /usr/local/pgsql/include ; then
++ pg_inc_dir="/usr/local/include/psql"
++ elif test -d /usr/local/include/psql ; then
++ pg_inc_dir="/usr/local/include/psql"
++ elif test -d /opt/psql/include ; then
++ pg_inc_dir="/opt/psql/include"
++ else
++ pg_inc_dir="no"
++ PQLIB=""
++ POSTGRESQL="no"
++ fi
+
+-if test "$pg_inc_dir" != "no"; then
+- AC_CHECK_HEADER($pg_inc_dir/libpq-fe.h, [
+- PGINC="-I$pg_inc_dir"
+- AC_CHECK_LIB(pq, PQconnectdb, PQLIB="-lpq")
+- POSTGRESQL_C="postgresql.c"
+- ])
+-else
+- POSTGRESQL="no"
++ POSTGRESQL_C=""
++
++ AC_MSG_RESULT($pg_inc_dir)
++
++ if test "$pg_inc_dir" != "no"; then
++ AC_CHECK_HEADER($pg_inc_dir/libpq-fe.h, [
++ PGINC="-I$pg_inc_dir"
++ AC_CHECK_LIB(pq, PQconnectdb, PQLIB="-lpq")
++ POSTGRESQL_C="postgresql.c"
++ ])
++ else
++ POSTGRESQL="no"
++ fi
+ fi
+
+ AC_SUBST(POSTGRESQL_C)
diff --git a/net-irc/atheme-services/files/makefile-DESTDIR-support.patch b/net-irc/atheme-services/files/makefile-DESTDIR-support.patch
new file mode 100644
index 000000000000..afd307912742
--- /dev/null
+++ b/net-irc/atheme-services/files/makefile-DESTDIR-support.patch
@@ -0,0 +1,145 @@
+diff -Nup -r atheme-0.2.2/backend/Makefile.in atheme-0.2.2.patched/backend/Makefile.in
+--- atheme-0.2.2/backend/Makefile.in 2005-09-03 21:17:28.000000000 +0000
++++ atheme-0.2.2.patched/backend/Makefile.in 2005-09-04 04:15:55.000000000 +0000
+@@ -6,6 +6,8 @@
+ # $Id: makefile-DESTDIR-support.patch,v 1.1 2011/06/08 00:45:35 binki Exp $
+ #
+
++DESTDIR :=
++
+ CC = @CC@
+ RM = @RM@
+ MV = @MV@
+@@ -36,8 +38,8 @@ all: protocols
+ build: all
+
+ install: build
+- ${INSTALL} -d ${PREFIX}/backend
+- ${INSTALL} -m 755 *.so ${PREFIX}/backend
++ ${INSTALL} -d $(DESTDIR)${PREFIX}/backend
++ ${INSTALL} -m 755 *.so $(DESTDIR)${PREFIX}/backend
+
+ protocols: $(OBJS)
+
+diff -Nup -r atheme-0.2.2/contrib/Makefile.in atheme-0.2.2.patched/contrib/Makefile.in
+--- atheme-0.2.2/contrib/Makefile.in 2005-09-03 21:17:29.000000000 +0000
++++ atheme-0.2.2.patched/contrib/Makefile.in 2005-09-04 04:15:55.000000000 +0000
+@@ -6,6 +6,8 @@
+ # $Id: makefile-DESTDIR-support.patch,v 1.1 2011/06/08 00:45:35 binki Exp $
+ #
+
++DESTDIR :=
++
+ CC = @CC@
+ RM = @RM@
+ MV = @MV@
+@@ -38,8 +40,8 @@ all: protocols
+ build: all
+
+ install: build
+- ${INSTALL} -d ${PREFIX}/contrib
+- ${INSTALL} -m 755 *.so ${PREFIX}/contrib
++ ${INSTALL} -d $(DESTDIR)${PREFIX}/contrib
++ ${INSTALL} -m 755 *.so $(DESTDIR)${PREFIX}/contrib
+
+ protocols: $(OBJS)
+
+diff -Nup -r atheme-0.2.2/modules/Makefile.in atheme-0.2.2.patched/modules/Makefile.in
+--- atheme-0.2.2/modules/Makefile.in 2005-09-03 21:17:30.000000000 +0000
++++ atheme-0.2.2.patched/modules/Makefile.in 2005-09-04 04:15:55.000000000 +0000
+@@ -6,6 +6,8 @@
+ # $Id: makefile-DESTDIR-support.patch,v 1.1 2011/06/08 00:45:35 binki Exp $
+ #
+
++DESTDIR :=
++
+ CC = @CC@
+ RM = @RM@
+ MV = @MV@
+@@ -36,8 +38,8 @@ all: modules
+ build: all
+
+ install: build
+- ${INSTALL} -d ${PREFIX}/modules
+- ${INSTALL} -m 755 *.so ${PREFIX}/modules
++ ${INSTALL} -d $(DESTDIR)${PREFIX}/modules
++ ${INSTALL} -m 755 *.so $(DESTDIR)${PREFIX}/modules
+
+ modules: $(OBJS)
+
+diff -Nup -r atheme-0.2.2/protocol/Makefile.in atheme-0.2.2.patched/protocol/Makefile.in
+--- atheme-0.2.2/protocol/Makefile.in 2005-09-03 21:17:29.000000000 +0000
++++ atheme-0.2.2.patched/protocol/Makefile.in 2005-09-04 04:15:55.000000000 +0000
+@@ -6,6 +6,8 @@
+ # $Id: makefile-DESTDIR-support.patch,v 1.1 2011/06/08 00:45:35 binki Exp $
+ #
+
++DESTDIR :=
++
+ CC = @CC@
+ RM = @RM@
+ MV = @MV@
+@@ -49,8 +51,8 @@ all: protocols
+ build: all
+
+ install: build
+- ${INSTALL} -d ${PREFIX}/protocol
+- ${INSTALL} -m 755 *.so ${PREFIX}/protocol
++ ${INSTALL} -d $(DESTDIR)${PREFIX}/protocol
++ ${INSTALL} -m 755 *.so $(DESTDIR)${PREFIX}/protocol
+
+ protocols: $(OBJS)
+
+diff -Nup -r atheme-0.2.2/src/Makefile.in atheme-0.2.2.patched/src/Makefile.in
+--- atheme-0.2.2/src/Makefile.in 2005-09-03 21:17:29.000000000 +0000
++++ atheme-0.2.2.patched/src/Makefile.in 2005-09-04 04:15:55.000000000 +0000
+@@ -6,6 +6,8 @@
+ # $Id: makefile-DESTDIR-support.patch,v 1.1 2011/06/08 00:45:35 binki Exp $
+ #
+
++DESTDIR :=
++
+ CC = @CC@
+ RM = @RM@
+ MV = @MV@
+@@ -70,27 +72,27 @@ atheme: $(OBJS)
+ $(MV) version.c version.c.last
+
+ install: build
+- $(INSTALL) -m 755 -d $(PREFIX)
+- $(INSTALL) -m 755 -d $(PREFIX)/bin
+- $(INSTALL) -m 755 -d $(PREFIX)/etc
+- $(INSTALL) -m 755 -d $(PREFIX)/var
+- $(INSTALL) -m 755 -c $(BIN) $(PREFIX)/bin
+- $(INSTALL) -m 640 -c ../dist/example.conf $(PREFIX)/etc
+- $(INSTALL) -m 640 -c ../dist/example-traditional.conf $(PREFIX)/etc
++ $(INSTALL) -m 755 -d $(DESTDIR)$(PREFIX)
++ $(INSTALL) -m 755 -d $(DESTDIR)$(PREFIX)/bin
++ $(INSTALL) -m 755 -d $(DESTDIR)$(PREFIX)/etc
++ $(INSTALL) -m 755 -d $(DESTDIR)$(PREFIX)/var
++ $(INSTALL) -m 755 -c $(BIN) $(DESTDIR)$(PREFIX)/bin
++ $(INSTALL) -m 640 -c ../dist/example.conf $(DESTDIR)$(PREFIX)/etc
++ $(INSTALL) -m 640 -c ../dist/example-traditional.conf $(DESTDIR)$(PREFIX)/etc
+ if [ ! -r $(PREFIX)/etc/atheme.db ]; then \
+- $(INSTALL) -m 640 -c ../dist/atheme.db $(PREFIX)/etc ; \
++ $(INSTALL) -m 640 -c ../dist/atheme.db $(DESTDIR)$(PREFIX)/etc ; \
+ fi
+ if [ ! -r $(PREFIX)/etc/atheme.chk ]; then \
+- $(INSTALL) -m 640 -c ../dist/atheme.chk $(PREFIX)/etc ; \
++ $(INSTALL) -m 640 -c ../dist/atheme.chk $(DESTDIR)$(PREFIX)/etc ; \
+ fi
+ if [ -e $(PREFIX)/doc ]; then \
+- $(RM) -rf $(PREFIX)/doc ; \
++ $(RM) -rf $(DESTDIR)$(PREFIX)/doc ; \
+ fi
+ if [ -e $(PREFIX)/help ]; then \
+- $(RM) -rf $(PREFIX)/help ; \
++ $(RM) -rf $(DESTDIR)$(PREFIX)/help ; \
+ fi
+- $(CP) -R ../doc $(PREFIX)
+- $(CP) -R ../help $(PREFIX)
++ $(CP) -R ../doc $(DESTDIR)$(PREFIX)
++ $(CP) -R ../help $(DESTDIR)$(PREFIX)
+
+ @echo "----------------------------------------------------------------"
+ @echo ">>> Remember to cd to ${PREFIX} and edit your config file.";
diff --git a/net-irc/atheme-services/metadata.xml b/net-irc/atheme-services/metadata.xml
new file mode 100644
index 000000000000..e51b33667db8
--- /dev/null
+++ b/net-irc/atheme-services/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="utf-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>net-irc</herd>
+ <use>
+ <flag name='largenet'>Enable support/tweaks for large networks</flag>
+ </use>
+</pkgmetadata>