summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorThomas Anderson <gentoofan23@gentoo.org>2009-03-07 19:57:16 +0000
committerThomas Anderson <gentoofan23@gentoo.org>2009-03-07 19:57:16 +0000
commitf4001e9aaf1c509c43208012b7357d845b8a8dc6 (patch)
treeb225c5101e94fe9dfb322091812c6f8c4499e623 /net-im
parentMigrate to EAPI 2. (diff)
downloadgentoo-2-f4001e9aaf1c509c43208012b7357d845b8a8dc6.tar.gz
gentoo-2-f4001e9aaf1c509c43208012b7357d845b8a8dc6.tar.bz2
gentoo-2-f4001e9aaf1c509c43208012b7357d845b8a8dc6.zip
Transition to eapi 2 use deps
Diffstat (limited to 'net-im')
-rw-r--r--net-im/gajim/ChangeLog9
-rw-r--r--net-im/gajim/gajim-0.11.1.ebuild28
-rw-r--r--net-im/gajim/gajim-0.11.2-r1.ebuild28
-rw-r--r--net-im/gajim/gajim-0.11.2.ebuild28
-rw-r--r--net-im/gajim/gajim-0.11.3-r1.ebuild28
-rw-r--r--net-im/gajim/gajim-0.11.3.ebuild28
-rw-r--r--net-im/gajim/gajim-0.11.4.ebuild28
7 files changed, 49 insertions, 128 deletions
diff --git a/net-im/gajim/ChangeLog b/net-im/gajim/ChangeLog
index 9f8cf8cb2311..89fcee5ff364 100644
--- a/net-im/gajim/ChangeLog
+++ b/net-im/gajim/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-im/gajim
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/gajim/ChangeLog,v 1.72 2008/08/05 16:57:30 gentoofan23 Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/gajim/ChangeLog,v 1.73 2009/03/07 19:57:16 gentoofan23 Exp $
+
+ 07 Mar 2009; Thomas Anderson <gentoofan23@gentoo.org> gajim-0.11.1.ebuild,
+ gajim-0.11.2.ebuild, gajim-0.11.2-r1.ebuild, gajim-0.11.3.ebuild,
+ gajim-0.11.3-r1.ebuild, gajim-0.11.4.ebuild:
+ Transition to eapi 2 use deps
05 Aug 2008; Thomas Anderson <gentoofan23@gentoo.org> metadata.xml:
Add USE flag description to metadata as per GLEP 56.
diff --git a/net-im/gajim/gajim-0.11.1.ebuild b/net-im/gajim/gajim-0.11.1.ebuild
index c73ca871d971..126b7b154c25 100644
--- a/net-im/gajim/gajim-0.11.1.ebuild
+++ b/net-im/gajim/gajim-0.11.1.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/gajim/gajim-0.11.1.ebuild,v 1.10 2007/07/01 09:12:37 welp Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/gajim/gajim-0.11.1.ebuild,v 1.11 2009/03/07 19:57:16 gentoofan23 Exp $
+EAPI="2"
inherit multilib python eutils
DESCRIPTION="Jabber client written in PyGTK"
@@ -15,7 +16,7 @@ IUSE="avahi dbus gnome idle libnotify nls spell srv trayicon X xhtml"
DEPEND="|| (
( <dev-lang/python-2.5 dev-python/pysqlite )
- >=dev-lang/python-2.5
+ >=dev-lang/python-2.5[sqlite]
)
dev-python/pygtk
sys-devel/gettext
@@ -31,7 +32,7 @@ RDEPEND="gnome? ( dev-python/gnome-python-extras
srv? ( net-dns/bind-tools )
idle? ( x11-libs/libXScrnSaver )
spell? ( app-text/gtkspell )
- avahi? ( net-dns/avahi )"
+ avahi? ( net-dns/avahi[dbus,gtk,python] )"
pkg_setup() {
if ! use dbus; then
@@ -49,22 +50,9 @@ pkg_setup() {
die "USE=\"python\" needed for dbus"
fi
fi
-
- if use avahi; then
- if ! built_with_use net-dns/avahi dbus gtk python; then
- eerror "The following USE flags are required for correct avahi"
- eerror "support: dbus gtk python"
- die "Please rebuild avahi with these use flags enabled."
- fi
- fi
-
- if has_version ">=dev-lang/python-2.5" && ! built_with_use dev-lang/python sqlite; then
- eerror "Please rebuild python with USE=\"sqlite\""
- die "USE=\"sqlite\" needed for python"
- fi
}
-src_compile() {
+src_configure() {
local myconf
if ! use gnome; then
@@ -79,9 +67,7 @@ src_compile() {
--docdir="/usr/share/doc/${PF}" \
--prefix="/usr" \
--libdir="/usr/$(get_libdir)" \
- ${myconf} || die "econf failed"
-
- emake || die "emake failed"
+ ${myconf}
}
src_install() {
diff --git a/net-im/gajim/gajim-0.11.2-r1.ebuild b/net-im/gajim/gajim-0.11.2-r1.ebuild
index 749f92777080..745c8a673144 100644
--- a/net-im/gajim/gajim-0.11.2-r1.ebuild
+++ b/net-im/gajim/gajim-0.11.2-r1.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/gajim/gajim-0.11.2-r1.ebuild,v 1.1 2007/10/23 10:45:45 welp Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/gajim/gajim-0.11.2-r1.ebuild,v 1.2 2009/03/07 19:57:16 gentoofan23 Exp $
+EAPI="2"
inherit multilib python eutils
DESCRIPTION="Jabber client written in PyGTK"
@@ -15,7 +16,7 @@ IUSE="avahi dbus gnome idle libnotify nls spell srv trayicon X xhtml"
DEPEND="|| (
( <dev-lang/python-2.5 dev-python/pysqlite )
- >=dev-lang/python-2.5
+ >=dev-lang/python-2.5[sqlite]
)
dev-python/pygtk
sys-devel/gettext
@@ -31,7 +32,7 @@ RDEPEND="gnome? ( dev-python/gnome-python-extras
srv? ( net-dns/bind-tools )
idle? ( x11-libs/libXScrnSaver )
spell? ( app-text/gtkspell )
- avahi? ( net-dns/avahi )
+ avahi? ( net-dns/avahi[dbus,gtk,python] )
dev-python/pyopenssl"
pkg_setup() {
@@ -50,22 +51,9 @@ pkg_setup() {
die "USE=\"python\" needed for dbus"
fi
fi
-
- if use avahi; then
- if ! built_with_use net-dns/avahi dbus gtk python; then
- eerror "The following USE flags are required for correct avahi"
- eerror "support: dbus gtk python"
- die "Please rebuild avahi with these use flags enabled."
- fi
- fi
-
- if has_version ">=dev-lang/python-2.5" && ! built_with_use dev-lang/python sqlite; then
- eerror "Please rebuild python with USE=\"sqlite\""
- die "USE=\"sqlite\" needed for python"
- fi
}
-src_compile() {
+src_configure() {
local myconf
if ! use gnome; then
@@ -80,9 +68,7 @@ src_compile() {
--docdir="/usr/share/doc/${PF}" \
--prefix="/usr" \
--libdir="/usr/$(get_libdir)" \
- ${myconf} || die "econf failed"
-
- emake || die "emake failed"
+ ${myconf}
}
src_install() {
diff --git a/net-im/gajim/gajim-0.11.2.ebuild b/net-im/gajim/gajim-0.11.2.ebuild
index f7caf8aa1c83..72834d32e632 100644
--- a/net-im/gajim/gajim-0.11.2.ebuild
+++ b/net-im/gajim/gajim-0.11.2.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/gajim/gajim-0.11.2.ebuild,v 1.1 2007/10/10 06:19:38 welp Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/gajim/gajim-0.11.2.ebuild,v 1.2 2009/03/07 19:57:16 gentoofan23 Exp $
+EAPI="2"
inherit multilib python eutils
DESCRIPTION="Jabber client written in PyGTK"
@@ -15,7 +16,7 @@ IUSE="avahi dbus gnome idle libnotify nls spell srv trayicon X xhtml"
DEPEND="|| (
( <dev-lang/python-2.5 dev-python/pysqlite )
- >=dev-lang/python-2.5
+ >=dev-lang/python-2.5[sqlite]
)
dev-python/pygtk
sys-devel/gettext
@@ -31,7 +32,7 @@ RDEPEND="gnome? ( dev-python/gnome-python-extras
srv? ( net-dns/bind-tools )
idle? ( x11-libs/libXScrnSaver )
spell? ( app-text/gtkspell )
- avahi? ( net-dns/avahi )"
+ avahi? ( net-dns/avahi[dbus,gtk,python] )"
pkg_setup() {
if ! use dbus; then
@@ -49,22 +50,9 @@ pkg_setup() {
die "USE=\"python\" needed for dbus"
fi
fi
-
- if use avahi; then
- if ! built_with_use net-dns/avahi dbus gtk python; then
- eerror "The following USE flags are required for correct avahi"
- eerror "support: dbus gtk python"
- die "Please rebuild avahi with these use flags enabled."
- fi
- fi
-
- if has_version ">=dev-lang/python-2.5" && ! built_with_use dev-lang/python sqlite; then
- eerror "Please rebuild python with USE=\"sqlite\""
- die "USE=\"sqlite\" needed for python"
- fi
}
-src_compile() {
+src_configure() {
local myconf
if ! use gnome; then
@@ -79,9 +67,7 @@ src_compile() {
--docdir="/usr/share/doc/${PF}" \
--prefix="/usr" \
--libdir="/usr/$(get_libdir)" \
- ${myconf} || die "econf failed"
-
- emake || die "emake failed"
+ ${myconf}
}
src_install() {
diff --git a/net-im/gajim/gajim-0.11.3-r1.ebuild b/net-im/gajim/gajim-0.11.3-r1.ebuild
index e659f80b839f..964271d9e2b2 100644
--- a/net-im/gajim/gajim-0.11.3-r1.ebuild
+++ b/net-im/gajim/gajim-0.11.3-r1.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/gajim/gajim-0.11.3-r1.ebuild,v 1.2 2007/12/02 16:57:38 welp Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/gajim/gajim-0.11.3-r1.ebuild,v 1.3 2009/03/07 19:57:16 gentoofan23 Exp $
+EAPI="2"
inherit multilib python eutils
DESCRIPTION="Jabber client written in PyGTK"
@@ -15,7 +16,7 @@ IUSE="avahi dbus gnome idle libnotify nls spell srv trayicon X xhtml"
DEPEND="|| (
( <dev-lang/python-2.5 dev-python/pysqlite )
- >=dev-lang/python-2.5
+ >=dev-lang/python-2.5[sqlite]
)
dev-python/pygtk
sys-devel/gettext
@@ -31,7 +32,7 @@ RDEPEND="gnome? ( dev-python/gnome-python-extras
srv? ( net-dns/bind-tools )
idle? ( x11-libs/libXScrnSaver )
spell? ( app-text/gtkspell )
- avahi? ( net-dns/avahi )
+ avahi? ( net-dns/avahi[dbus,gtk,python] )
dev-python/pyopenssl"
pkg_setup() {
@@ -50,19 +51,6 @@ pkg_setup() {
die "USE=\"python\" needed for dbus"
fi
fi
-
- if use avahi; then
- if ! built_with_use net-dns/avahi dbus gtk python; then
- eerror "The following USE flags are required for correct avahi"
- eerror "support: dbus gtk python"
- die "Please rebuild avahi with these use flags enabled."
- fi
- fi
-
- if has_version ">=dev-lang/python-2.5" && ! built_with_use dev-lang/python sqlite; then
- eerror "Please rebuild python with USE=\"sqlite\""
- die "USE=\"sqlite\" needed for python"
- fi
}
src_unpack() {
@@ -71,7 +59,7 @@ src_unpack() {
epatch "${FILESDIR}/${PV}-misc-fixes.patch"
}
-src_compile() {
+src_configure() {
local myconf
if ! use gnome; then
@@ -86,9 +74,7 @@ src_compile() {
--docdir="/usr/share/doc/${PF}" \
--prefix="/usr" \
--libdir="/usr/$(get_libdir)" \
- ${myconf} || die "econf failed"
-
- emake || die "emake failed"
+ ${myconf}
}
src_install() {
diff --git a/net-im/gajim/gajim-0.11.3.ebuild b/net-im/gajim/gajim-0.11.3.ebuild
index 36df202880a4..ddeafc517e1a 100644
--- a/net-im/gajim/gajim-0.11.3.ebuild
+++ b/net-im/gajim/gajim-0.11.3.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/gajim/gajim-0.11.3.ebuild,v 1.2 2007/11/19 19:37:32 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/gajim/gajim-0.11.3.ebuild,v 1.3 2009/03/07 19:57:16 gentoofan23 Exp $
+EAPI="2"
inherit multilib python eutils
DESCRIPTION="Jabber client written in PyGTK"
@@ -15,7 +16,7 @@ IUSE="avahi dbus gnome idle libnotify nls spell srv trayicon X xhtml"
DEPEND="|| (
( <dev-lang/python-2.5 dev-python/pysqlite )
- >=dev-lang/python-2.5
+ >=dev-lang/python-2.5[sqlite]
)
dev-python/pygtk
sys-devel/gettext
@@ -31,7 +32,7 @@ RDEPEND="gnome? ( dev-python/gnome-python-extras
srv? ( net-dns/bind-tools )
idle? ( x11-libs/libXScrnSaver )
spell? ( app-text/gtkspell )
- avahi? ( net-dns/avahi )
+ avahi? ( net-dns/avahi[dbus,gtk,python] )
dev-python/pyopenssl"
pkg_setup() {
@@ -50,22 +51,9 @@ pkg_setup() {
die "USE=\"python\" needed for dbus"
fi
fi
-
- if use avahi; then
- if ! built_with_use net-dns/avahi dbus gtk python; then
- eerror "The following USE flags are required for correct avahi"
- eerror "support: dbus gtk python"
- die "Please rebuild avahi with these use flags enabled."
- fi
- fi
-
- if has_version ">=dev-lang/python-2.5" && ! built_with_use dev-lang/python sqlite; then
- eerror "Please rebuild python with USE=\"sqlite\""
- die "USE=\"sqlite\" needed for python"
- fi
}
-src_compile() {
+src_configure() {
local myconf
if ! use gnome; then
@@ -80,9 +68,7 @@ src_compile() {
--docdir="/usr/share/doc/${PF}" \
--prefix="/usr" \
--libdir="/usr/$(get_libdir)" \
- ${myconf} || die "econf failed"
-
- emake || die "emake failed"
+ ${myconf}
}
src_install() {
diff --git a/net-im/gajim/gajim-0.11.4.ebuild b/net-im/gajim/gajim-0.11.4.ebuild
index ec7c15d7d3db..20af04e9ac31 100644
--- a/net-im/gajim/gajim-0.11.4.ebuild
+++ b/net-im/gajim/gajim-0.11.4.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/gajim/gajim-0.11.4.ebuild,v 1.6 2008/01/24 20:23:28 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/gajim/gajim-0.11.4.ebuild,v 1.7 2009/03/07 19:57:16 gentoofan23 Exp $
+EAPI="2"
inherit multilib python eutils
DESCRIPTION="Jabber client written in PyGTK"
@@ -15,7 +16,7 @@ IUSE="avahi dbus gnome idle libnotify nls spell srv trayicon X xhtml"
DEPEND="|| (
( <dev-lang/python-2.5 dev-python/pysqlite )
- >=dev-lang/python-2.5
+ >=dev-lang/python-2.5[sqlite]
)
dev-python/pygtk
sys-devel/gettext
@@ -31,7 +32,7 @@ RDEPEND="gnome? ( dev-python/gnome-python-extras
srv? ( net-dns/bind-tools )
idle? ( x11-libs/libXScrnSaver )
spell? ( app-text/gtkspell )
- avahi? ( net-dns/avahi )
+ avahi? ( net-dns/avahi[dbus,gtk,python] )
dev-python/pyopenssl"
pkg_setup() {
@@ -50,19 +51,6 @@ pkg_setup() {
die "USE=\"python\" needed for dbus"
fi
fi
-
- if use avahi; then
- if ! built_with_use net-dns/avahi dbus gtk python; then
- eerror "The following USE flags are required for correct avahi"
- eerror "support: dbus gtk python"
- die "Please rebuild avahi with these use flags enabled."
- fi
- fi
-
- if has_version ">=dev-lang/python-2.5" && ! built_with_use dev-lang/python sqlite; then
- eerror "Please rebuild python with USE=\"sqlite\""
- die "USE=\"sqlite\" needed for python"
- fi
}
src_unpack() {
@@ -71,7 +59,7 @@ src_unpack() {
epatch "${FILESDIR}/${P}-test_fix.patch"
}
-src_compile() {
+src_configure() {
local myconf
if ! use gnome; then
@@ -86,9 +74,7 @@ src_compile() {
--docdir="/usr/share/doc/${PF}" \
--prefix="/usr" \
--libdir="/usr/$(get_libdir)" \
- ${myconf} || die "econf failed"
-
- emake || die "emake failed"
+ ${myconf}
}
src_install() {