summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2009-03-23 10:11:10 +0000
committerPeter Volkov <pva@gentoo.org>2009-03-23 10:11:10 +0000
commite756e1bd1cf11a1a60e2b7cf5f52780661865dbc (patch)
treeebb4f3111fb9956558f882828621e36c928516a0 /net-im
parentFixed misc security vulnerabilities, bug #222121, thank Robert Buchholz for r... (diff)
downloadgentoo-2-e756e1bd1cf11a1a60e2b7cf5f52780661865dbc.tar.gz
gentoo-2-e756e1bd1cf11a1a60e2b7cf5f52780661865dbc.tar.bz2
gentoo-2-e756e1bd1cf11a1a60e2b7cf5f52780661865dbc.zip
Fixed build issue, thank Benjamin Southall for report in bug #261859.
(Portage version: 2.2_rc26/cvs/Linux i686)
Diffstat (limited to 'net-im')
-rw-r--r--net-im/psi/ChangeLog6
-rw-r--r--net-im/psi/files/psi-0.12.1-build-error.patch23
-rw-r--r--net-im/psi/psi-0.12.1.ebuild3
-rw-r--r--net-im/psi/psi-0.12.ebuild84
4 files changed, 30 insertions, 86 deletions
diff --git a/net-im/psi/ChangeLog b/net-im/psi/ChangeLog
index 9b0d7284ec52..d4a885d934f4 100644
--- a/net-im/psi/ChangeLog
+++ b/net-im/psi/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-im/psi
# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/psi/ChangeLog,v 1.156 2009/02/25 16:44:25 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/psi/ChangeLog,v 1.157 2009/03/23 10:11:10 pva Exp $
+
+ 23 Mar 2009; Peter Volkov <pva@gentoo.org>
+ +files/psi-0.12.1-build-error.patch, -psi-0.12.ebuild, psi-0.12.1.ebuild:
+ Fixed build issue, thank Benjamin Southall for report in bug #261859.
25 Feb 2009; Tobias Scherbaum <dertobi123@gentoo.org> psi-0.12.1.ebuild:
ppc stable, bug #252830
diff --git a/net-im/psi/files/psi-0.12.1-build-error.patch b/net-im/psi/files/psi-0.12.1-build-error.patch
new file mode 100644
index 000000000000..fe7f66336286
--- /dev/null
+++ b/net-im/psi/files/psi-0.12.1-build-error.patch
@@ -0,0 +1,23 @@
+commit 360310c8f2dc07c5ff50d4c26b6b984a2c66f5be
+Author: Justin Karneges <justin@affinix.com>
+Date: Thu Feb 5 22:53:05 2009 -0800
+
+ make these references less weird
+
+diff --git a/src/mainwin.cpp b/src/mainwin.cpp
+index d12497d..6c130e2 100644
+--- a/src/mainwin.cpp
++++ b/src/mainwin.cpp
+@@ -428,9 +428,9 @@ MainWin::~MainWin()
+
+ void MainWin::registerAction( IconAction* action )
+ {
+- char activated[] = SIGNAL( activated() );
+- char toggled[] = SIGNAL( toggled(bool) );
+- char setChecked[] = SLOT( setChecked(bool) );
++ const char *activated = SIGNAL( activated() );
++ const char *toggled = SIGNAL( toggled(bool) );
++ const char *setChecked = SLOT( setChecked(bool) );
+
+ struct {
+ const char* name;
diff --git a/net-im/psi/psi-0.12.1.ebuild b/net-im/psi/psi-0.12.1.ebuild
index d14a9619ba9b..e6613a5654d6 100644
--- a/net-im/psi/psi-0.12.1.ebuild
+++ b/net-im/psi/psi-0.12.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/psi/psi-0.12.1.ebuild,v 1.8 2009/02/25 16:44:25 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/psi/psi-0.12.1.ebuild,v 1.9 2009/03/23 10:11:10 pva Exp $
EAPI="2"
@@ -39,6 +39,7 @@ RDEPEND="${COMMON_DEPEND}
src_prepare() {
epatch "${FILESDIR}/${P}-qt-4.5-compatibility.patch"
+ epatch "${FILESDIR}/${P}-build-error.patch"
}
src_configure() {
diff --git a/net-im/psi/psi-0.12.ebuild b/net-im/psi/psi-0.12.ebuild
deleted file mode 100644
index e7971e393414..000000000000
--- a/net-im/psi/psi-0.12.ebuild
+++ /dev/null
@@ -1,84 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/psi/psi-0.12.ebuild,v 1.7 2008/09/20 10:05:57 armin76 Exp $
-
-EAPI="1"
-
-inherit eutils qt4 multilib
-
-DESCRIPTION="Qt4 Jabber client, with Licq-like interface"
-HOMEPAGE="http://psi-im.org/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
-
-IUSE="crypt dbus debug doc kernel_linux spell ssl xscreensaver"
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="amd64 hppa ppc ppc64 sparc x86 ~x86-fbsd"
-RESTRICT="test"
-
-COMMON_DEPEND="|| ( x11-libs/qt-gui:4 =x11-libs/qt-4.3* )
- =app-crypt/qca-2*
- spell? ( app-text/aspell )
- xscreensaver? ( x11-libs/libXScrnSaver )"
-
-DEPEND="${COMMON_DEPEND}
- doc? ( app-doc/doxygen )"
-
-RDEPEND="${COMMON_DEPEND}
- crypt? ( >=app-crypt/qca-gnupg-2.0.0_beta2 )
- ssl? ( >=app-crypt/qca-ossl-2.0.0_beta2 )"
-
-pkg_setup() {
- if has_version "=x11-libs/qt-4.3*"; then
- QT4_BUILT_WITH_USE_CHECK="qt3support png"
- QT4_OPTIONAL_BUILT_WITH_USE_CHECK="dbus"
- else
- if ! built_with_use "x11-libs/qt-gui:4" qt3support; then
- eerror "You have to build x11-libs/qt-gui:4 with qt3support."
- die "qt3support in qt-gui disabled"
- fi
- if ( use dbus && ! built_with_use "x11-libs/qt-gui:4" dbus ); then
- eerror "You have to build x11-libs/qt-gui:4 with dbus"
- die "dbus in qt-gui disabled"
- fi
- fi
- qt4_pkg_setup
-}
-
-src_compile() {
- # disable growl as it is a MacOS X extension only
- local myconf="--prefix=/usr --qtdir=/usr"
- myconf="${myconf} --disable-growl --disable-bundled-qca"
- use debug && myconf="${myconf} --enable-debug"
- use dbus || myconf="${myconf} --disable-qdbus"
- use kernel_linux || myconf="${myconf} --disable-dnotify"
- use spell || myconf="${myconf} --disable-aspell"
- use xscreensaver || myconf="${myconf} --disable-xss"
-
- # cannot use econf because of non-standard configure script
- ./configure ${myconf} || die "configure failed"
-
- eqmake4 ${PN}.pro
-
- SUBLIBS="-L/usr/${get_libdir}/qca2" emake || die "emake failed"
-
- if use doc; then
- cd doc
- make api_public || die "make api_public failed"
- fi
-}
-
-src_install() {
- emake INSTALL_ROOT="${D}" install || die "emake install failed"
-
- # this way the docs will be installed in the standard gentoo dir
- newdoc iconsets/roster/README README.roster
- newdoc iconsets/system/README README.system
- newdoc certs/README README.certs
- dodoc README
-
- if use doc; then
- cd doc
- dohtml -r api || die "dohtml failed"
- fi
-}