summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorTobias Klausmann <klausman@gentoo.org>2013-09-16 21:54:02 +0000
committerTobias Klausmann <klausman@gentoo.org>2013-09-16 21:54:02 +0000
commite6485850b37510a15a9240463aec7c5f06a634cb (patch)
tree67c5fd4297caf3356e15762630b9fd4b04aaef47 /net-im
parentversion bump (diff)
downloadgentoo-2-e6485850b37510a15a9240463aec7c5f06a634cb.tar.gz
gentoo-2-e6485850b37510a15a9240463aec7c5f06a634cb.tar.bz2
gentoo-2-e6485850b37510a15a9240463aec7c5f06a634cb.zip
Fix multilib-strict failure of 0.9.1, thanks to mrueg@ for the patch
(Portage version: 2.2.3/cvs/Linux x86_64, signed Manifest commit with key CE5D54E8)
Diffstat (limited to 'net-im')
-rw-r--r--net-im/prosody/ChangeLog7
-rw-r--r--net-im/prosody/prosody-0.9.1-r1.ebuild75
2 files changed, 81 insertions, 1 deletions
diff --git a/net-im/prosody/ChangeLog b/net-im/prosody/ChangeLog
index 57f29ccb4067..50a32c0245f7 100644
--- a/net-im/prosody/ChangeLog
+++ b/net-im/prosody/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-im/prosody
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/prosody/ChangeLog,v 1.28 2013/09/16 16:41:37 klausman Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/prosody/ChangeLog,v 1.29 2013/09/16 21:54:02 klausman Exp $
+
+*prosody-0.9.1-r1 (16 Sep 2013)
+
+ 16 Sep 2013; Tobias Klausmann <klausman@gentoo.org> +prosody-0.9.1-r1.ebuild:
+ Fix multilib-strict failure of 0.9.1, thanks to mrueg@ for the patch
16 Sep 2013; Tobias Klausmann <klausman@gentoo.org> prosody-0.9.1.ebuild:
Rekeyword prosody-0.9.1 and make luasocket dep USE-conditional
diff --git a/net-im/prosody/prosody-0.9.1-r1.ebuild b/net-im/prosody/prosody-0.9.1-r1.ebuild
new file mode 100644
index 000000000000..17ea0002a5e2
--- /dev/null
+++ b/net-im/prosody/prosody-0.9.1-r1.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/prosody/prosody-0.9.1-r1.ebuild,v 1.1 2013/09/16 21:54:02 klausman Exp $
+
+EAPI=5
+
+inherit flag-o-matic multilib versionator
+
+MY_PV=$(replace_version_separator 3 '')
+MY_P="${PN}-${MY_PV}"
+DESCRIPTION="Prosody is a flexible communications server for Jabber/XMPP written in Lua."
+HOMEPAGE="http://prosody.im/"
+SRC_URI="http://prosody.im/tmp/${MY_PV}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="ipv6 libevent mysql postgres sqlite ssl zlib"
+
+DEPEND="net-im/jabber-base
+ >=dev-lang/lua-5.1
+ >=net-dns/libidn-1.1
+ >=dev-libs/openssl-0.9.8"
+RDEPEND="${DEPEND}
+ dev-lua/luaexpat
+ dev-lua/luafilesystem
+ ipv6? ( >=dev-lua/luasocket-3 )
+ !ipv6? ( dev-lua/luasocket )
+ libevent? ( >=dev-lua/luaevent-0.4.3 )
+ mysql? ( dev-lua/luadbi[mysql] )
+ postgres? ( dev-lua/luadbi[postgres] )
+ sqlite? ( dev-lua/luadbi[sqlite] )
+ ssl? ( dev-lua/luasec )
+ zlib? ( dev-lua/lua-zlib )"
+
+S=${WORKDIR}/${MY_P}
+
+JABBER_ETC="/etc/jabber"
+JABBER_SPOOL="/var/spool/jabber"
+
+src_prepare() {
+ sed -i -e "s!MODULES = \$(DESTDIR)\$(PREFIX)/lib/!MODULES = \$(DESTDIR)\$(PREFIX)/$(get_libdir)/!"\
+ -e "s!SOURCE = \$(DESTDIR)\$(PREFIX)/lib/!SOURCE = \$(DESTDIR)\$(PREFIX)/$(get_libdir)/!"\
+ -e "s!INSTALLEDSOURCE = \$(PREFIX)/lib/!INSTALLEDSOURCE = \$(PREFIX)/$(get_libdir)/!"\
+ -e "s!INSTALLEDMODULES = \$(PREFIX)/lib/!INSTALLEDMODULES = \$(PREFIX)/$(get_libdir)/!"\
+ Makefile || die
+}
+
+src_configure() {
+ # the configure script is handcrafted (and yells at unknown options)
+ # hence do not use 'econf'
+ append-cflags -D_GNU_SOURCE
+ ./configure \
+ --ostype=linux \
+ --prefix="/usr" \
+ --sysconfdir="${JABBER_ETC}" \
+ --datadir="${JABBER_SPOOL}" \
+ --with-lua-include=/usr/include \
+ --with-lua-lib=/usr/$(get_libdir)/lua \
+ --cflags="${CFLAGS} -Wall -fPIC" \
+ --ldflags="${LDFLAGS} -shared" \
+ --c-compiler="$(tc-getCC)" \
+ --linker="$(tc-getCC)" \
+ --require-config || die "configure failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ newinitd "${FILESDIR}/${PN}".initd ${PN}
+}
+
+src_test() {
+ cd tests || die
+ ./run_tests.sh || die
+}