summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-11-03 11:38:40 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-11-03 11:38:40 +0000
commite4c85520a27dac1aa71ba44fcb6ab177f735b339 (patch)
treead3d5364beff3cc0c1aa4fab32137b98e2cab358 /net-im
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-e4c85520a27dac1aa71ba44fcb6ab177f735b339.tar.gz
gentoo-2-e4c85520a27dac1aa71ba44fcb6ab177f735b339.tar.bz2
gentoo-2-e4c85520a27dac1aa71ba44fcb6ab177f735b339.zip
#include fix and clean up wrt #343935
(Portage version: 2.2.0_alpha3/cvs/Linux x86_64)
Diffstat (limited to 'net-im')
-rw-r--r--net-im/cpop/ChangeLog8
-rw-r--r--net-im/cpop/cpop-0.0.4.ebuild22
-rw-r--r--net-im/cpop/files/cpop-0.0.4-implicit-exit_memset_strlen.patch38
3 files changed, 59 insertions, 9 deletions
diff --git a/net-im/cpop/ChangeLog b/net-im/cpop/ChangeLog
index 23c048296beb..6dd5029ddf97 100644
--- a/net-im/cpop/ChangeLog
+++ b/net-im/cpop/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-im/cpop
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/cpop/ChangeLog,v 1.5 2007/02/09 04:15:43 flameeyes Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/cpop/ChangeLog,v 1.6 2010/11/03 11:38:40 ssuominen Exp $
+
+ 03 Nov 2010; Samuli Suominen <ssuominen@gentoo.org> cpop-0.0.4.ebuild,
+ +files/cpop-0.0.4-implicit-exit_memset_strlen.patch:
+ #include fix and clean up wrt #343935
09 Feb 2007; Diego Pettenò <flameeyes@gentoo.org> ChangeLog:
Regenerate digest in Manifest2 format.
diff --git a/net-im/cpop/cpop-0.0.4.ebuild b/net-im/cpop/cpop-0.0.4.ebuild
index 6fa23d7b56c5..17d98ba2125d 100644
--- a/net-im/cpop/cpop-0.0.4.ebuild
+++ b/net-im/cpop/cpop-0.0.4.ebuild
@@ -1,6 +1,9 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/cpop/cpop-0.0.4.ebuild,v 1.5 2004/08/08 00:01:06 slarti Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/cpop/cpop-0.0.4.ebuild,v 1.6 2010/11/03 11:38:40 ssuominen Exp $
+
+EAPI=2
+inherit eutils
DESCRIPTION="GTK+ network popup message client. Compatible with the jpop protocol."
HOMEPAGE="http://www.draxil.uklinux.net/hip/index.pl?page=cpop"
@@ -8,13 +11,18 @@ SRC_URI="http://www.draxil.uklinux.net/hip/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86 ~ppc"
+KEYWORDS="~amd64 ~ppc ~x86"
IUSE=""
-DEPEND=">=x11-libs/gtk+-2.2.0
- >=dev-libs/glib-2.0.0"
+RDEPEND="dev-libs/glib:2
+ x11-libs/gtk+:2"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-implicit-exit_memset_strlen.patch
+}
src_install() {
- einstall || die
- dodoc COPYING ChangeLog INSTALL README
+ emake DESTDIR="${D}" install || die
+ dodoc README
}
diff --git a/net-im/cpop/files/cpop-0.0.4-implicit-exit_memset_strlen.patch b/net-im/cpop/files/cpop-0.0.4-implicit-exit_memset_strlen.patch
new file mode 100644
index 000000000000..3ce224c2910a
--- /dev/null
+++ b/net-im/cpop/files/cpop-0.0.4-implicit-exit_memset_strlen.patch
@@ -0,0 +1,38 @@
+pop_common.c:5:3: warning: incompatible implicit declaration of built-in function ‘exit’
+pop_common.c:10:3: warning: incompatible implicit declaration of built-in function ‘exit’
+pop_client.c:61:3: warning: incompatible implicit declaration of built-in function ‘exit’
+pop_gui_client.c:58:4: warning: incompatible implicit declaration of built-in function ‘memset’
+pop_gui_client.c:72:27: warning: incompatible implicit declaration of built-in function ‘strlen’
+pop_gui_client.c:128:3: warning: incompatible implicit declaration of built-in function ‘exit’
+
+--- pop_client.c
++++ pop_client.c
+@@ -1,11 +1,11 @@
+ #include <stdio.h>
++#include <stdlib.h>
+ #include <string.h>
+ #include <sys/socket.h>
+ #include <netinet/in.h>
+ #include <arpa/inet.h>
+ #include <errno.h>
+ #include <glib.h>
+-#include <stdio.h>
+ #include <netdb.h>
+ #include "pop_common.h"
+ #include "pop_client.h"
+--- pop_common.c
++++ pop_common.c
+@@ -1,4 +1,5 @@
+ #include <stdio.h>
++#include <stdlib.h>
+ void errquit(char *message)
+ {
+ perror(message);
+--- pop_gui_client.c
++++ pop_gui_client.c
+@@ -1,3 +1,5 @@
++#include <stdlib.h>
++#include <string.h>
+ #include <netdb.h>
+ #include <netinet/in.h>
+ #include <arpa/inet.h>