summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2014-05-01 07:11:48 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2014-05-01 07:11:48 +0000
commite0eff567d836f3a990de2d8ce0f336d99149c46b (patch)
tree215a412e83343c77758c93ad42d764be7413a4fb /net-im
parentAdd missing x86-fbsd keyword that is available on the underlying implementation. (diff)
downloadgentoo-2-e0eff567d836f3a990de2d8ce0f336d99149c46b.tar.gz
gentoo-2-e0eff567d836f3a990de2d8ce0f336d99149c46b.tar.bz2
gentoo-2-e0eff567d836f3a990de2d8ce0f336d99149c46b.zip
Version bump. Among others fixes CVE-2014-2741. Uncontrolled Resource Consumption with XMPP-Layer Compression, bug #507242 by Agostino Sarubbo.
(Portage version: 2.2.10_p15/cvs/Linux x86_64, signed Manifest commit with key 611FF3AA)
Diffstat (limited to 'net-im')
-rw-r--r--net-im/openfire/ChangeLog8
-rw-r--r--net-im/openfire/openfire-3.9.2.ebuild103
2 files changed, 110 insertions, 1 deletions
diff --git a/net-im/openfire/ChangeLog b/net-im/openfire/ChangeLog
index 291bb4084e12..419d426bbaff 100644
--- a/net-im/openfire/ChangeLog
+++ b/net-im/openfire/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-im/openfire
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/openfire/ChangeLog,v 1.56 2014/03/04 20:11:36 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/openfire/ChangeLog,v 1.57 2014/05/01 07:11:48 slyfox Exp $
+
+*openfire-3.9.2 (01 May 2014)
+
+ 01 May 2014; Sergei Trofimovich <slyfox@gentoo.org> +openfire-3.9.2.ebuild:
+ Version bump. Among others fixes CVE-2014-2741. Uncontrolled Resource
+ Consumption with XMPP-Layer Compression, bug #507242 by Agostino Sarubbo.
04 Mar 2014; Agostino Sarubbo <ago@gentoo.org> openfire-3.8.2-r1.ebuild:
Stable for x86, wrt bug #501390
diff --git a/net-im/openfire/openfire-3.9.2.ebuild b/net-im/openfire/openfire-3.9.2.ebuild
new file mode 100644
index 000000000000..0d1cc0f351f0
--- /dev/null
+++ b/net-im/openfire/openfire-3.9.2.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/openfire/openfire-3.9.2.ebuild,v 1.1 2014/05/01 07:11:48 slyfox Exp $
+
+inherit eutils java-pkg-2 java-ant-2 systemd
+
+MY_P=${PN}_src_${PV//./_}
+DESCRIPTION="Openfire (formerly wildfire) real time collaboration (RTC) server"
+HOMEPAGE="http://www.igniterealtime.org/projects/openfire/"
+SRC_URI="http://www.igniterealtime.org/builds/openfire/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND=">=virtual/jre-1.5"
+DEPEND="net-im/jabber-base
+ ~dev-java/ant-contrib-1.0_beta2
+ >=virtual/jdk-1.5"
+
+S=${WORKDIR}/${PN}_src
+
+QA_PREBUILT="opt/openfire/resources/nativeAuth/*.so"
+
+pkg_setup() {
+ if [ -f /etc/env.d/98openfire ]; then
+ einfo "This is an upgrade"
+ ewarn "As the plugin API changed, at least these plugins need to be updated also:"
+ ewarn "User Search, IM Gateway, Fastpath, Monitoring"
+ ewarn "they can be downloaded via Admin Console or at"
+ ewarn " ${HOMEPAGE}"
+ else
+ ewarn "If this is an upgrade stop right ( CONTROL-C ) and run the command:"
+ ewarn "echo 'CONFIG_PROTECT=\"/opt/openfire/resources/security/\"' > /etc/env.d/98openfire "
+ ewarn "For more info see bug #139708"
+ sleep 11
+ fi
+ java-pkg-2_pkg_setup
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-3.8.0-buildxml.patch
+ epatch "${FILESDIR}"/buildxml-ant.patch
+
+ # TODO should replace jars in build/lib with ones packaged by us -nichoj
+}
+
+src_compile() {
+ # Jikes doesn't support -source 1.5
+ java-pkg_filter-compiler jikes
+
+ ANT_TASKS="ant-contrib"
+ eant -f build/build.xml openfire plugins $(use_doc)
+}
+
+src_install() {
+ dodir /opt/openfire
+
+ newinitd "${FILESDIR}"/openfire-initd openfire
+ newconfd "${FILESDIR}"/openfire-confd openfire
+ systemd_dounit "${FILESDIR}"/${PN}.service
+
+ dodir /opt/openfire/conf
+ insinto /opt/openfire/conf
+ newins target/openfire/conf/openfire.xml openfire.xml.sample
+
+ dodir /opt/openfire/logs
+ keepdir /opt/openfire/logs
+
+ dodir /opt/openfire/lib
+ insinto /opt/openfire/lib
+ doins target/openfire/lib/*
+
+ dodir /opt/openfire/plugins
+ insinto /opt/openfire/plugins
+ doins -r target/openfire/plugins/*
+
+ dodir /opt/openfire/resources
+ insinto /opt/openfire/resources
+ doins -r target/openfire/resources/*
+
+ if use doc; then
+ dohtml -r documentation/docs/*
+ fi
+ dodoc documentation/dist/*
+
+ #Protect ssl key on upgrade
+ dodir /etc/env.d/
+ echo 'CONFIG_PROTECT="/opt/openfire/resources/security/"' > "${D}"/etc/env.d/98openfire
+}
+
+pkg_postinst() {
+ chown -R jabber:jabber /opt/openfire
+
+ ewarn If this is a new install, please edit /opt/openfire/conf/openfire.xml.sample
+ ewarn and save it as /opt/openfire/conf/openfire.xml
+ ewarn
+ ewarn The following must be be owned or writable by the jabber user.
+ ewarn /opt/openfire/conf/openfire.xml
+}