summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorBrandon Low <lostlogic@gentoo.org>2003-11-03 21:29:03 +0000
committerBrandon Low <lostlogic@gentoo.org>2003-11-03 21:29:03 +0000
commitdfa42d25bca491c98026d93a23ec46ae788076eb (patch)
tree74b81949fe5e72774bab0601bc38a044c22e1596 /net-im
parentBump encryption for bugfix (diff)
downloadgentoo-2-dfa42d25bca491c98026d93a23ec46ae788076eb.tar.gz
gentoo-2-dfa42d25bca491c98026d93a23ec46ae788076eb.tar.bz2
gentoo-2-dfa42d25bca491c98026d93a23ec46ae788076eb.zip
Bump encryption for bugfix
Diffstat (limited to 'net-im')
-rw-r--r--net-im/gaim/ChangeLog7
-rw-r--r--net-im/gaim/Manifest4
-rw-r--r--net-im/gaim/files/digest-gaim-0.72-r12
-rw-r--r--net-im/gaim/gaim-0.72-r1.ebuild82
4 files changed, 92 insertions, 3 deletions
diff --git a/net-im/gaim/ChangeLog b/net-im/gaim/ChangeLog
index e41aa8348f61..4d0a617a53c8 100644
--- a/net-im/gaim/ChangeLog
+++ b/net-im/gaim/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-im/gaim
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/gaim/ChangeLog,v 1.86 2003/11/01 08:08:08 lostlogic Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/gaim/ChangeLog,v 1.87 2003/11/03 21:29:01 lostlogic Exp $
+
+*gaim-0.72-r1 (03 Nov 2003)
+
+ 03 Nov 2003; Brandon Low <lostlogic@gentoo.org> gaim-0.72-r1.ebuild:
+ Bump encryption for bugfix
*gaim-0.72 (01 Nov 2003)
diff --git a/net-im/gaim/Manifest b/net-im/gaim/Manifest
index d9e1523dd2da..8348b9beb1ff 100644
--- a/net-im/gaim/Manifest
+++ b/net-im/gaim/Manifest
@@ -1,10 +1,10 @@
MD5 bed467c3e7077888cf4fd615c5f47678 gaim-0.67.ebuild 2185
MD5 7f89f602fb6fe4954a39c6909cbf3333 gaim-0.71-r2.ebuild 2658
-MD5 3ebf7cbaf55b8c11802a39b6b4e36667 gaim-0.72-r1.ebuild 2506
+MD5 3caf99d7bc93ab662a78b1ada1ae62be gaim-0.72-r1.ebuild 2509
MD5 01f40714eb213a4d4f1911cd3863b9da gaim-0.66-r3.ebuild 1987
MD5 59fe169133f9292aebafb199cb149a58 gaim-0.72.ebuild 2506
MD5 1a9b1940485519f26cffa675c833ca7d gaim-0.70-r2.ebuild 2506
-MD5 88b24d020241b5d2747682aa3d24098b ChangeLog 14758
+MD5 78abdd2f61163a8d6170955e83211c87 ChangeLog 14888
MD5 dc9ef26d3efea7cbe38cbe534cdeaa53 metadata.xml 510
MD5 5993641de8d56c2c433f252997c3c39c files/digest-gaim-0.67 135
MD5 e6a8773cabdf14d7422e573723258437 files/digest-gaim-0.72 135
diff --git a/net-im/gaim/files/digest-gaim-0.72-r1 b/net-im/gaim/files/digest-gaim-0.72-r1
new file mode 100644
index 000000000000..bd08cc5b99b3
--- /dev/null
+++ b/net-im/gaim/files/digest-gaim-0.72-r1
@@ -0,0 +1,2 @@
+MD5 2eb9478126ffc76b9a5f3cbf7cd82062 gaim-0.72.tar.bz2 3165345
+MD5 c7cea5b99b2e05f083db77032b0457d5 gaim-encryption-2.17.tar.gz 316928
diff --git a/net-im/gaim/gaim-0.72-r1.ebuild b/net-im/gaim/gaim-0.72-r1.ebuild
new file mode 100644
index 000000000000..0c6a0d975c66
--- /dev/null
+++ b/net-im/gaim/gaim-0.72-r1.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/gaim/gaim-0.72-r1.ebuild,v 1.1 2003/11/03 21:29:01 lostlogic Exp $
+
+IUSE="nls perl spell nas ssl"
+
+DESCRIPTION="GTK Instant Messenger client"
+HOMEPAGE="http://gaim.sourceforge.net/"
+EV=2.17
+SRC_URI="mirror://sourceforge/gaim/${P}.tar.bz2
+ ssl? ( mirror://sourceforge/gaim-encryption/gaim-encryption-${EV}.tar.gz )"
+RESTRICT="nomirror"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc"
+
+DEPEND="=sys-libs/db-1*
+ >=x11-libs/gtk+-2.0
+ >=dev-libs/glib-2.0
+ nas? ( >=media-libs/nas-1.4.1-r1 )
+ sys-devel/gettext
+ media-libs/libao
+ >=media-libs/audiofile-0.2.0
+ perl? ( >=dev-lang/perl-5.6.1
+ >=sys-apps/sed-4.0.0 )
+ dev-libs/nss
+ spell? ( >=app-text/gtkspell-2.0.2 )"
+
+src_unpack() {
+ unpack ${A} || die
+ use ssl && {
+ cd ${S}/plugins
+ unpack gaim-encryption-${EV}.tar.gz
+ }
+}
+
+src_compile() {
+
+ local myconf
+ use perl || myconf="${myconf} --disable-perl"
+ use spell || myconf="${myconf} --disable-gtkspell"
+ use nls || myconf="${myconf} --disable-nls"
+ use nas && myconf="${myconf} --enable-nas" || myconf="${myconf} --disable-nas"
+ myconf="${myconf} --with-nspr-includes=/usr/include/nspr"
+ myconf="${myconf} --with-nss-includes=/usr/include/nss"
+
+ econf ${myconf} || die "Configuration failed"
+ use perl && sed -i -e 's:^\(PERL_MM_PARAMS =.*PREFIX=\)\(.*\):\1'${D}'\2:' plugins/perl/Makefile
+ emake || MAKEOPTS="${MAKEOPTS} -j1" emake || die "Make failed"
+
+ use ssl && {
+ local myencconf
+ cd ${S}/plugins/gaim-encryption-${EV}
+
+ myencconf="${myencconf} --with-nspr-includes=/usr/include/nspr"
+ myencconf="${myencconf} --with-nss-includes=/usr/include/nss"
+ econf ${myencconf} || die "Configuration failed for encryption"
+ emake || die "Make failed for encryption"
+ }
+}
+
+src_install() {
+ einstall || die "Install failed"
+ use ssl && {
+ cd ${S}/plugins/gaim-encryption-${EV}
+ einstall || die "Install failed for encryption"
+ cd ${S}
+ }
+ dodoc ABOUT-NLS AUTHORS COPYING HACKING INSTALL NEWS PROGRAMMING_NOTES README ChangeLog VERSION
+}
+
+pkg_postinst() {
+ if [ `use ssl` ]; then
+ ewarn
+ ewarn "You have chosen (by selecting 'USE=ssl') to install"
+ ewarn "the gaim-encryption plugin ( http://gaim-encryption.sf.net/ )"
+ ewarn "this plugin is NOT supported by the Gaim project, and if you"
+ ewarn "expierence problems related to it, contact the Gentoo project"
+ ewarn "via http://bugs.gentoo.org/ or the gaim-encryption project."
+ fi
+}