summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorOlivier Crête <tester@gentoo.org>2007-05-26 20:34:30 +0000
committerOlivier Crête <tester@gentoo.org>2007-05-26 20:34:30 +0000
commitdef25d61331c66495c19d8400fda459ba657b6cf (patch)
tree374371bda6d0a1b85e98ea3800c3dbc641d461b8 /net-im
parentVersion bump, ~amd64, closes bug #147523 (diff)
downloadgentoo-2-def25d61331c66495c19d8400fda459ba657b6cf.tar.gz
gentoo-2-def25d61331c66495c19d8400fda459ba657b6cf.tar.bz2
gentoo-2-def25d61331c66495c19d8400fda459ba657b6cf.zip
Rename console use flag to ncurses to match standard and remove evil custom-cflags use flag
(Portage version: 2.1.2.2)
Diffstat (limited to 'net-im')
-rw-r--r--net-im/pidgin/ChangeLog7
-rw-r--r--net-im/pidgin/pidgin-2.0.0.ebuild28
-rw-r--r--net-im/pidgin/pidgin-2.0.1.ebuild26
3 files changed, 23 insertions, 38 deletions
diff --git a/net-im/pidgin/ChangeLog b/net-im/pidgin/ChangeLog
index d460bb4c255b..0e151c125df4 100644
--- a/net-im/pidgin/ChangeLog
+++ b/net-im/pidgin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-im/pidgin
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/pidgin/ChangeLog,v 1.12 2007/05/26 19:49:49 tester Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/pidgin/ChangeLog,v 1.13 2007/05/26 20:34:30 tester Exp $
+
+ 26 May 2007; Olivier Crête <tester@gentoo.org> pidgin-2.0.0.ebuild,
+ pidgin-2.0.1.ebuild:
+ Rename console use flag to ncurses to match standard and remove evil
+ custom-cflags use flag
*pidgin-2.0.1 (26 May 2007)
diff --git a/net-im/pidgin/pidgin-2.0.0.ebuild b/net-im/pidgin/pidgin-2.0.0.ebuild
index 474f1dbf47e9..a73c04a3097e 100644
--- a/net-im/pidgin/pidgin-2.0.0.ebuild
+++ b/net-im/pidgin/pidgin-2.0.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/pidgin/pidgin-2.0.0.ebuild,v 1.6 2007/05/25 09:16:49 drizzt Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/pidgin/pidgin-2.0.0.ebuild,v 1.7 2007/05/26 20:34:30 tester Exp $
inherit flag-o-matic eutils toolchain-funcs multilib autotools perl-app gnome2
@@ -13,8 +13,8 @@ SRC_URI="mirror://sourceforge/${PN}/${MY_PV}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE="avahi bonjour cjk crypt dbus debug doc eds gadu gnutls gstreamer meanwhile networkmanager nls perl silc startup-notification tcl tk xscreensaver custom-cflags spell ssl qq msn gadu"
-IUSE="${IUSE} gtk sasl console groupwise prediction" # mono"
+IUSE="avahi bonjour cjk crypt dbus debug doc eds gadu gnutls gstreamer meanwhile networkmanager nls perl silc startup-notification tcl tk xscreensaver spell ssl qq msn gadu"
+IUSE="${IUSE} gtk sasl ncurses groupwise prediction" # mono"
IUSE="${IUSE} krb4"
RDEPEND="
@@ -111,14 +111,6 @@ print_pidgin_warning() {
ewarn "Please read the pidgin FAQ at http://developer.pidgin.im/wiki/FAQ"
ewarn
einfo
- if use custom-cflags; then
- einfo "Note that you have chosen NOT TO FILTER UNSTABLE C[XX]FLAGS."
- einfo "DO NOT file bugs with GENTOO or UPSTREAM while using custom-cflags"
- einfo
- else
- einfo "Note that we are now filtering all unstable flags in C[XX]FLAGS."
- einfo
- fi
}
pkg_setup() {
@@ -140,7 +132,7 @@ pkg_setup() {
die "Configure failed"
fi
- if use console && ! built_with_use sys-libs/ncurses unicode; then
+ if use ncurses && ! built_with_use sys-libs/ncurses unicode; then
eerror
eerror "You need to rebuild sys-libs/ncurses with USE=unicode in order"
eerror "to build finch the console client of pidgin."
@@ -148,9 +140,9 @@ pkg_setup() {
die "Configure failed"
fi
- if ! use gtk && ! use console; then
+ if ! use gtk && ! use ncurses; then
einfo
- elog "As you did not pick gtk or console use flag, building"
+ elog "As you did not pick gtk or ncurses use flag, building"
elog "console only."
einfo
fi
@@ -173,9 +165,7 @@ src_unpack() {
src_compile() {
# Stabilize things, for your own good
- if ! use custom-cflags; then
- strip-flags
- fi
+ strip-flags
replace-flags -O? -O2
# -msse2 doesn't play nice on gcc 3.2
@@ -232,10 +222,10 @@ src_compile() {
myconf="${myconf} --x-includes=/usr/include/X11"
fi
- if ! use console && ! use gtk; then
+ if ! use ncurses && ! use gtk; then
myconf="${myconf} --enable-consoleui"
else
- myconf="${myconf} $(use_enable console consoleui) $(use_enable gtk gtkui)"
+ myconf="${myconf} $(use_enable ncurses consoleui) $(use_enable gtk gtkui)"
fi
econf \
diff --git a/net-im/pidgin/pidgin-2.0.1.ebuild b/net-im/pidgin/pidgin-2.0.1.ebuild
index 17ccef311612..b6352c847bea 100644
--- a/net-im/pidgin/pidgin-2.0.1.ebuild
+++ b/net-im/pidgin/pidgin-2.0.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/pidgin/pidgin-2.0.1.ebuild,v 1.1 2007/05/26 19:49:49 tester Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/pidgin/pidgin-2.0.1.ebuild,v 1.2 2007/05/26 20:34:30 tester Exp $
inherit flag-o-matic eutils toolchain-funcs multilib autotools perl-app gnome2
@@ -13,8 +13,8 @@ SRC_URI="mirror://sourceforge/${PN}/${MY_PV}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE="avahi bonjour cjk crypt dbus debug doc eds gadu gnutls gstreamer meanwhile networkmanager nls perl silc startup-notification tcl tk xscreensaver custom-cflags spell ssl qq msn gadu"
-IUSE="${IUSE} gtk sasl console groupwise prediction zephyr" # mono"
+IUSE="avahi bonjour cjk crypt dbus debug doc eds gadu gnutls gstreamer meanwhile networkmanager nls perl silc startup-notification tcl tk xscreensaver spell ssl qq msn gadu"
+IUSE="${IUSE} gtk sasl ncurses groupwise prediction zephyr" # mono"
RDEPEND="
bonjour? ( !avahi? ( net-misc/howl )
@@ -110,14 +110,6 @@ print_pidgin_warning() {
ewarn "Please read the pidgin FAQ at http://developer.pidgin.im/wiki/FAQ"
ewarn
einfo
- if use custom-cflags; then
- einfo "Note that you have chosen NOT TO FILTER UNSTABLE C[XX]FLAGS."
- einfo "DO NOT file bugs with GENTOO or UPSTREAM while using custom-cflags"
- einfo
- else
- einfo "Note that we are now filtering all unstable flags in C[XX]FLAGS."
- einfo
- fi
}
pkg_setup() {
@@ -139,7 +131,7 @@ pkg_setup() {
die "Configure failed"
fi
- if use console && ! built_with_use sys-libs/ncurses unicode; then
+ if use ncurses && ! built_with_use sys-libs/ncurses unicode; then
eerror
eerror "You need to rebuild sys-libs/ncurses with USE=unicode in order"
eerror "to build finch the console client of pidgin."
@@ -147,7 +139,7 @@ pkg_setup() {
die "Configure failed"
fi
- if ! use gtk && ! use console; then
+ if ! use gtk && ! use ncurses ; then
einfo
elog "As you did not pick gtk or console use flag, building"
elog "console only."
@@ -173,9 +165,7 @@ src_unpack() {
src_compile() {
# Stabilize things, for your own good
- if ! use custom-cflags; then
- strip-flags
- fi
+ strip-flags
replace-flags -O? -O2
# -msse2 doesn't play nice on gcc 3.2
@@ -236,10 +226,10 @@ src_compile() {
myconf="${myconf} --x-includes=/usr/include/X11"
fi
- if ! use console && ! use gtk; then
+ if ! use ncurses && ! use gtk; then
myconf="${myconf} --enable-consoleui"
else
- myconf="${myconf} $(use_enable console consoleui) $(use_enable gtk gtkui)"
+ myconf="${myconf} $(use_enable ncurses consoleui) $(use_enable gtk gtkui)"
fi
econf \