summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2007-07-13 23:13:06 +0000
committerTony Vroon <chainsaw@gentoo.org>2007-07-13 23:13:06 +0000
commitdd166e7e40e440f8e1c3cc998883954852a52f78 (patch)
treeaa12d9b587e0e8d566b12c54e7c9a771a17cddcc /net-im
parentVersion bump. See bug #177150. (diff)
downloadgentoo-2-dd166e7e40e440f8e1c3cc998883954852a52f78.tar.gz
gentoo-2-dd166e7e40e440f8e1c3cc998883954852a52f78.tar.bz2
gentoo-2-dd166e7e40e440f8e1c3cc998883954852a52f78.zip
Version bump, closes bug #179467. Suggested ebuild not used as I had to tame a wild build system that was pre-stripping binaries and not listening to --enable flags. Thanks to Edge <edge87@gmail.com> for help with a test account. Dropped ~alpha & ~hppa keywords over dev-tcltk/snack dependency, filed bug #185250.
(Portage version: 2.1.3_rc8)
Diffstat (limited to 'net-im')
-rw-r--r--net-im/amsn/ChangeLog13
-rw-r--r--net-im/amsn/amsn-0.97_rc1.ebuild75
-rw-r--r--net-im/amsn/files/amsn-0.97_rc1-autoconf-logic.patch31
-rw-r--r--net-im/amsn/files/amsn-0.97_rc1-nostrip.patch14
-rw-r--r--net-im/amsn/files/digest-amsn-0.97_rc13
5 files changed, 135 insertions, 1 deletions
diff --git a/net-im/amsn/ChangeLog b/net-im/amsn/ChangeLog
index b2ebdff8279d..b88ca069a8c1 100644
--- a/net-im/amsn/ChangeLog
+++ b/net-im/amsn/ChangeLog
@@ -1,6 +1,17 @@
# ChangeLog for net-im/amsn
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/amsn/ChangeLog,v 1.70 2007/04/30 14:06:44 yoswink Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/amsn/ChangeLog,v 1.71 2007/07/13 23:13:06 chainsaw Exp $
+
+*amsn-0.97_rc1 (13 Jul 2007)
+
+ 13 Jul 2007; Tony Vroon <chainsaw@gentoo.org>
+ +files/amsn-0.97_rc1-autoconf-logic.patch,
+ +files/amsn-0.97_rc1-nostrip.patch, +amsn-0.97_rc1.ebuild:
+ Version bump, closes bug #179467. Suggested ebuild not used as I had to tame
+ a wild build system that was pre-stripping binaries and not listening to
+ --enable flags. Thanks to Edge <edge87@gmail.com> for help with a test
+ account. Dropped ~alpha & ~hppa keywords over dev-tcltk/snack dependency,
+ filed bug #185250.
30 Apr 2007; Jose Luis Rivero <yoswink@gentoo.org> amsn-0.96-r1.ebuild:
Alpha stable wrt security bug #175563
diff --git a/net-im/amsn/amsn-0.97_rc1.ebuild b/net-im/amsn/amsn-0.97_rc1.ebuild
new file mode 100644
index 000000000000..46a68819c6ab
--- /dev/null
+++ b/net-im/amsn/amsn-0.97_rc1.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/amsn/amsn-0.97_rc1.ebuild,v 1.1 2007/07/13 23:13:06 chainsaw Exp $
+
+inherit autotools eutils fdo-mime gnome2-utils
+
+MY_P=${P/_rc/RC}
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="Alvaro's Messenger client for MSN"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
+HOMEPAGE="http://www.amsn-project.net"
+
+# The tests are interactive
+RESTRICT="test"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc -sparc ~x86"
+IUSE="debug static"
+
+DEPEND=">=dev-lang/tcl-8.4
+ >=dev-lang/tk-8.4
+ >=dev-tcltk/tls-1.4.1
+ media-libs/jpeg
+ media-libs/libpng
+ >=dev-tcltk/snack-2.2.10"
+
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-autoconf-logic.patch
+ epatch ${FILESDIR}/${P}-nostrip.patch
+ eaclocal
+ eautoconf
+ eautomake
+}
+
+src_compile() {
+ econf \
+ $(use_enable debug) \
+ $(use_enable static) \
+ || die "configure script failed"
+ emake || die "Compilation failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc AGREEMENT TODO README FAQ CREDITS
+
+ domenu amsn.desktop
+ sed -i -e s:.png:: ${D}/usr/share/applications/amsn.desktop
+
+ cd desktop-icons
+ for i in *; do
+ if [ -e ${i}/msn.png ]; then
+ insinto /usr/share/icons/hicolor/${i}/apps
+ doins ${i}/msn.png
+ fi
+ done
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ gnome2_icon_cache_update
+
+ ewarn "You might have to remove ~/.amsn prior to running as user if amsn hangs on start-up."
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ gnome2_icon_cache_update
+}
diff --git a/net-im/amsn/files/amsn-0.97_rc1-autoconf-logic.patch b/net-im/amsn/files/amsn-0.97_rc1-autoconf-logic.patch
new file mode 100644
index 000000000000..1b2a85cae2de
--- /dev/null
+++ b/net-im/amsn/files/amsn-0.97_rc1-autoconf-logic.patch
@@ -0,0 +1,31 @@
+--- configure.ac.orig 2007-07-13 23:27:25.000000000 +0100
++++ configure.ac 2007-07-13 23:29:44.000000000 +0100
+@@ -19,24 +19,24 @@
+ dnl compile time options
+
+ AC_ARG_ENABLE(debug,
+- [ --enable-debug enable some debuging informations],[enable_debug=yes])
++ [ --enable-debug enable some debugging information],[enable_debug=$enableval],[enable_debug=no])
+
+-AC_SUBST(DEBUG)
+ if test "$enable_debug" == "yes" ; then
+ DEBUG="yes"
+ else
+ DEBUG="no"
+ fi
++AC_SUBST(DEBUG)
+
+ AC_ARG_ENABLE(static,
+- [ --enable-static enable static link of libstdc++],[enable_static=yes])
++ [ --enable-static enable static link of libstdc++],[enable_static=$enableval],[enable_static=no])
+
+-AC_SUBST(STATIC)
+ if test "$enable_static" == "yes" ; then
+ STATIC="yes"
+ else
+ STATIC="no"
+ fi
++AC_SUBST(STATIC)
+
+ dnl subst configure command
+ AC_SUBST(CONFIGURE_ARGS)
diff --git a/net-im/amsn/files/amsn-0.97_rc1-nostrip.patch b/net-im/amsn/files/amsn-0.97_rc1-nostrip.patch
new file mode 100644
index 000000000000..53a5a7d7229d
--- /dev/null
+++ b/net-im/amsn/files/amsn-0.97_rc1-nostrip.patch
@@ -0,0 +1,14 @@
+--- Makefile.in.orig 2007-07-13 23:06:37.000000000 +0100
++++ Makefile.in 2007-07-13 23:07:20.000000000 +0100
+@@ -107,11 +107,6 @@
+ LDFLAGS := @LDFLAGS@
+ endif
+
+-ifeq (@DEBUG@,no)
+- ifneq (@FOUND_OS@,mac)
+-LDFLAGS += -s
+- endif
+-endif
+ X_LIBS := @X_LIBS@
+ CXX_LIB := @CXX_LIB@
+
diff --git a/net-im/amsn/files/digest-amsn-0.97_rc1 b/net-im/amsn/files/digest-amsn-0.97_rc1
new file mode 100644
index 000000000000..1f49d575c1ba
--- /dev/null
+++ b/net-im/amsn/files/digest-amsn-0.97_rc1
@@ -0,0 +1,3 @@
+MD5 382431ba91ae014daf9148dd5b5674b6 amsn-0.97RC1.tar.bz2 6294926
+RMD160 8a01e6880643a920b7e44882599faf2eae900911 amsn-0.97RC1.tar.bz2 6294926
+SHA256 2dcaa349f7c5335f9c63633afcc1736aae6da1ba6ca3c6fa341817a5a0bad327 amsn-0.97RC1.tar.bz2 6294926