summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorJauhien Piatlicki <jauhien@gentoo.org>2014-06-18 20:58:03 +0000
committerJauhien Piatlicki <jauhien@gentoo.org>2014-06-18 20:58:03 +0000
commitd7af7329c7b096dd3b25a5d6fd252c8a032d70cb (patch)
tree80bb144828056679e55d213d80b2b3fa2f59d75b /net-im
parentUpdate dependencies to require guaranteed EAPI=5 or multilib ebuilds, bug #51... (diff)
downloadgentoo-2-d7af7329c7b096dd3b25a5d6fd252c8a032d70cb.tar.gz
gentoo-2-d7af7329c7b096dd3b25a5d6fd252c8a032d70cb.tar.bz2
gentoo-2-d7af7329c7b096dd3b25a5d6fd252c8a032d70cb.zip
version bump, closing bug #513712, thanks to Manuel Rüger
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB2EFA1D4)
Diffstat (limited to 'net-im')
-rw-r--r--net-im/skype/ChangeLog8
-rw-r--r--net-im/skype/files/skype-4.3.0.37-desktop.patch15
-rw-r--r--net-im/skype/skype-4.3.0.37.ebuild126
3 files changed, 148 insertions, 1 deletions
diff --git a/net-im/skype/ChangeLog b/net-im/skype/ChangeLog
index 71771164ca9d..f8dd02ccf99f 100644
--- a/net-im/skype/ChangeLog
+++ b/net-im/skype/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-im/skype
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/skype/ChangeLog,v 1.155 2014/06/18 20:33:44 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/skype/ChangeLog,v 1.156 2014/06/18 20:58:03 jauhien Exp $
+
+*skype-4.3.0.37 (18 Jun 2014)
+
+ 18 Jun 2014; Jauhien Piatlicki <jauhien@gentoo.org>
+ +files/skype-4.3.0.37-desktop.patch, +skype-4.3.0.37.ebuild:
+ version bump, closing bug #513712, thanks to Manuel Rüger
18 Jun 2014; Michał Górny <mgorny@gentoo.org> skype-2.2.0.35-r99.ebuild,
skype-4.0.0.8-r1.ebuild, skype-4.1.0.20.ebuild, skype-4.2.0.11-r1.ebuild,
diff --git a/net-im/skype/files/skype-4.3.0.37-desktop.patch b/net-im/skype/files/skype-4.3.0.37-desktop.patch
new file mode 100644
index 000000000000..af31e0e34aea
--- /dev/null
+++ b/net-im/skype/files/skype-4.3.0.37-desktop.patch
@@ -0,0 +1,15 @@
+--- skype.desktop
++++ skype.desktop
+@@ -2,10 +2,10 @@
+ Name=Skype
+ Comment=Skype Internet Telephony
+ Exec=skype %U
+-Icon=skype.png
++Icon=skype
+ Terminal=false
+ Type=Application
+ Encoding=UTF-8
+-Categories=Network;Application;
++Categories=Network;InstantMessaging;Telephony;
+ MimeType=x-scheme-handler/skype;
+ X-KDE-Protocols=skype
diff --git a/net-im/skype/skype-4.3.0.37.ebuild b/net-im/skype/skype-4.3.0.37.ebuild
new file mode 100644
index 000000000000..06c936fbdb99
--- /dev/null
+++ b/net-im/skype/skype-4.3.0.37.ebuild
@@ -0,0 +1,126 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/skype/skype-4.3.0.37.ebuild,v 1.1 2014/06/18 20:58:03 jauhien Exp $
+
+EAPI=5
+
+inherit eutils gnome2-utils pax-utils
+
+DESCRIPTION="P2P Internet Telephony (VoiceIP) client"
+HOMEPAGE="http://www.skype.com/"
+SRC_URI="http://download.${PN}.com/linux/${P}.tar.bz2"
+
+LICENSE="${PN}-4.0.0.7-copyright ${PN}-4.0.0.7-third-party_attributions.txt"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="pax_kernel selinux"
+
+QA_PREBUILT=opt/bin/${PN}
+RESTRICT="mirror strip" #299368
+
+EMUL_X86_VER=20120520
+
+RDEPEND="
+ virtual/ttf-fonts
+ amd64? (
+ || (
+ (
+ dev-qt/qtcore:4[abi_x86_32(-)]
+ dev-qt/qtdbus:4[abi_x86_32(-)]
+ dev-qt/qtgui:4[accessibility,abi_x86_32(-)]
+ dev-qt/qtwebkit:4[abi_x86_32(-)]
+ )
+ >=app-emulation/emul-linux-x86-qtlibs-${EMUL_X86_VER}
+ )
+ || (
+ media-libs/alsa-lib[abi_x86_32(-)]
+ >=app-emulation/emul-linux-x86-soundlibs-${EMUL_X86_VER}
+ )
+ || (
+ (
+ x11-libs/libX11[abi_x86_32(-)]
+ x11-libs/libXext[abi_x86_32(-)]
+ x11-libs/libXScrnSaver[abi_x86_32(-)]
+ x11-libs/libXv[abi_x86_32(-)]
+ )
+ >=app-emulation/emul-linux-x86-xlibs-${EMUL_X86_VER}
+ )
+ )
+ x86? (
+ media-libs/alsa-lib
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXScrnSaver
+ x11-libs/libXv
+ dev-qt/qtcore:4
+ dev-qt/qtdbus:4
+ dev-qt/qtgui:4[accessibility]
+ dev-qt/qtwebkit:4
+ )
+ selinux? ( sec-policy/selinux-skype )"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-desktop.patch"
+}
+
+src_compile() {
+ if type -P lrelease >/dev/null; then
+ lrelease lang/*.ts || die
+ fi
+ rm -f lang/*.ts || die
+}
+
+src_install() {
+ into /opt
+ dobin ${PN}
+ fowners root:audio /opt/bin/${PN}
+
+ insinto /etc/dbus-1/system.d
+ doins ${PN}.conf
+
+ insinto /usr/share/skype
+ doins -r avatars lang sounds
+
+ dodoc README
+
+ local res
+ for res in 16 32 48 64 96 128 256; do
+ newicon -s ${res} icons/SkypeBlue_${res}x${res}.png ${PN}.png
+ done
+
+ domenu skype.desktop
+
+ if use pax_kernel; then
+ pax-mark Cm "${ED}"/opt/bin/${PN} || die
+ eqawarn "You have set USE=pax_kernel meaning that you intend to run"
+ eqawarn "${PN} under a PaX enabled kernel. To do so, we must modify"
+ eqawarn "the ${PN} binary itself and this *may* lead to breakage! If"
+ eqawarn "you suspect that ${PN} is being broken by this modification,"
+ eqawarn "please open a bug."
+ fi
+
+ echo PRELINK_PATH_MASK=/opt/bin/${PN} > ${T}/99${PN}
+ doenvd "${T}"/99${PN} #430142
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+
+ rm -rf "${EROOT}"/usr/share/${PN} #421165
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+
+ # http://bugs.gentoo.org/360815
+ elog "For webcam support, see \"LD_PRELOAD\" section of \"README.lib\" document provided by"
+ elog "media-libs/libv4l package and \"README\" document of this package."
+ if use amd64; then
+ elog "You can install app-emulation/emul-linux-x86-medialibs package for the 32bit"
+ elog "libraries from the media-libs/libv4l package."
+ fi
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}