summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorDominik Kapusta <ayoy@gentoo.org>2009-09-20 07:46:22 +0000
committerDominik Kapusta <ayoy@gentoo.org>2009-09-20 07:46:22 +0000
commitd731d2e92b543bac1be2bd27c3ed7239b62fbd72 (patch)
treeccfa44b1a8063623d6132b41eb2dbb6bfe66e103 /net-im
parentFix tests patch to work fully without system gtk-doc (diff)
downloadgentoo-2-d731d2e92b543bac1be2bd27c3ed7239b62fbd72.tar.gz
gentoo-2-d731d2e92b543bac1be2bd27c3ed7239b62fbd72.tar.bz2
gentoo-2-d731d2e92b543bac1be2bd27c3ed7239b62fbd72.zip
Adding patch to fix compilation without OAuth support. Thanks to Dragon Jake for reporting.
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'net-im')
-rw-r--r--net-im/qtwitter/ChangeLog7
-rw-r--r--net-im/qtwitter/files/qtwitter-0.9.0-no-oauth-fix.patch37
-rw-r--r--net-im/qtwitter/metadata.xml7
-rw-r--r--net-im/qtwitter/qtwitter-0.9.0.ebuild5
4 files changed, 47 insertions, 9 deletions
diff --git a/net-im/qtwitter/ChangeLog b/net-im/qtwitter/ChangeLog
index d1ae1fdb2677..fc60592592a9 100644
--- a/net-im/qtwitter/ChangeLog
+++ b/net-im/qtwitter/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-im/qtwitter
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/qtwitter/ChangeLog,v 1.14 2009/09/12 10:07:24 wired Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/qtwitter/ChangeLog,v 1.15 2009/09/20 07:46:21 ayoy Exp $
+
+ 20 Sep 2009; Dominik Kapusta <ayoy@gentoo.org> qtwitter-0.9.0.ebuild,
+ +files/qtwitter-0.9.0-no-oauth-fix.patch, metadata.xml:
+ Adding patch to fix compilation without OAuth support. Thanks to Dragon
+ Jake for reporting.
*qtwitter-0.9.0 (12 Sep 2009)
diff --git a/net-im/qtwitter/files/qtwitter-0.9.0-no-oauth-fix.patch b/net-im/qtwitter/files/qtwitter-0.9.0-no-oauth-fix.patch
new file mode 100644
index 000000000000..41758f914532
--- /dev/null
+++ b/net-im/qtwitter/files/qtwitter-0.9.0-no-oauth-fix.patch
@@ -0,0 +1,37 @@
+diff --git a/qtwitter-app/src/statuslist.cpp b/qtwitter-app/src/statuslist.cpp
+index 4b3fec5..c5b5673 100644
+--- a/qtwitter-app/src/statuslist.cpp
++++ b/qtwitter-app/src/statuslist.cpp
+@@ -25,7 +25,9 @@
+ #include <QPixmap>
+
+ #include <account.h>
+-#include <oauthwizard.h>
++#ifdef OAUTH
++# include <oauthwizard.h>
++#endif
+ #include "imagedownload.h"
+ #include "core.h"
+ #include "dmdialog.h"
+diff --git a/twitterapi/twitterapi.cpp b/twitterapi/twitterapi.cpp
+index d4e69cc..eed4496 100644
+--- a/twitterapi/twitterapi.cpp
++++ b/twitterapi/twitterapi.cpp
+@@ -284,7 +284,7 @@ TwitterAPI::TwitterAPI( const QString &serviceUrl, const QString &login,
+ }
+ #else
+ TwitterAPI::TwitterAPI( const QString &serviceUrl, const QString &login,
+- const QString &password, QObject *parent = 0 ) :
++ const QString &password, QObject *parent ) :
+ QObject( parent ),
+ d_ptr( new TwitterAPIPrivate )
+ {
+@@ -444,7 +444,7 @@ void TwitterAPI::postUpdate( const QString &data, quint64 inReplyTo )
+ #else
+ QByteArray auth = d->login.toUtf8() + ":" + d->password.toUtf8();
+ request.setRawHeader( "Authorization", "Basic " + auth.toBase64() );
+- content = prepareRequest( data, inReplyTo );
++ content = d->prepareRequest( data, inReplyTo );
+ #endif
+
+ request.setUrl( QUrl(url) );
diff --git a/net-im/qtwitter/metadata.xml b/net-im/qtwitter/metadata.xml
index 1f9ce8d3f18f..099738bf66ef 100644
--- a/net-im/qtwitter/metadata.xml
+++ b/net-im/qtwitter/metadata.xml
@@ -6,13 +6,8 @@
<flag name="oauth">Enables authorization using OAuth for Twitter accounts</flag>
</use>
<maintainer>
-<email>hwoarang@gentoo.org</email>
-<name>Markos Chandras</name>
-</maintainer>
-<maintainer>
-<email>d@ayoy.net</email>
+<email>ayoy@gentoo.org</email>
<name>Dominik Kapusta</name>
-<description>Upstream developer, proxy maintainer</description>
</maintainer>
<longdescription lang="en">
</longdescription>
diff --git a/net-im/qtwitter/qtwitter-0.9.0.ebuild b/net-im/qtwitter/qtwitter-0.9.0.ebuild
index a0cb0f51f49f..d4738e5afbc7 100644
--- a/net-im/qtwitter/qtwitter-0.9.0.ebuild
+++ b/net-im/qtwitter/qtwitter-0.9.0.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/qtwitter/qtwitter-0.9.0.ebuild,v 1.1 2009/09/12 10:07:24 wired Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/qtwitter/qtwitter-0.9.0.ebuild,v 1.2 2009/09/20 07:46:21 ayoy Exp $
EAPI="2"
-inherit qt4
+inherit qt4 eutils
DESCRIPTION="A Qt-based client for Twitter and Identi.ca"
HOMEPAGE="http://www.qt-apps.org/content/show.php/qTwitter?content=99087"
@@ -59,6 +59,7 @@ src_prepare() {
if ! use oauth; then
sed -i '/DEFINES += OAUTH/d' ${PN}.pri || die "sed failed"
+ epatch "${FILESDIR}/${P}-no-oauth-fix.patch"
fi
}