summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-07-31 18:53:05 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-07-31 18:53:05 +0000
commitca1c361b52186a7e21e1b2befa6a4a50cbd182e4 (patch)
tree7bfbaa24216e28e0aa9274f6483e118a9ae9f80e /net-im
parentppc stable, bug #140644 (diff)
downloadgentoo-2-ca1c361b52186a7e21e1b2befa6a4a50cbd182e4.tar.gz
gentoo-2-ca1c361b52186a7e21e1b2befa6a4a50cbd182e4.tar.bz2
gentoo-2-ca1c361b52186a7e21e1b2befa6a4a50cbd182e4.zip
Add patch to fix yet-again more ICQ protocol changes, see KDE BUG #130630.
(Portage version: 2.1.1_pre4-r1)
Diffstat (limited to 'net-im')
-rw-r--r--net-im/kopete/ChangeLog9
-rw-r--r--net-im/kopete/files/digest-kopete-0.12.1-r33
-rw-r--r--net-im/kopete/files/kopete-0.12.1-icqfix3.patch13
-rw-r--r--net-im/kopete/kopete-0.12.1-r3.ebuild136
4 files changed, 160 insertions, 1 deletions
diff --git a/net-im/kopete/ChangeLog b/net-im/kopete/ChangeLog
index 9a33074a875a..8ca5d13823d4 100644
--- a/net-im/kopete/ChangeLog
+++ b/net-im/kopete/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-im/kopete
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/kopete/ChangeLog,v 1.75 2006/07/30 14:36:43 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/kopete/ChangeLog,v 1.76 2006/07/31 18:53:05 flameeyes Exp $
+
+*kopete-0.12.1-r3 (31 Jul 2006)
+
+ 31 Jul 2006; Diego Pettenò <flameeyes@gentoo.org>
+ +files/kopete-0.12.1-icqfix3.patch, -kopete-0.12.1-r2.ebuild,
+ +kopete-0.12.1-r3.ebuild:
+ Add patch to fix yet-again more ICQ protocol changes, see KDE BUG #130630.
*kopete-0.12.1-r2 (30 Jul 2006)
diff --git a/net-im/kopete/files/digest-kopete-0.12.1-r3 b/net-im/kopete/files/digest-kopete-0.12.1-r3
new file mode 100644
index 000000000000..2f6f75f34afa
--- /dev/null
+++ b/net-im/kopete/files/digest-kopete-0.12.1-r3
@@ -0,0 +1,3 @@
+MD5 b646f2f45fc0fbcd56ada5078fb540fb kopete-0.12.1.tar.bz2 5309636
+RMD160 0bb66fb0a8a0d12b0d19845d5a39993520cb368d kopete-0.12.1.tar.bz2 5309636
+SHA256 a18174bf48257361c6a337073e2fa1c7dc0b0eba274d558ac9fd5bc84275927e kopete-0.12.1.tar.bz2 5309636
diff --git a/net-im/kopete/files/kopete-0.12.1-icqfix3.patch b/net-im/kopete/files/kopete-0.12.1-icqfix3.patch
new file mode 100644
index 000000000000..ac786297eb5e
--- /dev/null
+++ b/net-im/kopete/files/kopete-0.12.1-icqfix3.patch
@@ -0,0 +1,13 @@
+Index: kopete/protocols/oscar/liboscar/oscartypes.h
+===================================================================
+--- kopete/protocols/oscar/liboscar/oscartypes.h (revision 568242)
++++ kopete/protocols/oscar/liboscar/oscartypes.h (revision 568243)
+@@ -239,7 +239,7 @@
+ const WORD ICQ_MAJOR = 0x0014;
+ const WORD ICQ_MINOR = 0x0034;
+ const WORD ICQ_POINT = 0x0000;
+- const WORD ICQ_BUILD = 0x0A0F;
++ const WORD ICQ_BUILD = 0x0BB8;
+ const char ICQ_OTHER[] = { 0x00, 0x00, 0x04, 0x3d };
+ const char ICQ_COUNTRY[] = "us";
+ const char ICQ_LANG[] = "en";
diff --git a/net-im/kopete/kopete-0.12.1-r3.ebuild b/net-im/kopete/kopete-0.12.1-r3.ebuild
new file mode 100644
index 000000000000..5185de4a62d2
--- /dev/null
+++ b/net-im/kopete/kopete-0.12.1-r3.ebuild
@@ -0,0 +1,136 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/kopete/kopete-0.12.1-r3.ebuild,v 1.1 2006/07/31 18:53:05 flameeyes Exp $
+
+inherit kde eutils
+
+MY_P="${P/_/-}"
+MY_P="${MY_P/.0/}"
+
+DESCRIPTION="KDE multi-protocol IM client"
+HOMEPAGE="http://kopete.kde.org/"
+LICENSE="GPL-2"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="jingle sametime ssl xmms xscreensaver slp kernel_linux latex crypt
+ winpopup sms irc yahoo gadu groupwise netmeeting statistics autoreplace
+ connectionstatus contactnotes translator webpresence texteffect highlight
+ alias autoreplace history nowlistening addbookmarks"
+
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
+
+# The kernel_linux? ( ) conditional dependencies are for webcams, not supported
+# on other kernels AFAIK
+BOTH_DEPEND="dev-libs/libxslt
+ dev-libs/libxml2
+ net-dns/libidn
+ >=dev-libs/glib-2
+ app-crypt/qca
+ slp? ( net-libs/openslp )
+ jingle? (
+ >=media-libs/speex-1.1.6
+ dev-libs/expat
+ ~net-libs/ortp-0.7.1 )
+ sametime? ( =net-libs/meanwhile-0.4* )
+ xmms? ( media-sound/xmms )
+ || ( (
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXrender
+ xscreensaver? ( x11-libs/libXScrnSaver )
+ ) <virtual/x11-7 )
+ kernel_linux? ( virtual/opengl )
+ sms? ( app-mobilephone/gsmlib )"
+
+RDEPEND="${BOTH_DEPEND}
+ ssl? ( app-crypt/qca-tls )
+ !kde-base/kopete
+ !kde-base/kdenetwork
+ latex? ( virtual/tetex )
+ crypt? ( app-crypt/gnupg )"
+# gnomemeeting is deprecated and ekiga is not yet ~ppc64
+# only needed for calling
+# netmeeting? ( net-im/gnomemeeting )"
+
+DEPEND="${BOTH_DEPEND}
+ kernel_linux? ( virtual/os-headers )
+ || ( (
+ x11-proto/videoproto
+ x11-proto/xextproto
+ x11-proto/xproto
+ kernel_linux? ( x11-libs/libXv )
+ xscreensaver? ( x11-proto/scrnsaverproto )
+ ) <virtual/x11-7 )"
+
+need-kde 3.4
+
+#dev-libs/ilbc-rfc3951: could not see any benifit in it
+#sed -i 's:ilbc_found="no":ilbc_found="yes":' ${S}/kopete/protocols/jabber/jingle/configure.in.in
+
+pkg_setup() {
+ if use kernel_linux && ! built_with_use =x11-libs/qt-3* opengl; then
+ eerror "To support Video4Linux webcams in this package is required to have"
+ eerror "=x11-libs/qt-3* compiled with OpenGL support."
+ eerror "Please reemerge =x11-libs/qt-3* with USE=\"opengl\"."
+ die "Please reemerge =x11-libs/qt-3* with USE=\"opengl\"."
+ fi
+}
+
+kopete_disable() {
+ einfo "Disabling $2 $1"
+ sed -i -e "s/$2//" "${S}/kopete/$1s/Makefile.am"
+}
+
+src_unpack() {
+ kde_src_unpack
+ epatch "${FILESDIR}/${PN}-0.12_alpha1-xscreensaver.patch"
+ # use ekiga instead of gnomemeeting by default
+ epatch "${FILESDIR}/gnomemeeting-ekiga.patch"
+ # Bug #141675
+ epatch "${FILESDIR}/${P}-oscarcontacts.patch"
+ # KDE BUG #130630
+ epatch "${FILESDIR}/${P}-icqfix3.patch"
+
+ use latex || kopete_disable plugin latex
+ use crypt || kopete_disable plugin cryptography
+ use netmeeting || kopete_disable plugin netmeeting
+ use statistics || kopete_disable plugin statistics
+ use autoreplace || kopete_disable plugin autoreplace
+ use connectionstatus || kopete_disable plugin connectionstatus
+ use contactnotes || kopete_disable plugin contactnotes
+ use translator || kopete_disable plugin translator
+ use webpresence || kopete_disable plugin webpresence
+ use texteffect || kopete_disable plugin texteffect
+ use highlight || kopete_disable plugin highlight
+ use alias || kopete_disable plugin alias
+ use addbookmarks || kopete_disable plugin addbookmarks
+ use history || kopete_disable plugin history
+ use nowlistening || kopete_disable plugin nowlistening
+
+ use winpopup || kopete_disable protocol winpopup
+ use gadu || kopete_disable protocol '\$(GADU)'
+ use irc || kopete_disable protocol irc
+ use groupwise || kopete_disable protocol groupwise
+ use yahoo || kopete_disable protocol yahoo
+
+ rm -f "${S}/configure"
+}
+
+src_compile() {
+ # External libgadu support - doesn't work, kopete requires a specific development snapshot of libgadu.
+ # Maybe we can enable it in the future.
+ # The nowlistening plugin has xmms support.
+ local myconf="$(use_enable jingle)
+ $(use_enable sametime sametime-plugin)
+ $(use_with xmms) --without-external-libgadu
+ $(use_with xscreensaver) $(use_enable sms smsgsm)
+ $(use_enable debug testbed)"
+
+ kde_src_compile
+}
+
+src_install() {
+ kde_src_install
+
+ rm -f "${D}"/usr/bin/{stun,relay}server
+}