summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2009-10-23 12:49:13 +0000
committerPeter Volkov <pva@gentoo.org>2009-10-23 12:49:13 +0000
commitba52804020cf6b8443cdfb3bfde8899f5c5872e8 (patch)
treea8ef4e2d9b4ed2227656f91673805f330374887c /net-im
parentSay thanks. (diff)
downloadgentoo-2-ba52804020cf6b8443cdfb3bfde8899f5c5872e8.tar.gz
gentoo-2-ba52804020cf6b8443cdfb3bfde8899f5c5872e8.tar.bz2
gentoo-2-ba52804020cf6b8443cdfb3bfde8899f5c5872e8.zip
Disable kde support, should fix build issue with kde4 installed, bug #275316, thank Anton Bolshakov and DaggyStyle for report and investigation of the problem.
(Portage version: 2.1.7.1/cvs/Linux x86_64)
Diffstat (limited to 'net-im')
-rw-r--r--net-im/sim/ChangeLog7
-rw-r--r--net-im/sim/sim-0.9.4.3-r3.ebuild53
2 files changed, 17 insertions, 43 deletions
diff --git a/net-im/sim/ChangeLog b/net-im/sim/ChangeLog
index 663f23627a0d..62c09b522c0b 100644
--- a/net-im/sim/ChangeLog
+++ b/net-im/sim/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-im/sim
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/sim/ChangeLog,v 1.96 2009/10/10 19:55:06 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/sim/ChangeLog,v 1.97 2009/10/23 12:49:13 pva Exp $
+
+ 23 Oct 2009; Peter Volkov <pva@gentoo.org> sim-0.9.4.3-r3.ebuild:
+ Disable kde support, should fix build issue with kde4 installed, bug
+ #275316, thank Anton Bolshakov and DaggyStyle for report and investigation
+ of the problem.
10 Oct 2009; Peter Volkov <pva@gentoo.org> -sim-0.9.4.3-r1.ebuild,
-sim-0.9.4.3-r2.ebuild:
diff --git a/net-im/sim/sim-0.9.4.3-r3.ebuild b/net-im/sim/sim-0.9.4.3-r3.ebuild
index dea77ad686fb..1e071278da69 100644
--- a/net-im/sim/sim-0.9.4.3-r3.ebuild
+++ b/net-im/sim/sim-0.9.4.3-r3.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/sim/sim-0.9.4.3-r3.ebuild,v 1.5 2009/07/07 23:20:37 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/sim/sim-0.9.4.3-r3.ebuild,v 1.6 2009/10/23 12:49:13 pva Exp $
EAPI=1
-inherit kde-functions eutils flag-o-matic
+inherit eutils flag-o-matic
DESCRIPTION="Simple Instant Messenger (with KDE support). ICQ/AIM/Jabber/MSN/Yahoo."
HOMEPAGE="http://sim-im.org/"
@@ -14,15 +14,12 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ppc x86"
-IUSE="debug kde spell ssl"
+IUSE="debug spell ssl"
RESTRICT="fetch"
-# kdebase-data provides the icon "licq.png"
-RDEPEND="kde? ( =kde-base/kdelibs-3.5*
- || ( =kde-base/kdebase-data-3.5* =kde-base/kdebase-3.5* ) )
- !kde? ( x11-libs/qt:3
- spell? ( app-text/aspell ) )
+RDEPEND="x11-libs/qt:3
+ spell? ( app-text/aspell )
ssl? ( dev-libs/openssl )
dev-libs/libxml2
dev-libs/libxslt
@@ -36,7 +33,7 @@ DEPEND="${RDEPEND}
pkg_nofetch() {
elog "${CATEGORY}/${P} contains icons and sounds with unclear licensing and thus"
- elog "you have to download and it put into '${DISTDIR}' by yourself."
+ elog "you have to download it and put into '${DISTDIR}' by yourself."
elog "Download location:"
echo
elog "${SRC_URI}"
@@ -45,31 +42,6 @@ pkg_nofetch() {
elog "information."
}
-pkg_setup() {
- if use kde; then
- if use spell; then
- if ! built_with_use "=kde-base/kdelibs-3.5*" spell; then
- ewarn "kde-base/kdelibs were merged without spell in USE."
- ewarn "Thus spelling will not work in sim. Please, either"
- ewarn "reemerge kde-base/kdelibs with spell in USE or emerge"
- ewarn 'sim with USE="-spell" to avoid this message.'
- ebeep
- fi
- else
- if built_with_use "=kde-base/kdelibs-3.5*" spell; then
- ewarn 'kde-base/kdelibs were merged with spell in USE.'
- ewarn 'Thus spelling will work in sim. Please, either'
- ewarn 'reemerge kde-base/kdelibs without spell in USE or emerge'
- ewarn 'sim with USE="spell" to avoid this message.'
- ebeep
- fi
- fi
- if ! built_with_use "=kde-base/kdelibs-3.5*" arts; then
- myconf="--without-arts"
- fi
- fi
-}
-
src_unpack() {
unpack ${A}
cd "${S}"
@@ -78,22 +50,19 @@ src_unpack() {
epatch "${FILESDIR}"/${P}-sslv23.patch
epatch ../${P}-r1919_1924.patch
epatch "${FILESDIR}"/${P}-old-protocol.patch
- if use kde; then
- set-kdedir 3
- fi
}
src_compile() {
- filter-flags -fstack-protector -fstack-protector-all
-
# Workaround for bug #119906
append-flags -fno-stack-protector
- use kde || use spell || export DO_NOT_COMPILE="$DO_NOT_COMPILE plugins/spell"
+ use spell || export DO_NOT_COMPILE="$DO_NOT_COMPILE plugins/spell"
- econf ${myconf} $(use_enable kde) \
+ econf ${myconf} \
$(use_with ssl) \
- $(use_enable debug) || die "econf failed"
+ $(use_enable debug) \
+ --without-arts \
+ --disable-kde
emake -j1 || die "make failed"
}