summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorDonny Davies <woodchip@gentoo.org>2001-08-30 05:56:16 +0000
committerDonny Davies <woodchip@gentoo.org>2001-08-30 05:56:16 +0000
commitb43f0e788af7ab9758e6bae8cc637c36626fa8af (patch)
tree48c94a6d44065be6541e7923cc10c6ade68840d8 /net-im
parentfixo? (diff)
downloadgentoo-2-b43f0e788af7ab9758e6bae8cc637c36626fa8af.tar.gz
gentoo-2-b43f0e788af7ab9758e6bae8cc637c36626fa8af.tar.bz2
gentoo-2-b43f0e788af7ab9758e6bae8cc637c36626fa8af.zip
add __with_kde for naz
Diffstat (limited to 'net-im')
-rw-r--r--net-im/licq/files/digest-licq-1.0.3-r21
-rw-r--r--net-im/licq/licq-1.0.3-r2.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/net-im/licq/files/digest-licq-1.0.3-r2 b/net-im/licq/files/digest-licq-1.0.3-r2
new file mode 100644
index 000000000000..442083ca1cc5
--- /dev/null
+++ b/net-im/licq/files/digest-licq-1.0.3-r2
@@ -0,0 +1 @@
+MD5 894d7c27c0799c8b31dda134fe14b257 licq-1.0.3.tar.gz
diff --git a/net-im/licq/licq-1.0.3-r2.ebuild b/net-im/licq/licq-1.0.3-r2.ebuild
new file mode 100644
index 000000000000..1250759ee38e
--- /dev/null
+++ b/net-im/licq/licq-1.0.3-r2.ebuild
@@ -0,0 +1,59 @@
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Jules Gagnon <eonwe@users.sourceforge.net>
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="licq"
+SRC_URI="http://download.sourceforge.net/${PN}/${A}
+ ftp://ftp.fanfic.org/pub/${PN}/srcs/${A}
+ ftp://licq.darkorb.net/${A}
+ ftp://ftp.fr.licq.org/pub/${PN}/srcs/${A}
+ ftp://ftp.ru.licq.org/pub/${PN}/srcs/${A}
+ ftp://ftp.pt.licq.org/pub/mirrors/${PN}/srcs/${A}
+ ftp://mirror.itcnet.ro/pub/${PN}/srcs/${A}"
+HOMEPAGE="http://www.licq.org"
+
+DEPEND="virtual/glibc ssl? ( >=dev-libs/openssl-0.9.6 )
+ qt? ( >=x11-libs/qt-x11-2.2.1 >=kde-base/kdebase-2.1 )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+}
+
+src_compile() {
+ local myconf
+ if [ -z "`use ssl`" ]
+ then
+ myconf="--disable-openssl"
+ fi
+ if [ "`use kde`" ]
+ then
+ myconf="${myconf} --with-kde"
+ fi
+ if [ "`use socks5`" ]
+ then
+ myconf="${myconf} --enable-socks5"
+ fi
+ try ./configure --host=${CHOST} --prefix=/usr ${myconf}
+ try make
+ if [ "`use qt`" ]
+ then
+ cd ./plugins/qt-gui-1.0.3
+ try ./configure --host=${CHOST} --prefix=/usr
+ try make
+ cd ../..
+ fi
+}
+
+src_install() {
+ try make prefix=${D}/usr install
+ dodoc README.OPENSSL doc/*
+ if [ "`use qt`" ]
+ then
+ cd ./plugins/qt-gui-1.0.3
+ try make prefix=${D}/usr install
+ cd ../..
+ fi
+}
+