summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-07-27 07:49:22 +0000
committerPacho Ramos <pacho@gentoo.org>2013-07-27 07:49:22 +0000
commitad3fe629ae2d087e260dedc04f64f8125cd96dbe (patch)
tree33162672333baf7683bdee7461098d1fe96a5d3a /net-im
parentVersion bump for both 2.7 and 2.8 series. (diff)
downloadgentoo-2-ad3fe629ae2d087e260dedc04f64f8125cd96dbe.tar.gz
gentoo-2-ad3fe629ae2d087e260dedc04f64f8125cd96dbe.tar.bz2
gentoo-2-ad3fe629ae2d087e260dedc04f64f8125cd96dbe.zip
Install unit file #469672
(Portage version: 2.1.13.1/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'net-im')
-rw-r--r--net-im/prosody/ChangeLog8
-rw-r--r--net-im/prosody/files/prosody.service12
-rw-r--r--net-im/prosody/files/prosody.tmpfilesd1
-rw-r--r--net-im/prosody/prosody-0.8.2-r1.ebuild78
4 files changed, 98 insertions, 1 deletions
diff --git a/net-im/prosody/ChangeLog b/net-im/prosody/ChangeLog
index 3fb401a75557..521f2961b8e2 100644
--- a/net-im/prosody/ChangeLog
+++ b/net-im/prosody/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-im/prosody
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/prosody/ChangeLog,v 1.23 2013/07/13 05:46:32 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/prosody/ChangeLog,v 1.24 2013/07/27 07:49:22 pacho Exp $
+
+*prosody-0.8.2-r1 (27 Jul 2013)
+
+ 27 Jul 2013; Pacho Ramos <pacho@gentoo.org> +files/prosody.service,
+ +files/prosody.tmpfilesd, +prosody-0.8.2-r1.ebuild:
+ Install unit file #469672
13 Jul 2013; Agostino Sarubbo <ago@gentoo.org> prosody-0.8.2.ebuild:
Stable for amd64, wrt bug #388797
diff --git a/net-im/prosody/files/prosody.service b/net-im/prosody/files/prosody.service
new file mode 100644
index 000000000000..ec00e5445d51
--- /dev/null
+++ b/net-im/prosody/files/prosody.service
@@ -0,0 +1,12 @@
+[Unit]
+Description=Prosody XMPP (Jabber) server
+After=network.target
+
+[Service]
+Type=forking
+PIDFile=/var/run/jabber/prosody.pid
+ExecStart=/usr/bin/prosodyctl start
+ExecStop=/usr/bin/prosodyctl stop
+
+[Install]
+WantedBy=multi-user.target
diff --git a/net-im/prosody/files/prosody.tmpfilesd b/net-im/prosody/files/prosody.tmpfilesd
new file mode 100644
index 000000000000..924ba434659c
--- /dev/null
+++ b/net-im/prosody/files/prosody.tmpfilesd
@@ -0,0 +1 @@
+d /var/run/jabber 710 jabber jabber
diff --git a/net-im/prosody/prosody-0.8.2-r1.ebuild b/net-im/prosody/prosody-0.8.2-r1.ebuild
new file mode 100644
index 000000000000..8b0c945fdaba
--- /dev/null
+++ b/net-im/prosody/prosody-0.8.2-r1.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/prosody/prosody-0.8.2-r1.ebuild,v 1.1 2013/07/27 07:49:22 pacho Exp $
+
+EAPI="5"
+
+inherit eutils multilib systemd toolchain-funcs versionator
+
+MY_PV=$(replace_version_separator 3 '')
+DESCRIPTION="Prosody is a flexible communications server for Jabber/XMPP written in Lua."
+HOMEPAGE="http://prosody.im/"
+SRC_URI="http://prosody.im/downloads/source/${PN}-${MY_PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libevent mysql postgres sqlite ssl zlib"
+
+DEPEND="net-im/jabber-base
+ >=dev-lang/lua-5.1
+ >=net-dns/libidn-1.1
+ >=dev-libs/openssl-0.9.8"
+RDEPEND="${DEPEND}
+ dev-lua/luasocket
+ ssl? ( dev-lua/luasec )
+ dev-lua/luaexpat
+ dev-lua/luafilesystem
+ mysql? ( >=dev-lua/luadbi-0.5[mysql] )
+ postgres? ( >=dev-lua/luadbi-0.5[postgres] )
+ sqlite? ( >=dev-lua/luadbi-0.5[sqlite] )
+ libevent? ( dev-lua/luaevent )
+ zlib? ( dev-lua/lua-zlib )"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+JABBER_ETC="/etc/jabber"
+JABBER_SPOOL="/var/spool/jabber"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-0.8.0-cfg.lua.patch"
+
+ # Modify config to let prosodyctl work by default
+ sed -i -e 's/--"posix"/"posix"/' prosody.cfg.lua.dist || die
+
+ sed -i "s!MODULES = \$(DESTDIR)\$(PREFIX)/lib/!MODULES = \$(DESTDIR)\$(PREFIX)/$(get_libdir)/!" Makefile
+ sed -i "s!SOURCE = \$(DESTDIR)\$(PREFIX)/lib/!SOURCE = \$(DESTDIR)\$(PREFIX)/$(get_libdir)/!" Makefile
+ sed -i "s!INSTALLEDSOURCE = \$(PREFIX)/lib/!INSTALLEDSOURCE = \$(PREFIX)/$(get_libdir)/!" Makefile
+ sed -i "s!INSTALLEDMODULES = \$(PREFIX)/lib/!INSTALLEDMODULES = \$(PREFIX)/$(get_libdir)/!" Makefile
+}
+
+src_configure() {
+ # the configure script is handcrafted (and yells at unknown options)
+ # hence do not use 'econf'
+ ./configure --prefix="/usr" \
+ --sysconfdir="${JABBER_ETC}" \
+ --datadir="${JABBER_SPOOL}" \
+ --with-lua-lib=/usr/$(get_libdir)/lua \
+ --c-compiler="$(tc-getCC)" --linker="$(tc-getCC)" \
+ --cflags="${CFLAGS} -Wall -fPIC" \
+ --ldflags="${LDFLAGS} -shared" \
+ --require-config || die "configure failed"
+}
+
+src_install() {
+ DESTDIR="${D}" emake install
+ newinitd "${FILESDIR}/${PN}".initd ${PN}
+ systemd_dounit "${FILESDIR}/${PN}".service
+ systemd_newtmpfilesd "${FILESDIR}/${PN}".tmpfilesd "${PN}".conf
+}
+
+src_test() {
+ cd tests
+ ./run_tests.sh
+}
+
+pkg_postinst() {
+ elog "Please note that the module 'console' has been renamed to 'admin_telnet'."
+}