summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorDon Seiler <rizzo@gentoo.org>2004-04-23 12:12:51 +0000
committerDon Seiler <rizzo@gentoo.org>2004-04-23 12:12:51 +0000
commit9890ec18cf4de9eb91bb0f68415e581c694e1a67 (patch)
tree3ffed8523c5db0b844d8bea415dc121e5b9ac7b9 /net-im
parentadded missing digest (diff)
downloadgentoo-2-9890ec18cf4de9eb91bb0f68415e581c694e1a67.tar.gz
gentoo-2-9890ec18cf4de9eb91bb0f68415e581c694e1a67.tar.bz2
gentoo-2-9890ec18cf4de9eb91bb0f68415e581c694e1a67.zip
Patches for use gaim-0.77
Diffstat (limited to 'net-im')
-rw-r--r--net-im/gaim-encryption/ChangeLog8
-rw-r--r--net-im/gaim-encryption/files/digest-gaim-encryption-2.24-r11
-rw-r--r--net-im/gaim-encryption/files/encrypt_api.diff11
-rw-r--r--net-im/gaim-encryption/gaim-encryption-2.24-r1.ebuild57
4 files changed, 76 insertions, 1 deletions
diff --git a/net-im/gaim-encryption/ChangeLog b/net-im/gaim-encryption/ChangeLog
index 9c3abb9d17ee..fef16539ddd9 100644
--- a/net-im/gaim-encryption/ChangeLog
+++ b/net-im/gaim-encryption/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-im/gaim-encryption
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/gaim-encryption/ChangeLog,v 1.20 2004/04/22 14:16:24 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/gaim-encryption/ChangeLog,v 1.21 2004/04/23 12:12:51 rizzo Exp $
+
+*gaim-encryption-2.24-r1 (23 Apr 2004)
+
+ 23 Apr 2004; Don Seiler <rizzo@gentoo.org>; +files/encrypt_api.diff,
+ +gaim-encryption-2.24-r1.ebuild:
+ Patches for use gaim-0.77
22 Apr 2004; Travis Tilley <lv@gentoo.org> gaim-encryption-2.22.ebuild:
stable on amd64
diff --git a/net-im/gaim-encryption/files/digest-gaim-encryption-2.24-r1 b/net-im/gaim-encryption/files/digest-gaim-encryption-2.24-r1
new file mode 100644
index 000000000000..9be01742275c
--- /dev/null
+++ b/net-im/gaim-encryption/files/digest-gaim-encryption-2.24-r1
@@ -0,0 +1 @@
+MD5 70beb68dbb6413c75423a88e0080e171 gaim-encryption-2.24.tar.gz 357046
diff --git a/net-im/gaim-encryption/files/encrypt_api.diff b/net-im/gaim-encryption/files/encrypt_api.diff
new file mode 100644
index 000000000000..98ec6caf8306
--- /dev/null
+++ b/net-im/gaim-encryption/files/encrypt_api.diff
@@ -0,0 +1,11 @@
+--- encrypt.c.orig 2004-04-22 11:15:40.576477904 -0500
++++ encrypt.c 2004-04-22 11:17:05.246606088 -0500
+@@ -1110,7 +1110,7 @@
+
+ static GaimPluginInfo info =
+ {
+- 2, /**< api_version */
++ GAIM_PLUGIN_API_VERSION, /**< api_version */
+ GAIM_PLUGIN_STANDARD, /**< type */
+ GAIM_GTK_PLUGIN_TYPE, /**< ui_requirement */
+ 0, /**< flags */
diff --git a/net-im/gaim-encryption/gaim-encryption-2.24-r1.ebuild b/net-im/gaim-encryption/gaim-encryption-2.24-r1.ebuild
new file mode 100644
index 000000000000..231f11e1178e
--- /dev/null
+++ b/net-im/gaim-encryption/gaim-encryption-2.24-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/gaim-encryption/gaim-encryption-2.24-r1.ebuild,v 1.1 2004/04/23 12:12:51 rizzo Exp $
+
+inherit flag-o-matic
+
+IUSE=""
+DESCRIPTION="GAIM Encryption PlugIn"
+HOMEPAGE="http://gaim-encryption.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~x86 ~sparc ~amd64 ~ppc ~alpha ~ia64 ~hppa ~mips"
+
+DEPEND=">=net-im/gaim-0.76
+ || ( dev-libs/nss net-www/mozilla )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/encrypt_api.diff
+}
+
+src_compile() {
+ local myconf
+ myconf="--with-gaim=/usr/include/gaim"
+
+ NSS_LIB=/usr/lib
+ NSS_INC=/usr/include
+ has_version dev-libs/nss && {
+ # Only need to specify this if no pkgconfig from mozilla
+ myconf="${myconf} --with-nspr-includes=${NSS_INC}/nspr"
+ myconf="${myconf} --with-nss-includes=${NSS_INC}/nss"
+ myconf="${myconf} --with-nspr-libs=${NSS_LIB}"
+ myconf="${myconf} --with-nss-libs=${NSS_LIB}"
+ }
+
+ econf ${myconf} || die "Configuration failed"
+ einfo "Replacing -Os CFLAG with -O2"
+ replace-flags -Os -O2
+
+ emake || MAKEOPTS="${MAKEOPTS} -j1" emake || die "Make failed"
+}
+
+src_install() {
+ einstall || die "Install failed"
+ dodoc CHANGELOG COPYING INSTALL NOTES README TODO VERSION WISHLIST
+}
+
+pkg_postinst() {
+ ewarn
+ ewarn "This release is not backwards compatible for MSN, Yahoo, or IRC."
+ ewarn "See the release notes at:"
+ ewarn "https://sourceforge.net/project/shownotes.php?release_id=230104"
+ ewarn
+}