summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorOlivier Crête <tester@gentoo.org>2012-05-26 17:53:45 +0000
committerOlivier Crête <tester@gentoo.org>2012-05-26 17:53:45 +0000
commit9835e56a87dcc60b1cdaaf53d512cda09d22fc24 (patch)
tree2e527034194237ff3b81da8e5e85f0187831c5eb /net-im
parentkeyword ~amd64-fbsd (diff)
downloadgentoo-2-9835e56a87dcc60b1cdaaf53d512cda09d22fc24.tar.gz
gentoo-2-9835e56a87dcc60b1cdaaf53d512cda09d22fc24.tar.bz2
gentoo-2-9835e56a87dcc60b1cdaaf53d512cda09d22fc24.zip
Version bump
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'net-im')
-rw-r--r--net-im/amsn/ChangeLog9
-rw-r--r--net-im/amsn/amsn-0.98.9.ebuild91
2 files changed, 98 insertions, 2 deletions
diff --git a/net-im/amsn/ChangeLog b/net-im/amsn/ChangeLog
index 61055bc9362f..5d1d5d4f76d1 100644
--- a/net-im/amsn/ChangeLog
+++ b/net-im/amsn/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-im/amsn
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/amsn/ChangeLog,v 1.114 2011/10/23 16:26:45 ssuominen Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/amsn/ChangeLog,v 1.115 2012/05/26 17:53:45 tester Exp $
+
+*amsn-0.98.9 (26 May 2012)
+
+ 26 May 2012; Olivier Crête <tester@gentoo.org> +amsn-0.98.9.ebuild:
+ Version bump
23 Oct 2011; Samuli Suominen <ssuominen@gentoo.org>
-files/amsn-0.97.2-TkCximage.patch, -files/amsn-0.97.2-http-fix.patch,
diff --git a/net-im/amsn/amsn-0.98.9.ebuild b/net-im/amsn/amsn-0.98.9.ebuild
new file mode 100644
index 000000000000..85586a5a9c5d
--- /dev/null
+++ b/net-im/amsn/amsn-0.98.9.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/amsn/amsn-0.98.9.ebuild,v 1.1 2012/05/26 17:53:45 tester Exp $
+
+EAPI=4
+inherit autotools eutils fdo-mime gnome2-utils toolchain-funcs
+
+MY_P=${P/_rc/RC}
+
+DESCRIPTION="aMSN Messenger client"
+SRC_URI="mirror://sourceforge/${PN}/${PN}/${PV}/${MY_P}-src.tar.bz2"
+HOMEPAGE="http://www.amsn-project.net"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc -sparc ~x86"
+IUSE="debug"
+
+DEPEND=">=dev-lang/tcl-8.4
+ >=dev-lang/tk-8.4
+ virtual/jpeg
+ media-libs/libpng
+ >=dev-tcltk/snack-2.2.10
+ >=net-libs/gupnp-igd-0.1.3
+ media-libs/libv4l
+ media-libs/imlib"
+# >=net-libs/farsight2-0.0.14
+# >=media-libs/gstreamer-0.10.23
+# >=media-libs/gst-plugins-base-0.10.23
+
+RDEPEND="${DEPEND}
+ >=dev-tcltk/tls-1.5
+ virtual/ffmpeg[encode]"
+# >=media-libs/gst-plugins-good-0.10.15
+# >=media-libs/gst-plugins-bad-0.10.13
+# >=media-plugins/gst-plugins-ffmpeg-0.10.7
+
+# The tests are interactive
+RESTRICT="test"
+
+S=${WORKDIR}/${MY_P}
+
+DOCS=( AGREEMENT TODO README FAQ CREDITS )
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-0.98-noautoupdate.patch \
+ "${FILESDIR}"/${PN}-0.98.4-v4l2.patch \
+ "${FILESDIR}"/${PN}-0.98.4-amsnplus-ldflags.patch
+
+ # only portage should strip files, bug 285682
+ sed -i -e "s/LDFLAGS += -s/LDFLAGS += /" Makefile.in || die "sed failed"
+ # Ships with a 32-bit binary, we want to rebuild it
+ rm -f plugins/amsnplus/snapshot || die
+ eautoreconf
+}
+
+src_configure() {
+ tc-export CC
+ econf $(use_enable debug)
+}
+
+src_install() {
+ emake -C plugins/amsnplus
+ default
+
+ domenu amsn.desktop
+ sed -i -e s:.png:: "${D}"/usr/share/applications/amsn.desktop || die
+
+ pushd desktop-icons
+ local res
+ for res in 22 32 48 64 72 96 128; do
+ insinto /usr/share/icons/hicolor/${res}x${res}/apps
+ doins ${res}x${res}/apps/amsn.png
+ done
+ popd
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ gnome2_icon_cache_update
+}