summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2012-03-16 11:58:25 +0000
committerJohannes Huber <johu@gentoo.org>2012-03-16 11:58:25 +0000
commit89695cf7ffb77101a146dbba9a3b4bc33cb0dccf (patch)
tree2419217c6a9f251b1d47f93f8b0f56e31a506670 /net-im
parentSwitch to virtual/shadow. (diff)
downloadgentoo-2-89695cf7ffb77101a146dbba9a3b4bc33cb0dccf.tar.gz
gentoo-2-89695cf7ffb77101a146dbba9a3b4bc33cb0dccf.tar.bz2
gentoo-2-89695cf7ffb77101a146dbba9a3b4bc33cb0dccf.zip
Revision bumps adds patch to fix build with gold linker. Patch by kensington <gentoo@scribeofthenile.com>. Fixes bug #369907.
(Portage version: 2.2.0_alpha90/cvs/Linux i686)
Diffstat (limited to 'net-im')
-rw-r--r--net-im/qutim/ChangeLog11
-rw-r--r--net-im/qutim/files/qutim-0.2.0-gold.patch10
-rw-r--r--net-im/qutim/qutim-0.2.0-r4.ebuild111
3 files changed, 130 insertions, 2 deletions
diff --git a/net-im/qutim/ChangeLog b/net-im/qutim/ChangeLog
index 717f0aa178aa..83e692c8b1ad 100644
--- a/net-im/qutim/ChangeLog
+++ b/net-im/qutim/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-im/qutim
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/qutim/ChangeLog,v 1.12 2011/06/13 15:12:17 hwoarang Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/qutim/ChangeLog,v 1.13 2012/03/16 11:58:25 johu Exp $
+
+*qutim-0.2.0-r4 (16 Mar 2012)
+
+ 16 Mar 2012; Johannes Huber <johu@gentoo.org> +files/qutim-0.2.0-gold.patch,
+ +qutim-0.2.0-r4.ebuild:
+ Revision bumps adds patch to fix build with gold linker. Patch by kensington
+ <gentoo@scribeofthenile.com>. Fixes bug #369907.
13 Jun 2011; Markos Chandras <hwoarang@gentoo.org> metadata.xml:
Remove myself from metadata.xml
diff --git a/net-im/qutim/files/qutim-0.2.0-gold.patch b/net-im/qutim/files/qutim-0.2.0-gold.patch
new file mode 100644
index 000000000000..9b96f70dad11
--- /dev/null
+++ b/net-im/qutim/files/qutim-0.2.0-gold.patch
@@ -0,0 +1,10 @@
+--- CMakeLists.txt
++++ CMakeLists.txt
+@@ -446,6 +446,7 @@
+ ${QT_LIBRARIES}
+ ${QT_QTMAIN_LIBRARY}
+ ${QUTIM_LIBS}
++ -lX11
+ )
+
+ SET (module_install_dir "${CMAKE_ROOT}/Modules") \ No newline at end of file
diff --git a/net-im/qutim/qutim-0.2.0-r4.ebuild b/net-im/qutim/qutim-0.2.0-r4.ebuild
new file mode 100644
index 000000000000..1a57052e3870
--- /dev/null
+++ b/net-im/qutim/qutim-0.2.0-r4.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/qutim/qutim-0.2.0-r4.ebuild,v 1.1 2012/03/16 11:58:25 johu Exp $
+
+EAPI="2"
+LANGSLONG="bg_BG cs_CZ de_DE uk_UA"
+LANGS="ru"
+
+inherit eutils qt4-r2 cmake-utils
+MY_PN="${PN/im/IM}"
+
+DESCRIPTION="New Qt4-based Instant Messenger (ICQ)."
+HOMEPAGE="http://www.qutim.org"
+LICENSE="GPL-2"
+SRC_URI="http://qutim.org/uploads/src/${P}.tar.bz2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug histman icq irc xmpp gnutls mrim ssl vkontakte yandexnarod"
+
+DEPEND="x11-libs/qt-gui:4[debug?]
+ x11-libs/qt-webkit:4
+ || ( media-libs/phonon x11-libs/qt-phonon )
+ xmpp? ( ssl? ( dev-libs/openssl )
+ gnutls? ( net-libs/gnutls ) )"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/fix_insecure_rpath.patch
+ "${FILESDIR}"/${P}-gold.patch
+)
+
+src_prepare() {
+ qt4-r2_src_prepare
+ # fix translations directory
+ einfo "Fixing LINGUAS path"
+ sed -i "s/languages/\/usr\/share\/${PN}\/languages/" src/${PN}.cpp
+}
+
+src_compile() {
+ # build main executable
+ cmake-utils_src_compile
+ found=0
+ # build protocol support
+ if use xmpp; then
+ found=1
+ cd "${S}"/plugins/jabber || die
+ mkdir build
+ cd build
+ cmake -C "${TMPDIR}"/gentoo_common_config.cmake \
+ $(cmake-utils_use ssl OpenSSL) \
+ $(cmake-utils_use gnutls GNUTLS) ../ || die
+ emake || die
+ fi
+ # build mrim
+ if use mrim; then
+ found=1
+ cd "${S}"/plugins/mrim || die
+ mkdir build
+ cd build
+ cmake -C "${TMPDIR}"/gentoo_common_config.cmake ../ || die
+ emake || die "failed to compile mrim plugin"
+ fi
+ # Qt4 based projects so I shall use eqmake4
+ cd "${S}"/plugins || die
+ for i in histman yandexnarod icq irc vkontakte;do
+ if use ${i}; then
+ found=1
+ cd "${i}"
+ einfo "now building ${i}-plugin"
+ eqmake4 ${i}.pro
+ emake || die "failed to compile ${i} plugin"
+ cd ..
+ fi
+ done
+
+}
+
+src_install(){
+ # not recommended by upstream and probably broken
+ #cmake-utils_src_install
+ dobin "${WORKDIR}/${P}_build/${PN}" || die
+
+ cd "${S}"/plugins || die
+ insinto "/usr/$(get_libdir)/qutim"
+ [[ $found -eq 1 ]] && doins $(find . -type f -executable -iname "*.so")
+ doicon "${S}"/icons/${PN}_64.png || die "Failed to install icon"
+ make_desktop_entry ${PN} ${MY_PN} ${PN}_64 \
+ "Network;InstantMessaging;Qt" || die "make_desktop_entry failed"
+
+ #install linguas
+ for X in ${LANGSLONG}; do
+ for Z in ${LINGUAS}; do
+ if [[ ${X%_*} == ${Z} ]]; then
+ einfo "Installing ${Z} translation files"
+ insinto /usr/share/${PN}/languages/${X}/
+ doins -r "${S}"/languages/${X}/binaries/* || die "failed to install ${X} translation"
+ fi
+ done
+ done
+ for X in ${LANGS}; do
+ for Z in ${LINGUAS}; do
+ if [[ ${X} == ${Z} ]]; then
+ einfo "Installing ${Z} translation files"
+ insinto /usr/share/${PN}/languages/${X}/
+ doins -r "${S}"/languages/${X}/binaries/* || die "failed to install ${X} translation"
+ fi
+ done
+ done
+
+}