summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2009-07-14 19:03:01 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2009-07-14 19:03:01 +0000
commit8521409067999641e28bd5ed982a1cddda84b083 (patch)
tree3f3cab8c408e93cd1cd9488849cbf76c7c45f73d /net-im
parentFix libwww-perl version (diff)
downloadgentoo-2-8521409067999641e28bd5ed982a1cddda84b083.tar.gz
gentoo-2-8521409067999641e28bd5ed982a1cddda84b083.tar.bz2
gentoo-2-8521409067999641e28bd5ed982a1cddda84b083.zip
Version bump
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'net-im')
-rw-r--r--net-im/qtwitter/ChangeLog7
-rw-r--r--net-im/qtwitter/metadata.xml3
-rw-r--r--net-im/qtwitter/qtwitter-0.8.0.ebuild65
3 files changed, 74 insertions, 1 deletions
diff --git a/net-im/qtwitter/ChangeLog b/net-im/qtwitter/ChangeLog
index b6a6261c8068..9ce58b9b0b2b 100644
--- a/net-im/qtwitter/ChangeLog
+++ b/net-im/qtwitter/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-im/qtwitter
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/qtwitter/ChangeLog,v 1.6 2009/06/30 21:01:58 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/qtwitter/ChangeLog,v 1.7 2009/07/14 19:03:01 hwoarang Exp $
+
+*qtwitter-0.8.0 (14 Jul 2009)
+
+ 14 Jul 2009; Markos Chandras <hwoarang@gentoo.org> +qtwitter-0.8.0.ebuild:
+ Version bump
30 Jun 2009; Christian Faulhammer <fauli@gentoo.org>
qtwitter-0.7.1.ebuild:
diff --git a/net-im/qtwitter/metadata.xml b/net-im/qtwitter/metadata.xml
index a3c8d94075e1..1f9ce8d3f18f 100644
--- a/net-im/qtwitter/metadata.xml
+++ b/net-im/qtwitter/metadata.xml
@@ -2,6 +2,9 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>qt</herd>
+<use>
+ <flag name="oauth">Enables authorization using OAuth for Twitter accounts</flag>
+</use>
<maintainer>
<email>hwoarang@gentoo.org</email>
<name>Markos Chandras</name>
diff --git a/net-im/qtwitter/qtwitter-0.8.0.ebuild b/net-im/qtwitter/qtwitter-0.8.0.ebuild
new file mode 100644
index 000000000000..12637430095d
--- /dev/null
+++ b/net-im/qtwitter/qtwitter-0.8.0.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/qtwitter/qtwitter-0.8.0.ebuild,v 1.1 2009/07/14 19:03:01 hwoarang Exp $
+
+EAPI="2"
+
+inherit qt4
+
+DESCRIPTION="A Qt-based client for Twitter and Identi.ca"
+HOMEPAGE="http://www.qt-apps.org/content/show.php/qTwitter?content=99087"
+SRC_URI="http://files.ayoy.net/qtwitter/release/${PV}/src/${P}-src.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug +oauth"
+
+DEPEND="x11-libs/qt-gui:4
+ oauth? ( dev-libs/qoauth )"
+RDEPEND="${DEPEND}"
+
+LANGS="pt_BR"
+LANGSLONG="ca_ES de_DE es_ES fr_FR it_IT ja_JP pl_PL"
+
+src_prepare() {
+ qt4_src_prepare
+ echo "CONFIG += nostrip" >> "${S}"/${PN}.pro
+
+ local langs=
+ for lingua in $LINGUAS; do
+ if has $lingua $LANGS; then
+ langs="$langs loc/${PN}_${lingua}.ts"
+ else
+ for a in $LANGSLONG; do
+ if [[ $lingua == ${a%_*} ]]; then
+ langs="$langs loc/${PN}_${a}.ts"
+ fi
+ done
+ fi
+ done
+
+ # remove translations and add only the selected ones
+ sed -i -e '/^ *loc.*\.ts/d' \
+ -e "/^TRANSLATIONS/s:loc.*:${langs}:" \
+ qtwitter-app/qtwitter-app.pro || die "sed failed"
+ # first line fixes bug about unsecure runpaths
+ # second disables docs installation by make (done by dodoc in install)
+ sed -i -e '/-Wl,-rpath,\$\${TOP}/d' \
+ -e '/doc \\/d' \
+ qtwitter-app/qtwitter-app.pro || die "sed failed"
+
+ sed -i "s!\(\$\${INSTALL_PREFIX}\)/lib!\1/$(get_libdir)!" \
+ twitterapi/twitterapi.pro urlshortener/urlshortener.pro || die "sed failed"
+
+ use oauth || sed -i '/DEFINES += OAUTH/d' ${PN}.pri
+}
+
+src_configure() {
+ eqmake4
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install || die "emake install failed"
+ dodoc README CHANGELOG || die "dodoc failed"
+}