summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorStefan Knoblich <stkn@gentoo.org>2005-07-29 18:45:27 +0000
committerStefan Knoblich <stkn@gentoo.org>2005-07-29 18:45:27 +0000
commit7c028d8d8813b63523f3fdca4a81111afa8524d1 (patch)
tree46d22dac6c5cb6f502c5ef3b777282bf5c2f4400 /net-im
parentaborted midway through previous commit... (diff)
downloadgentoo-2-7c028d8d8813b63523f3fdca4a81111afa8524d1.tar.gz
gentoo-2-7c028d8d8813b63523f3fdca4a81111afa8524d1.tar.bz2
gentoo-2-7c028d8d8813b63523f3fdca4a81111afa8524d1.zip
-O3 causes trouble with audio plugins, replace with -O2 (bug #88710)
(Portage version: 2.0.51.19)
Diffstat (limited to 'net-im')
-rw-r--r--net-im/gnomemeeting/ChangeLog7
-rw-r--r--net-im/gnomemeeting/gnomemeeting-1.2.0.ebuild8
-rw-r--r--net-im/gnomemeeting/gnomemeeting-1.2.1.ebuild7
3 files changed, 16 insertions, 6 deletions
diff --git a/net-im/gnomemeeting/ChangeLog b/net-im/gnomemeeting/ChangeLog
index 242874753b46..e5d22dea59d4 100644
--- a/net-im/gnomemeeting/ChangeLog
+++ b/net-im/gnomemeeting/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-im/gnomemeeting
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/gnomemeeting/ChangeLog,v 1.57 2005/07/27 11:00:43 pvdabeel Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/gnomemeeting/ChangeLog,v 1.58 2005/07/29 18:45:27 stkn Exp $
+
+ 29 Jul 2005; <stkn@gentoo.org> gnomemeeting-1.2.1.ebuild,
+ gnomemeeting-1.2.0.ebuild:
+ -O3 causes trouble with audio plugins, replace with -O2
+ (bug #88710).
27 Jul 2005; Pieter Van den Abeele <pvdabeel@gentoo.org>
gnomemeeting-1.2.0.ebuild, gnomemeeting-1.2.1.ebuild:
diff --git a/net-im/gnomemeeting/gnomemeeting-1.2.0.ebuild b/net-im/gnomemeeting/gnomemeeting-1.2.0.ebuild
index 4f8d5fb51a31..06bf902ec76c 100644
--- a/net-im/gnomemeeting/gnomemeeting-1.2.0.ebuild
+++ b/net-im/gnomemeeting/gnomemeeting-1.2.0.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/gnomemeeting/gnomemeeting-1.2.0.ebuild,v 1.8 2005/07/27 11:00:43 pvdabeel Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/gnomemeeting/gnomemeeting-1.2.0.ebuild,v 1.9 2005/07/29 18:45:27 stkn Exp $
-inherit gnome2 eutils
+inherit gnome2 eutils flag-o-matic
DESCRIPTION="H.323 videoconferencing and VoIP softphone"
HOMEPAGE="http://www.gnomemeeting.org/"
@@ -56,9 +56,11 @@ src_unpack() {
}
src_compile() {
-
local myconf
+ # filter -O3, causes trouble with plugins (bug #88710)
+ replace-flags -O3 -O2
+
myconf="${myconf} --with-ptlib-includes=/usr/include/ptlib"
myconf="${myconf} --with-ptlib-libs=/usr/lib"
myconf="${myconf} --with-openh323-includes=/usr/include/openh323"
diff --git a/net-im/gnomemeeting/gnomemeeting-1.2.1.ebuild b/net-im/gnomemeeting/gnomemeeting-1.2.1.ebuild
index 5c1eabaa9019..130ed8147719 100644
--- a/net-im/gnomemeeting/gnomemeeting-1.2.1.ebuild
+++ b/net-im/gnomemeeting/gnomemeeting-1.2.1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/gnomemeeting/gnomemeeting-1.2.1.ebuild,v 1.4 2005/07/27 11:00:43 pvdabeel Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/gnomemeeting/gnomemeeting-1.2.1.ebuild,v 1.5 2005/07/29 18:45:27 stkn Exp $
-inherit gnome2 eutils
+inherit gnome2 eutils flag-o-matic
DESCRIPTION="H.323 videoconferencing and VoIP softphone"
HOMEPAGE="http://www.gnomemeeting.org/"
@@ -54,6 +54,9 @@ src_unpack() {
src_compile() {
local myconf
+ # filter -O3, causes trouble with plugins (bug #88710)
+ replace-flags -O3 -O2
+
myconf="${myconf} --with-ptlib-includes=/usr/include/ptlib"
myconf="${myconf} --with-ptlib-libs=/usr/lib"
myconf="${myconf} --with-openh323-includes=/usr/include/openh323"