summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2005-04-14 20:04:15 +0000
committerMichael Januszewski <spock@gentoo.org>2005-04-14 20:04:15 +0000
commit7170dec7fe87270e7f701c863bb256bd818d7840 (patch)
tree082989d32808e93371f41746b78a850cf887b7d4 /net-im
parentversion bump; remove oldie; actualize homepage (diff)
downloadgentoo-2-7170dec7fe87270e7f701c863bb256bd818d7840.tar.gz
gentoo-2-7170dec7fe87270e7f701c863bb256bd818d7840.tar.bz2
gentoo-2-7170dec7fe87270e7f701c863bb256bd818d7840.zip
Added a patch that should fix bug #88713.
(Portage version: 2.0.51.19)
Diffstat (limited to 'net-im')
-rw-r--r--net-im/ekg/ChangeLog6
-rw-r--r--net-im/ekg/ekg-1.6_rc1.ebuild17
-rw-r--r--net-im/ekg/files/ekg-1.6_rc1-fpic.patch12
3 files changed, 30 insertions, 5 deletions
diff --git a/net-im/ekg/ChangeLog b/net-im/ekg/ChangeLog
index aa6d4d599093..1221ce2c1298 100644
--- a/net-im/ekg/ChangeLog
+++ b/net-im/ekg/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-im/ekg
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/ekg/ChangeLog,v 1.15 2005/04/01 15:11:15 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/ekg/ChangeLog,v 1.16 2005/04/14 20:04:15 spock Exp $
+
+ 14 Apr 2005; Michał Januszewski <spock@gentoo.org>
+ +files/ekg-1.6_rc1-fpic.patch, ekg-1.6_rc1.ebuild:
+ Added a patch that should fix bug #88713.
01 Apr 2005; Aron Griffis <agriffis@gentoo.org> ekg-1.6_rc1.ebuild:
stable on ia64
diff --git a/net-im/ekg/ekg-1.6_rc1.ebuild b/net-im/ekg/ekg-1.6_rc1.ebuild
index 22281a319b92..fd4ed6cdd68f 100644
--- a/net-im/ekg/ekg-1.6_rc1.ebuild
+++ b/net-im/ekg/ekg-1.6_rc1.ebuild
@@ -1,8 +1,10 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/ekg/ekg-1.6_rc1.ebuild,v 1.2 2005/04/01 15:11:15 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/ekg/ekg-1.6_rc1.ebuild,v 1.3 2005/04/14 20:04:15 spock Exp $
-IUSE="ssl ncurses zlib python spell"
+inherit eutils
+
+IUSE="ssl ncurses zlib python spell threads"
DESCRIPTION="EKG (Eksperymentalny Klient Gadu-Gadu) - a text client for Polish instant messaging system Gadu-Gadu"
HOMEPAGE="http://dev.null.pl/ekg/"
@@ -21,14 +23,21 @@ DEPEND="ssl? ( >=dev-libs/openssl-0.9.6 )
python? ( dev-lang/python )
spell? ( >=app-text/aspell-0.50.3 )"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/ekg-1.6_rc1-fpic.patch
+}
+
src_compile() {
- local myconf="--enable-ioctld --enable-shared --with-pthread --enable-dynamic"
+ local myconf="--enable-ioctld --enable-shared --enable-dynamic"
use ssl || myconf="$myconf --disable-openssl"
use ncurses || myconf="$myconf --disable-ui-ncurses --enable-ui-readline"
use zlib || myconf="$myconf --disable-zlib"
use python && myconf="$myconf --with-python"
use spell && myconf="$myconf --enable-aspell"
-
+ use threads && myconf="$myconf --with-pthread"
+
econf ${myconf} || die
emake || die
}
diff --git a/net-im/ekg/files/ekg-1.6_rc1-fpic.patch b/net-im/ekg/files/ekg-1.6_rc1-fpic.patch
new file mode 100644
index 000000000000..ca2da2967c54
--- /dev/null
+++ b/net-im/ekg/files/ekg-1.6_rc1-fpic.patch
@@ -0,0 +1,12 @@
+diff -ur ekg-1.6rc1-old/configure ekg-1.6rc1/configure
+--- ekg-1.6rc1-old/configure 2005-03-20 13:46:53.000000000 +0100
++++ ekg-1.6rc1/configure 2005-04-14 13:15:30.294949464 +0200
+@@ -4224,7 +4224,7 @@
+ echo $ECHO_N "checking if -pthread is sufficient with -shared... $ECHO_C" >&6
+ save_CFLAGS="$CFLAGS"
+ save_LIBS="$LIBS"
+- CFLAGS="-shared -Wl,-z,defs $CFLAGS"
++ CFLAGS="-shared -fPIC -Wl,-z,defs $CFLAGS"
+ ok="no"
+ cat >conftest.$ac_ext <<_ACEOF
+ #line $LINENO "configure"