summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorKathryn Kulick <gothgirl@gentoo.org>2006-10-13 01:50:45 +0000
committerKathryn Kulick <gothgirl@gentoo.org>2006-10-13 01:50:45 +0000
commit6fed057664d53f809ab75123d821043d62121a33 (patch)
treeeb2127249515afdf102010c56e4879257c534b39 /net-im
parentBump (diff)
downloadgentoo-2-6fed057664d53f809ab75123d821043d62121a33.tar.gz
gentoo-2-6fed057664d53f809ab75123d821043d62121a33.tar.bz2
gentoo-2-6fed057664d53f809ab75123d821043d62121a33.zip
Made adjustments re bug#:146246,149696,141639
(Portage version: 2.1.2_pre2-r7)
Diffstat (limited to 'net-im')
-rw-r--r--net-im/gaim/ChangeLog9
-rw-r--r--net-im/gaim/files/digest-gaim-2.0.0_beta3-r33
-rw-r--r--net-im/gaim/files/gaim-1.5.0-icq.patch12
-rw-r--r--net-im/gaim/files/gaim-2.0.0_beta3-gtkconv.diff15
-rw-r--r--net-im/gaim/files/gaim-2.0.0_beta3-icq.patch12
-rw-r--r--net-im/gaim/gaim-1.5.0.ebuild27
-rw-r--r--net-im/gaim/gaim-2.0.0_beta3-r3.ebuild223
7 files changed, 289 insertions, 12 deletions
diff --git a/net-im/gaim/ChangeLog b/net-im/gaim/ChangeLog
index 69755b6773bf..8b7f7534933f 100644
--- a/net-im/gaim/ChangeLog
+++ b/net-im/gaim/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-im/gaim
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/gaim/ChangeLog,v 1.408 2006/10/12 23:37:28 gothgirl Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/gaim/ChangeLog,v 1.409 2006/10/13 01:50:45 gothgirl Exp $
+
+*gaim-2.0.0_beta3-r3 (13 Oct 2006)
+
+ 13 Oct 2006; gothgirl <gothgirl@gentoo.org> +files/gaim-1.5.0-icq.patch,
+ +files/gaim-2.0.0_beta3-gtkconv.diff, +files/gaim-2.0.0_beta3-icq.patch,
+ gaim-1.5.0.ebuild, +gaim-2.0.0_beta3-r3.ebuild:
+ Made adjustments re bug#:146246,149696,141639
12 Oct 2006; gothgirl <gothgirl@gentoo.org> gaim-2.0.0_beta3-r1.ebuild,
gaim-2.0.0_beta3-r2.ebuild:
diff --git a/net-im/gaim/files/digest-gaim-2.0.0_beta3-r3 b/net-im/gaim/files/digest-gaim-2.0.0_beta3-r3
new file mode 100644
index 000000000000..f020f448cc44
--- /dev/null
+++ b/net-im/gaim/files/digest-gaim-2.0.0_beta3-r3
@@ -0,0 +1,3 @@
+MD5 202b9e6ee5171da90de14230b3037dc1 gaim-2.0.0beta3.1.tar.bz2 5445059
+RMD160 5987586fee212a5c5e9287a9dce55a35c30ea7b7 gaim-2.0.0beta3.1.tar.bz2 5445059
+SHA256 a282c56f32a37f7838c5332f182bdd920d4e80099b96313e503c6acc020931f4 gaim-2.0.0beta3.1.tar.bz2 5445059
diff --git a/net-im/gaim/files/gaim-1.5.0-icq.patch b/net-im/gaim/files/gaim-1.5.0-icq.patch
new file mode 100644
index 000000000000..e0756746da8d
--- /dev/null
+++ b/net-im/gaim/files/gaim-1.5.0-icq.patch
@@ -0,0 +1,12 @@
+--- ssi.c.old 2005-07-09 20:51:05.000000000 +0200
++++ ssi.c 2006-07-24 23:58:47.000000000 +0200
+@@ -918,8 +918,8 @@ faim_export int aim_ssi_deldeny(aim_sess
+ faim_export int aim_ssi_movebuddy(aim_session_t *sess, const char *oldgn, const char *newgn, const char *sn)
+ {
+ char *alias = aim_ssi_getalias(sess->ssi.local, oldgn, sn);
+- aim_ssi_addbuddy(sess, sn, newgn, alias, NULL, NULL, aim_ssi_waitingforauth(sess->ssi.local, oldgn, sn));
+ aim_ssi_delbuddy(sess, sn, oldgn);
++ aim_ssi_addbuddy(sess, sn, newgn, alias, NULL, NULL, aim_ssi_waitingforauth(sess->ssi.local, oldgn, sn));
+ free(alias);
+ return 0;
+ }
diff --git a/net-im/gaim/files/gaim-2.0.0_beta3-gtkconv.diff b/net-im/gaim/files/gaim-2.0.0_beta3-gtkconv.diff
new file mode 100644
index 000000000000..a89a76ff0b9f
--- /dev/null
+++ b/net-im/gaim/files/gaim-2.0.0_beta3-gtkconv.diff
@@ -0,0 +1,15 @@
+--- gaim-2.0.0beta3.1/src/gtkconv.c 2006-08-19 15:36:07.000000000 -0500
++++ gaim/gaim-2.0.0beta3/src/gtkconv.c 2006-10-12 16:51:52.654751430 -0500
+@@ -7313,12 +7313,6 @@
+
+ g_return_if_fail(conv != NULL);
+
+- /*
+- * Only set "unseen" to "none" if the window has focus
+- */
+- if (gaim_gtk_conv_window_has_focus(win))
+- gtkconv_set_unseen(gtkconv, GAIM_UNSEEN_NONE);
+-
+ /* Update the menubar */
+
+ gtk_check_menu_item_set_active(GTK_CHECK_MENU_ITEM(gtkconv->win->menu.logging),
diff --git a/net-im/gaim/files/gaim-2.0.0_beta3-icq.patch b/net-im/gaim/files/gaim-2.0.0_beta3-icq.patch
new file mode 100644
index 000000000000..9bceb816932b
--- /dev/null
+++ b/net-im/gaim/files/gaim-2.0.0_beta3-icq.patch
@@ -0,0 +1,12 @@
+--- family_feedbag.c 2006-07-25 00:13:56.000000000 +0200
++++ family_feedbag.c.old 2006-07-25 00:13:46.000000000 +0200
+@@ -936,8 +936,8 @@ faim_export int aim_ssi_deldeny(OscarSes
+ faim_export int aim_ssi_movebuddy(OscarSession *sess, const char *oldgn, const char *newgn, const char *sn)
+ {
+ char *alias = aim_ssi_getalias(sess->ssi.local, oldgn, sn);
+- aim_ssi_delbuddy(sess, sn, oldgn);
+ aim_ssi_addbuddy(sess, sn, newgn, alias, NULL, NULL, aim_ssi_waitingforauth(sess->ssi.local, oldgn, sn));
++ aim_ssi_delbuddy(sess, sn, oldgn);
+ free(alias);
+ return 0;
+ }
diff --git a/net-im/gaim/gaim-1.5.0.ebuild b/net-im/gaim/gaim-1.5.0.ebuild
index 25426cc67d84..76055ef8ee60 100644
--- a/net-im/gaim/gaim-1.5.0.ebuild
+++ b/net-im/gaim/gaim-1.5.0.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/gaim/gaim-1.5.0.ebuild,v 1.18 2006/07/10 17:53:30 gothgirl Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/gaim/gaim-1.5.0.ebuild,v 1.19 2006/10/13 01:50:45 gothgirl Exp $
-inherit flag-o-matic eutils toolchain-funcs debug multilib perl-app
+inherit flag-o-matic eutils toolchain-funcs debug multilib perl-module perl-app
DESCRIPTION="GTK Instant Messenger client"
HOMEPAGE="http://gaim.sourceforge.net/"
@@ -11,7 +11,7 @@ SRC_URI="mirror://sourceforge/gaim/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 sparc x86"
-IUSE="nls perl spell nas cjk gnutls silc eds tcl tk debug"
+IUSE="nls perl spell nas cjk gnutls silc eds krb4 tcltk debug"
RDEPEND=">=x11-libs/gtk+-2.0
>=dev-libs/glib-2.0
@@ -24,8 +24,9 @@ RDEPEND=">=x11-libs/gtk+-2.0
!gnutls? ( >=dev-libs/nss-3.9.2-r2 )
silc? ( >=net-im/silc-toolkit-0.9.12-r3 )
eds? ( gnome-extra/evolution-data-server )
- tcl? ( dev-lang/tcl )
- tk? ( dev-lang/tk )
+ krb4? ( >=app-crypt/mit-krb5-1.3.6-r1 )
+ tcltk? ( dev-lang/tcl
+ dev-lang/tk )
x11-libs/startup-notification"
DEPEND="$RDEPEND
@@ -69,22 +70,26 @@ print_gaim_warning() {
einfo
einfo "Note that we are now filtering all unstable flags in C[XX]FLAGS."
einfo
- einfo "In order to connect to the SILC protocol, please run the"
- einfo "command usermod <yourusername> -c \"yourusername\" where"
- einfo "yourusername is your user's name on your system."
- einfo
ebeep 5
epause 3
}
pkg_setup() {
print_gaim_warning
+ if use krb4 && ! built_with_use app-crypt/mit-krb5 krb4 ; then
+ eerror
+ eerror You need to rebuild app-crypt/mit-krb5 with USE=krb4 in order to
+ eerror enable krb4 support for the zephyr protocol in gaim.
+ eerror
+ die "Configure failed"
+ fi
}
src_unpack() {
unpack ${A}
cd ${S}
use cjk && epatch ${FILESDIR}/gaim-0.76-xinput.patch
+ epatch "${FILESDIR}"/"${P}"-icq.patch
}
src_compile() {
@@ -102,8 +107,8 @@ src_compile() {
use nls || myconf="${myconf} --disable-nls"
use nas && myconf="${myconf} --enable-nas" || myconf="${myconf} --disable-nas"
use eds || myconf="${myconf} --disable-gevolution"
- use tcl || myconf="${myconf} --disable-tcl"
- use tk || myconf="${myconf} --disable-tk"
+ use krb4 && myconf="${myconf} --with-krb4"
+ use tcltk || myconf="${myconf} --disable-tcl --disable-tk"
if use gnutls ; then
einfo "Disabling NSS, using GnuTLS"
diff --git a/net-im/gaim/gaim-2.0.0_beta3-r3.ebuild b/net-im/gaim/gaim-2.0.0_beta3-r3.ebuild
new file mode 100644
index 000000000000..6ac6d3a129ba
--- /dev/null
+++ b/net-im/gaim/gaim-2.0.0_beta3-r3.ebuild
@@ -0,0 +1,223 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/gaim/gaim-2.0.0_beta3-r3.ebuild,v 1.1 2006/10/13 01:50:45 gothgirl Exp $
+
+inherit flag-o-matic eutils toolchain-funcs debug multilib mono autotools perl-app
+
+#MY_PV=${PV/_beta/beta}
+MY_PV="2.0.0beta3.1"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="GTK Instant Messenger client"
+HOMEPAGE="http://gaim.sourceforge.net/"
+SRC_URI="mirror://sourceforge/gaim/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="avahi audiofile bonjour cjk dbus debug doc eds gadu gnutls meanwhile mono nas nls perl silc spell startup-notification tcl tk xscreensaver custom-flags ssl msn"
+
+RDEPEND="
+ audiofile? ( media-libs/libao
+ media-libs/audiofile )
+ bonjour? ( !avahi? ( net-misc/howl )
+ avahi? ( net-dns/avahi ) )
+ dbus? ( >=sys-apps/dbus-0.35
+ >=dev-lang/python-2.4 )
+ >=x11-libs/gtk+-2.0
+ >=dev-libs/glib-2.0
+ nas? ( >=media-libs/nas-1.4.1-r1 )
+ perl? ( >=dev-lang/perl-5.8.2-r1 )
+ spell? ( >=app-text/gtkspell-2.0.2 )
+ gadu? ( net-libs/libgadu )
+ ssl? (
+ gnutls? ( net-libs/gnutls )
+ !gnutls? ( >=dev-libs/nss-3.11 )
+ )
+ msn? (
+ gnutls? ( net-libs/gnutls )
+ !gnutls? ( >=dev-libs/nss-3.11 )
+ )
+ meanwhile? ( net-libs/meanwhile )
+ silc? ( >=net-im/silc-toolkit-0.9.12-r3 )
+ eds? ( gnome-extra/evolution-data-server )
+ tcl? ( dev-lang/tcl )
+ tk? ( dev-lang/tk )
+ startup-notification? ( >=x11-libs/startup-notification-0.5 )
+ mono? ( dev-lang/mono )
+ doc? ( app-doc/doxygen )
+ xscreensaver? ( x11-libs/libXScrnSaver )"
+
+DEPEND="$RDEPEND
+ dev-util/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+
+S="${WORKDIR}/${MY_P}"
+
+# List of plugins
+# app-accessibility/festival-gaim
+# net-im/gaim-blogger
+# net-im/gaim-bnet
+# net-im/gaim-meanwhile
+# net-im/gaim-snpp
+# x11-plugins/autoprofile
+# x11-plugins/gaim-assistant
+# x11-plugins/gaim-encryption
+# x11-plugins/gaim-extprefs
+# x11-plugins/gaim-latex
+# x11-plugins/gaim-otr
+# x11-plugins/gaim-rhythmbox
+# x11-plugins/gaim-xmms-remote
+# x11-plugins/gaimosd
+# x11-plugins/guifications
+
+
+print_gaim_warning() {
+ ewarn
+ ewarn "This is a beta release! Please back up everything in your .gaim"
+ ewarn "directory. We're looking for lots of feedback on this release"
+ ewarn "especially what you love about it and what you hate about it."
+ ewarn
+ ewarn "If you are merging ${MY_P} from an earlier version, you may need"
+ ewarn "to re-merge any plugins like gaim-encryption or gaim-snpp."
+ ewarn
+ ewarn "If you experience problems with gaim, file them as bugs with"
+ ewarn "Gentoo's bugzilla, http://bugs.gentoo.org. DO NOT report them"
+ ewarn "as bugs with gaim's sourceforge tracker, and by all means DO NOT"
+ ewarn "seek help in #gaim."
+ ewarn
+ ewarn "Be sure to USE=\"debug\" and include a backtrace for any seg"
+ ewarn "faults, see http://gaim.sourceforge.net/gdb.php for details on"
+ ewarn "backtraces."
+ ewarn
+ ewarn "Please read the gaim FAQ at http://gaim.sourceforge.net/faq.php"
+ ewarn
+ einfo
+ if use custom-flags; then
+ einfo "Note that you have chosen NOT TO FILTER UNSTABLE C[XX]FLAGS."
+ einfo "DO NOT file bugs with GENTOO or UPSTREAM while using custom-flags"
+ einfo
+ else
+ einfo "Note that we are now filtering all unstable flags in C[XX]FLAGS."
+ einfo
+ fi
+
+ if use silc; then
+ einfo "To be able to connect to silc network, you need to run"
+ einfo "\`usermod -c \"comment\"\` as user as which you are running gaim,"
+ einfo "where \"comment\" is either your real name if you want show it"
+ einfo "on silc or any othe not empty string."
+ einfo
+ fi
+ ebeep 5
+ epause 3
+}
+
+pkg_setup() {
+ print_gaim_warning
+
+ if use bonjour && use avahi && ! built_with_use net-dns/avahi howl-compat ; then
+ eerror
+ eerror You need to rebuild net-dns/avahi with USE=howl-compat in order
+ eerror to enable howl support for the bonjour protocol in gaim.
+ eerror
+ die "Configure failed"
+ fi
+
+ if use gadu && built_with_use net-libs/libgadu ssl ; then
+ eerror
+ eerror You need to rebuild net-libs/libgadu with USE=-ssl in order
+ eerror enable gadu gadu support in gaim.
+ eerror
+ die "Configure failed"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch "${FILESDIR}"/"${P}"-as-needed.patch
+ epatch "${FILESDIR}"/"${P}"-avahi-compat.patch
+ epatch "${FILESDIR}"/"${P}"-gtkconv.diff
+ epatch "${FILESDIR}"/"${P}"-icq.patch
+ eautoreconf || die "Failed running eautoreconf"
+}
+
+src_compile() {
+ # Stabilize things, for your own good
+ if ! use custom-flags; then
+ strip-flags
+ fi
+ replace-flags -O? -O2
+
+ # -msse2 doesn't play nice on gcc 3.2
+ [ "`gcc-version`" == "3.2" ] && filter-flags -msse2
+
+ local myconf
+
+ if ! use bonjour ; then
+ myconf="${myconf} --with-howl-includes=."
+ myconf="${myconf} --with-howl-libs=."
+ fi
+
+ if ! use silc; then
+ einfo "Disabling SILC protocol"
+ myconf="${myconf} --with-silc-includes=."
+ myconf="${myconf} --with-silc-libs=."
+ fi
+
+ if ! use gadu ; then
+ myconf="${myconf} --with-gadu-includes=."
+ myconf="${myconf} --with-gadu-libs=."
+ fi
+
+ if use ssl || use msn ; then
+ if use gnutls ; then
+ einfo "Disabling NSS, using GnuTLS"
+ myconf="${myconf} --enable-nss=no --enable-gnutls=yes"
+ myconf="${myconf} --with-gnutls-includes=/usr/include/gnutls"
+ myconf="${myconf} --with-gnutls-libs=/usr/$(get_libdir)"
+ else
+ einfo "Disabling GnuTLS, using NSS"
+ myconf="${myconf} --enable-gnutls=no --enable-nss=yes"
+ fi
+ else
+ einfo "No SSL support selected"
+ myconf="${myconf} --enable-gnutls=no --enable-nss=no"
+ fi
+
+ if use xscreensaver ; then
+ myconf="${myconf} --x-includes=/usr/include/X11"
+ fi
+
+ econf \
+ $(use_enable nls) \
+ $(use_enable perl) \
+ $(use_enable spell gtkspell) \
+ $(use_enable startup-notification) \
+ $(use_enable tcl) \
+ $(use_enable tk) \
+ $(use_enable mono) \
+ $(use_enable debug) \
+ $(use_enable dbus) \
+ $(use_enable meanwhile) \
+ $(use_enable nas) \
+ $(use_enable eds gevolution) \
+ $(use_enable audiofile audio) \
+ $(use_enable doc doxygen) \
+ ${myconf} || die "Configuration failed"
+
+ emake -j1 || die "Make failed"
+}
+
+src_install() {
+ make install DESTDIR=${D} || die "Install failed"
+ use perl && fixlocalpod
+ dodoc ABOUT-NLS AUTHORS COPYING HACKING INSTALL NEWS PROGRAMMING_NOTES README ChangeLog VERSION
+}
+
+pkg_postinst() {
+ print_gaim_warning
+}