summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2008-08-24 03:57:47 +0000
committerDaniel Black <dragonheart@gentoo.org>2008-08-24 03:57:47 +0000
commit6d68cbdb1869e1e0385fae6745bb9e1d0fed3dd6 (patch)
tree84d348307cb9a0734e26a917b869bb17a4bcf80b /net-im
parentuse eapi=1 (fixes bug #233200) (diff)
downloadgentoo-2-6d68cbdb1869e1e0385fae6745bb9e1d0fed3dd6.tar.gz
gentoo-2-6d68cbdb1869e1e0385fae6745bb9e1d0fed3dd6.tar.bz2
gentoo-2-6d68cbdb1869e1e0385fae6745bb9e1d0fed3dd6.zip
version bump. attempting to support --without-kde. Any probs let me know
(Portage version: 2.2_rc1/cvs/Linux 2.6.22-vs2.2.0.7-gentoo x86_64)
Diffstat (limited to 'net-im')
-rw-r--r--net-im/twinkle/ChangeLog9
-rw-r--r--net-im/twinkle/files/twinkle-1.3-gcc4.3.patch10
-rw-r--r--net-im/twinkle/files/twinkle-1.3.1-withoutkde.patch11
-rw-r--r--net-im/twinkle/twinkle-1.3.1.ebuild (renamed from net-im/twinkle/twinkle-1.3.ebuild)7
4 files changed, 23 insertions, 14 deletions
diff --git a/net-im/twinkle/ChangeLog b/net-im/twinkle/ChangeLog
index fdb4470dda02..c8531429c25a 100644
--- a/net-im/twinkle/ChangeLog
+++ b/net-im/twinkle/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-im/twinkle
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/twinkle/ChangeLog,v 1.42 2008/08/22 23:41:37 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/twinkle/ChangeLog,v 1.43 2008/08/24 03:57:46 dragonheart Exp $
+
+*twinkle-1.3.1 (24 Aug 2008)
+
+ 24 Aug 2008; Daniel Black <dragonheart@gentoo.org>
+ -files/twinkle-1.3-gcc4.3.patch, +files/twinkle-1.3.1-withoutkde.patch,
+ -twinkle-1.3.ebuild, +twinkle-1.3.1.ebuild:
+ version bump. attempting to support --without-kde. Any probs let me know
*twinkle-1.3 (22 Aug 2008)
diff --git a/net-im/twinkle/files/twinkle-1.3-gcc4.3.patch b/net-im/twinkle/files/twinkle-1.3-gcc4.3.patch
deleted file mode 100644
index 7859e85950fd..000000000000
--- a/net-im/twinkle/files/twinkle-1.3-gcc4.3.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- twinkle-1.3/src/utils/file_utils.cpp.orig 2008-08-23 09:13:35.000000000 +1000
-+++ twinkle-1.3/src/utils/file_utils.cpp 2008-08-23 09:14:14.000000000 +1000
-@@ -24,6 +24,7 @@
- #include <vector>
- #include <cerrno>
- #include <unistd.h>
-+#include <stdlib.h>
-
- using namespace std;
- using namespace utils;
diff --git a/net-im/twinkle/files/twinkle-1.3.1-withoutkde.patch b/net-im/twinkle/files/twinkle-1.3.1-withoutkde.patch
new file mode 100644
index 000000000000..5c74a98b1f6c
--- /dev/null
+++ b/net-im/twinkle/files/twinkle-1.3.1-withoutkde.patch
@@ -0,0 +1,11 @@
+--- twinkle-1.3.1/src/gui/twinkleapplication.h.orig 2008-08-24 13:44:29.000000000 +1000
++++ twinkle-1.3.1/src/gui/twinkleapplication.h 2008-08-24 13:44:42.000000000 +1000
+@@ -36,7 +36,7 @@
+ #ifdef HAVE_KDE
+ t_twinkle_application();
+ #else
+- t_twinkle_application(int &argv, char **argv);
++ t_twinkle_application(int &argc, char **argv);
+ #endif
+ virtual void commitData ( QSessionManager &sm );
+ };
diff --git a/net-im/twinkle/twinkle-1.3.ebuild b/net-im/twinkle/twinkle-1.3.1.ebuild
index 4e7a7005a6a2..4b2121447bd4 100644
--- a/net-im/twinkle/twinkle-1.3.ebuild
+++ b/net-im/twinkle/twinkle-1.3.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/twinkle/twinkle-1.3.ebuild,v 1.1 2008/08/22 23:41:37 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/twinkle/twinkle-1.3.1.ebuild,v 1.1 2008/08/24 03:57:46 dragonheart Exp $
EAPI=1
ARTS_REQUIRED="never"
@@ -13,7 +13,7 @@ SRC_URI="http://www.xs4all.nl/~mfnboer/twinkle/download/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-IUSE="arts speex ilbc zrtp kdehiddenvisibility"
+IUSE="kde arts speex ilbc zrtp kdehiddenvisibility"
# Requires libqt-mt actually... Is that *always* built, or do we need to check?
RDEPEND=">=net-libs/ccrtp-1.6.0
@@ -39,11 +39,12 @@ pkg_setup() {
src_unpack() {
unpack ${A}
- epatch "${FILESDIR}"/${P}-gcc4.3.patch
+ epatch "${FILESDIR}"/${P}-withoutkde.patch
}
src_compile() {
local myconf=" \
+ $(use_with kde) \
$(use_with ilbc) \
$(use_with arts) \
$(use_with zrtp) \