summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2009-11-22 14:59:24 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2009-11-22 14:59:24 +0000
commit49fe98d12d1c070de0c3db97c8ac8034c83d131a (patch)
treed7a500356ea1e54e7b547d877863c3ef010d8dea /net-im
parentMask net-mail/vimap for removal (diff)
downloadgentoo-2-49fe98d12d1c070de0c3db97c8ac8034c83d131a.tar.gz
gentoo-2-49fe98d12d1c070de0c3db97c8ac8034c83d131a.tar.bz2
gentoo-2-49fe98d12d1c070de0c3db97c8ac8034c83d131a.zip
Moved from sunrise. Fixes bug #227627
(Portage version: 2.2_rc51/cvs/Linux x86_64)
Diffstat (limited to 'net-im')
-rw-r--r--net-im/qutim/ChangeLog11
-rw-r--r--net-im/qutim/metadata.xml19
-rw-r--r--net-im/qutim/qutim-0.2.0.ebuild72
3 files changed, 102 insertions, 0 deletions
diff --git a/net-im/qutim/ChangeLog b/net-im/qutim/ChangeLog
new file mode 100644
index 000000000000..83233abd0996
--- /dev/null
+++ b/net-im/qutim/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for net-im/qutim
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/qutim/ChangeLog,v 1.1 2009/11/22 14:59:24 hwoarang Exp $
+
+*qutim-0.2.0 (22 Nov 2009)
+
+ 22 Nov 2009; Markos Chandras <hwoarang@gentoo.org> +qutim-0.2.0.ebuild:
+ Moved from sunrise overlay. Thanks to Sergey Kondakov
+ <virtuousfox@gmail.com>
+ for the base ebuild. Fixes bug #227627
+
diff --git a/net-im/qutim/metadata.xml b/net-im/qutim/metadata.xml
new file mode 100644
index 000000000000..8f9a1a8e4b72
--- /dev/null
+++ b/net-im/qutim/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>qt</herd>
+<maintainer>
+<email>hwoarang@gentoo.org</email>
+<name>Markos Chandras</name>
+</maintainer>
+<use>
+ <flag name="irc">Enable irc support</flag>
+ <flag name="histman">Enable histman plugin</flag>
+ <flag name="mrim">Enable mrim plugin</flag>
+ <flag name="vkontakte">Enable vkontakte plugin</flag>
+ <flag name="yandexnarod">Enable yanderx.narod plugin</flag>
+</use>
+<longdescription lang="en">
+</longdescription>
+</pkgmetadata>
+
diff --git a/net-im/qutim/qutim-0.2.0.ebuild b/net-im/qutim/qutim-0.2.0.ebuild
new file mode 100644
index 000000000000..b59a82203f61
--- /dev/null
+++ b/net-im/qutim/qutim-0.2.0.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/qutim/qutim-0.2.0.ebuild,v 1.1 2009/11/22 14:59:24 hwoarang Exp $
+
+EAPI="2"
+
+inherit eutils qt4 cmake-utils
+MY_PN="${PN/im/IM}"
+
+DESCRIPTION="New Qt4-based Instant Messenger (ICQ)."
+HOMEPAGE="http://www.qutim.org"
+LICENSE="GPL-2"
+SRC_URI="http://qutim.org/uploads/src/${P}.tar.bz2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug histman icq irc jabber gnutls mrim ssl vkontakte yandexnarod"
+
+DEPEND="x11-libs/qt-gui:4[debug?]
+ x11-libs/qt-webkit:4
+ media-sound/phonon
+ jabber? ( ssl? ( dev-libs/openssl )
+ gnutls? ( net-libs/gnutls ) )"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ # build main executable
+ cmake-utils_src_compile
+
+ # build protocol support
+ if use jabber; then
+ cd "${S}"/plugins/jabber || die
+ mkdir build
+ cd build
+ cmake -C "${TMPDIR}"/gentoo_common_config.cmake \
+ $(cmake-utils_use ssl OpenSSL) \
+ $(cmake-utils_use gnutls GNUTLS) ../ || die
+ emake || die
+ fi
+ # build mrim
+ if use mrim; then
+ cd "${S}"/plugins/mrim || die
+ mkdir build
+ cd build
+ cmake -C "${TMPDIR}"/gentoo_common_config.cmake ../ || die
+ emake || die "failed to compile mrim plugin"
+ fi
+ # Qt4 based projects so I shall use eqmake4
+ cd "${S}"/plugins || die
+ for i in histman yandexnarod icq irc vkontakte;do
+ if use ${i}; then
+ cd "${i}"
+ einfo "now building ${i}-plugin"
+ eqmake4 ${i}.pro
+ emake || die "failed to compile ${i} plugin"
+ cd ..
+ fi
+ done
+}
+
+src_install(){
+ # not recommended by upstream and probably broken
+ #cmake-utils_src_install
+ dobin "${WORKDIR}/${P}_build/${PN}" || die
+
+ cd "${S}"/plugins || die
+ insinto "/usr/$(get_libdir)/qutim"
+ doins $(find . -type f -executable -iname "*.so") || die
+ doicon "${S}"/icons/${PN}_64.png || die "Failed to install icon"
+ make_desktop_entry ${PN} ${MY_PN} ${PN}_64.png \
+ "Network;InstantMessaging;Qt" || die "make_desktop_entry failed"
+}