summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-06-28 17:14:13 +0000
committerJustin Lecher <jlec@gentoo.org>2015-06-28 17:14:13 +0000
commit45aa57ce1de29ff5cf3a5757576e03c4b7ce9b35 (patch)
tree8f5b23a081d1d3f6f75ebf95bcc970299e05e2da /net-im
parentcheck disk space, bug 552322 thanks to Dennis Schridde (diff)
downloadgentoo-2-45aa57ce1de29ff5cf3a5757576e03c4b7ce9b35.tar.gz
gentoo-2-45aa57ce1de29ff5cf3a5757576e03c4b7ce9b35.tar.bz2
gentoo-2-45aa57ce1de29ff5cf3a5757576e03c4b7ce9b35.zip
Add fix for ncurses[tinfo], bug #461482
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key E9402A79B03529A2!)
Diffstat (limited to 'net-im')
-rw-r--r--net-im/pidgin/ChangeLog6
-rw-r--r--net-im/pidgin/files/pidgin-2.10.11-tinfo.patch25
-rw-r--r--net-im/pidgin/pidgin-2.10.11.ebuild18
3 files changed, 41 insertions, 8 deletions
diff --git a/net-im/pidgin/ChangeLog b/net-im/pidgin/ChangeLog
index 9961d123a9a0..8bfcaf71a695 100644
--- a/net-im/pidgin/ChangeLog
+++ b/net-im/pidgin/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-im/pidgin
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/pidgin/ChangeLog,v 1.369 2015/06/27 12:33:37 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/pidgin/ChangeLog,v 1.370 2015/06/28 17:14:13 jlec Exp $
+
+ 28 Jun 2015; Justin Lecher <jlec@gentoo.org>
+ +files/pidgin-2.10.11-tinfo.patch, pidgin-2.10.11.ebuild:
+ Add fix for ncurses[tinfo], bug #461482
27 Jun 2015; Markus Meier <maekke@gentoo.org> pidgin-2.10.11.ebuild:
arm stable, bug #530674
diff --git a/net-im/pidgin/files/pidgin-2.10.11-tinfo.patch b/net-im/pidgin/files/pidgin-2.10.11-tinfo.patch
new file mode 100644
index 000000000000..b7fd91da13f7
--- /dev/null
+++ b/net-im/pidgin/files/pidgin-2.10.11-tinfo.patch
@@ -0,0 +1,25 @@
+ configure.ac | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+diff --git a/configure.ac b/configure.ac
+index 51471b1..16982cf 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -638,6 +638,8 @@ if test "x$enable_consoleui" = "xyes"; then
+ AC_CHECK_LIB(ncursesw, initscr, [GNT_LIBS="-lncursesw"], [enable_consoleui=no])
+ AC_CHECK_LIB(panelw, update_panels, [GNT_LIBS="$GNT_LIBS -lpanelw"],
+ [enable_consoleui=no], [$GNT_LIBS])
++ AC_CHECK_LIB(tinfow, termname, [GNT_LIBS="$GNT_LIBS -ltinfow"],
++ [enable_consoleui=no], [$GNT_LIBS])
+
+ if test "x$enable_consoleui" = "xyes"; then
+ dnl # Some distros put the headers in ncursesw/, some don't
+@@ -690,6 +692,8 @@ if test "x$enable_consoleui" = "xyes"; then
+ AC_CHECK_LIB(ncurses, initscr, [GNT_LIBS="-lncurses"], [enable_consoleui=no])
+ AC_CHECK_LIB(panel, update_panels, [GNT_LIBS="$GNT_LIBS -lpanel"],
+ [enable_consoleui=no], [$GNT_LIBS])
++ AC_CHECK_LIB(tinfo, termname, [GNT_LIBS="$GNT_LIBS -ltinfo"],
++ [enable_consoleui=no], [$GNT_LIBS])
+ AC_DEFINE(NO_WIDECHAR, 1, [Define to 1 if you don't have wide-character support.])
+ if test x"$ac_ncurses_includes" != "x"; then
+ GNT_CFLAGS="-I$ac_ncurses_includes"
diff --git a/net-im/pidgin/pidgin-2.10.11.ebuild b/net-im/pidgin/pidgin-2.10.11.ebuild
index dc60cde94175..f0130334d13b 100644
--- a/net-im/pidgin/pidgin-2.10.11.ebuild
+++ b/net-im/pidgin/pidgin-2.10.11.ebuild
@@ -1,16 +1,18 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/pidgin/pidgin-2.10.11.ebuild,v 1.8 2015/06/27 12:33:37 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/pidgin/pidgin-2.10.11.ebuild,v 1.9 2015/06/28 17:14:13 jlec Exp $
EAPI=5
GENTOO_DEPEND_ON_PERL=no
-PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
+PYTHON_COMPAT=( python2_7 python3_{3,4} )
+
inherit autotools flag-o-matic eutils toolchain-funcs multilib perl-app gnome2 python-single-r1
DESCRIPTION="GTK Instant Messenger client"
HOMEPAGE="http://pidgin.im/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2
+SRC_URI="
+ mirror://sourceforge/${PN}/${P}.tar.bz2
http://dev.gentoo.org/~polynomial-c/${PN}-eds-3.6.patch.bz2"
LICENSE="GPL-2"
@@ -137,10 +139,12 @@ pkg_setup() {
}
src_prepare() {
- epatch "${FILESDIR}/${PN}-2.10.0-gold.patch" \
- "${WORKDIR}/${PN}-eds-3.6.patch" \
- "${FILESDIR}/${PN}-2.10.9-fix-gtkmedia.patch" \
- "${FILESDIR}/${PN}-2.10.10-eds-3.6-configure.ac.patch"
+ epatch \
+ "${FILESDIR}"/${PN}-2.10.0-gold.patch \
+ "${WORKDIR}"/${PN}-eds-3.6.patch \
+ "${FILESDIR}"/${PN}-2.10.9-fix-gtkmedia.patch \
+ "${FILESDIR}"/${PN}-2.10.10-eds-3.6-configure.ac.patch \
+ "${FILESDIR}"/${P}-tinfo.patch
epatch_user
eautoreconf