summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2014-06-14 16:37:16 +0000
committerManuel Rüger <mrueg@gentoo.org>2014-06-14 16:37:16 +0000
commit3f0698f99157797602d122d1582333d7b88c23dd (patch)
tree7dbe7bf692d25f69c05fdbfdbb8edd13c772bea7 /net-im
parentVersion bump. (diff)
downloadgentoo-2-3f0698f99157797602d122d1582333d7b88c23dd.tar.gz
gentoo-2-3f0698f99157797602d122d1582333d7b88c23dd.tar.bz2
gentoo-2-3f0698f99157797602d122d1582333d7b88c23dd.zip
Version bump.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'net-im')
-rw-r--r--net-im/licq/ChangeLog9
-rw-r--r--net-im/licq/licq-1.8.2.ebuild76
2 files changed, 83 insertions, 2 deletions
diff --git a/net-im/licq/ChangeLog b/net-im/licq/ChangeLog
index 38517258a642..a6ea14eaf2ff 100644
--- a/net-im/licq/ChangeLog
+++ b/net-im/licq/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-im/licq
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/licq/ChangeLog,v 1.130 2013/12/06 08:00:33 polynomial-c Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/licq/ChangeLog,v 1.131 2014/06/14 16:37:16 mrueg Exp $
+
+*licq-1.8.2 (14 Jun 2014)
+
+ 14 Jun 2014; Manuel Rüger <mrueg@gentoo.org> +licq-1.8.2.ebuild:
+ Version bump.
06 Dec 2013; Lars Wendler <polynomial-c@gentoo.org> licq-1.3.8-r1.ebuild,
licq-1.3.9.ebuild, licq-1.8.1.ebuild:
diff --git a/net-im/licq/licq-1.8.2.ebuild b/net-im/licq/licq-1.8.2.ebuild
new file mode 100644
index 000000000000..c64ec689e5a8
--- /dev/null
+++ b/net-im/licq/licq-1.8.2.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/licq/licq-1.8.2.ebuild,v 1.1 2014/06/14 16:37:16 mrueg Exp $
+
+EAPI=5
+
+inherit cmake-utils eutils flag-o-matic
+
+DESCRIPTION="ICQ Client with v8 support"
+HOMEPAGE="http://www.licq.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc linguas_he nls socks5 ssl xosd aosd jabber qt4 msn"
+
+RDEPEND=">=app-crypt/gpgme-1
+ jabber? ( net-libs/gloox )
+ qt4? ( dev-qt/qtgui:4 )
+ socks5? ( net-proxy/dante )
+ ssl? ( >=dev-libs/openssl-0.9.5a )
+ xosd? ( x11-libs/xosd )
+ aosd? ( x11-libs/libaosd )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen[dot] )
+ nls? ( sys-devel/gettext )
+ dev-libs/boost"
+
+src_prepare() {
+ local licq_plugins="auto-reply icq rms"
+ use msn && licq_plugins+=" msn"
+ use xosd && licq_plugins+=" osd"
+ use aosd && licq_plugins+=" aosd"
+ use jabber && licq_plugins+=" jabber"
+ use qt4 && licq_plugins+=" qt4-gui"
+
+ local plugins="" x
+ for x in ${licq_plugins}; do
+ plugins+=" ${x}\/CMakeLists.txt"
+ done
+
+ sed -i -e "s/file(GLOB cmake_plugins.*$/set(cmake_plugins ${plugins})/" plugins/CMakeLists.txt
+}
+
+pkg_setup() {
+ # crutch
+ append-flags -pthread
+}
+
+src_configure() {
+ local myopts="-DCMAKE_BUILD_TYPE=$(use debug && echo 'Debug' || echo 'Release')"
+ mycmakeargs="$myopts
+ $(cmake-utils_use doc USE_DOXYGEN)
+ $(cmake-utils_use linguas_he USE_HEBREW)
+ $(cmake-utils_use nls ENABLE_NLS)
+ $(cmake-utils_use socks5 USE_SOCKS5)
+ $(cmake-utils_use ssl USE_OPENSSL)
+ -DUSE_FIFO=ON
+ -DBUILD_PLUGINS=ON"
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ dodoc README
+
+ docinto doc
+ dodoc doc/*
+
+ use ssl && dodoc README.OPENSSL
+
+ exeinto /usr/share/${PN}/upgrade
+ doexe upgrade/*.pl
+}