summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2008-10-28 13:03:06 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2008-10-28 13:03:06 +0000
commit3745c98207ca4e5235477b64d2f54f8af3cfd6b8 (patch)
treeea5f8cd6227ae8a59f4b26e7fb66aff5b7d0c1a9 /net-im
parentMarking nfs-utils-1.1.3 ppc64 for bug 242696 (diff)
downloadgentoo-2-3745c98207ca4e5235477b64d2f54f8af3cfd6b8.tar.gz
gentoo-2-3745c98207ca4e5235477b64d2f54f8af3cfd6b8.tar.bz2
gentoo-2-3745c98207ca4e5235477b64d2f54f8af3cfd6b8.zip
Add patch for building with --as-needed (upstream bug #7391).
(Portage version: 2.2_rc12/cvs/Linux 2.6.27-gentoo-r1 x86_64)
Diffstat (limited to 'net-im')
-rw-r--r--net-im/pidgin/ChangeLog6
-rw-r--r--net-im/pidgin/files/pidgin-2.5.2-asneeded.patch12
-rw-r--r--net-im/pidgin/pidgin-2.5.2.ebuild14
3 files changed, 29 insertions, 3 deletions
diff --git a/net-im/pidgin/ChangeLog b/net-im/pidgin/ChangeLog
index e8e1cb230a8a..c8a36542e1d0 100644
--- a/net-im/pidgin/ChangeLog
+++ b/net-im/pidgin/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-im/pidgin
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/pidgin/ChangeLog,v 1.71 2008/10/24 16:22:18 tester Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/pidgin/ChangeLog,v 1.72 2008/10/28 13:03:06 flameeyes Exp $
+
+ 28 Oct 2008; Diego Pettenò <flameeyes@gentoo.org>
+ +files/pidgin-2.5.2-asneeded.patch, pidgin-2.5.2.ebuild:
+ Add patch for building with --as-needed (upstream bug #7391).
*pidgin-2.5.2 (24 Oct 2008)
diff --git a/net-im/pidgin/files/pidgin-2.5.2-asneeded.patch b/net-im/pidgin/files/pidgin-2.5.2-asneeded.patch
new file mode 100644
index 000000000000..7c774e0c13bb
--- /dev/null
+++ b/net-im/pidgin/files/pidgin-2.5.2-asneeded.patch
@@ -0,0 +1,12 @@
+Index: pidgin-2.5.2/pidgin/Makefile.am
+===================================================================
+--- pidgin-2.5.2.orig/pidgin/Makefile.am
++++ pidgin-2.5.2/pidgin/Makefile.am
+@@ -188,6 +188,7 @@ pidgin_DEPENDENCIES = @LIBOBJS@
+ pidgin_LDFLAGS = -export-dynamic
+ pidgin_LDADD = \
+ @LIBOBJS@ \
++ $(GLIB_LIBS) \
+ $(DBUS_LIBS) \
+ $(GSTREAMER_LIBS) \
+ $(XSS_LIBS) \
diff --git a/net-im/pidgin/pidgin-2.5.2.ebuild b/net-im/pidgin/pidgin-2.5.2.ebuild
index f366c2381dff..4462312d447a 100644
--- a/net-im/pidgin/pidgin-2.5.2.ebuild
+++ b/net-im/pidgin/pidgin-2.5.2.ebuild
@@ -1,8 +1,10 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/pidgin/pidgin-2.5.2.ebuild,v 1.1 2008/10/24 16:22:18 tester Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/pidgin/pidgin-2.5.2.ebuild,v 1.2 2008/10/28 13:03:06 flameeyes Exp $
-inherit flag-o-matic eutils toolchain-funcs multilib perl-app gnome2
+WANT_AUTOMAKE="1.9"
+
+inherit flag-o-matic eutils toolchain-funcs multilib perl-app gnome2 autotools
DESCRIPTION="GTK Instant Messenger client"
HOMEPAGE="http://pidgin.im/"
@@ -104,6 +106,14 @@ pkg_setup() {
}
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-asneeded.patch
+ eautomake
+}
+
src_compile() {
# Stabilize things, for your own good
strip-flags