summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-10-27 17:19:04 +0000
committerJustin Lecher <jlec@gentoo.org>2010-10-27 17:19:04 +0000
commit0dcc30e37e5b14c77a3531754c8340f85147e7e5 (patch)
tree266803d32c84f49e06566be4e980676630b71304 /net-im
parentdev-vcs/svneverever: Drop back to Python 2.x only (diff)
downloadgentoo-2-0dcc30e37e5b14c77a3531754c8340f85147e7e5.tar.gz
gentoo-2-0dcc30e37e5b14c77a3531754c8340f85147e7e5.tar.bz2
gentoo-2-0dcc30e37e5b14c77a3531754c8340f85147e7e5.zip
Version Bump, support python abis
(Portage version: 2.2.0_alpha1/cvs/Linux x86_64)
Diffstat (limited to 'net-im')
-rw-r--r--net-im/gajim/ChangeLog8
-rw-r--r--net-im/gajim/files/0.14.1-testing.patch13
-rw-r--r--net-im/gajim/gajim-0.14.1.ebuild117
3 files changed, 137 insertions, 1 deletions
diff --git a/net-im/gajim/ChangeLog b/net-im/gajim/ChangeLog
index 221fbf1779e9..1ddf2da09088 100644
--- a/net-im/gajim/ChangeLog
+++ b/net-im/gajim/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-im/gajim
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/gajim/ChangeLog,v 1.104 2010/10/18 13:51:40 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/gajim/ChangeLog,v 1.105 2010/10/27 17:19:04 jlec Exp $
+
+*gajim-0.14.1 (27 Oct 2010)
+
+ 27 Oct 2010; Justin Lecher <jlec@gentoo.org> +files/0.14.1-testing.patch,
+ +gajim-0.14.1.ebuild:
+ Version Bump, support python abis
18 Oct 2010; Raúl Porcel <armin76@gentoo.org> gajim-0.13.3.ebuild:
ia64 stable
diff --git a/net-im/gajim/files/0.14.1-testing.patch b/net-im/gajim/files/0.14.1-testing.patch
new file mode 100644
index 000000000000..10dd844e7902
--- /dev/null
+++ b/net-im/gajim/files/0.14.1-testing.patch
@@ -0,0 +1,13 @@
+diff --git a/Makefile.am b/Makefile.am
+index 4e70251..8b8702f 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -59,7 +59,7 @@ MAINTAINERCLEANDIRS = \
+
+
+ test:
+- python test/runtests.py
++ $(GENTOOPY) test/runtests.py
+ .PHONY: test
+
+ doc:
diff --git a/net-im/gajim/gajim-0.14.1.ebuild b/net-im/gajim/gajim-0.14.1.ebuild
new file mode 100644
index 000000000000..11c4cac32019
--- /dev/null
+++ b/net-im/gajim/gajim-0.14.1.ebuild
@@ -0,0 +1,117 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/gajim/gajim-0.14.1.ebuild,v 1.1 2010/10/27 17:19:04 jlec Exp $
+
+EAPI="2"
+
+PYTHON_DEPEND="2"
+PYTHON_USE_WITH="sqlite xml"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit eutils python versionator
+
+DESCRIPTION="Jabber client written in PyGTK"
+HOMEPAGE="http://www.gajim.org/"
+SRC_URI="http://www.gajim.org/downloads/$(get_version_component_range 1-2)/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="avahi crypt dbus gnome idle jingle libnotify networkmanager nls spell srv X xhtml"
+
+COMMON_DEPEND="
+ x11-libs/gtk+:2
+ >=dev-python/pygtk-2.16.0"
+
+DEPEND="${COMMON_DEPEND}
+ >=sys-devel/gettext-0.17-r1
+ >=dev-util/intltool-0.40.1
+ dev-util/pkgconfig"
+
+RDEPEND="${COMMON_DEPEND}
+ dev-python/pyopenssl
+ dev-python/sexy-python
+ crypt? (
+ app-crypt/gnupg
+ dev-python/pycrypto
+ )
+ dbus? (
+ dev-python/dbus-python
+ dev-libs/dbus-glib
+ libnotify? ( dev-python/notify-python )
+ avahi? ( net-dns/avahi[dbus,gtk,python] )
+ )
+ gnome? (
+ dev-python/libgnome-python
+ dev-python/gnome-keyring-python
+ dev-python/egg-python
+ )
+ idle? ( x11-libs/libXScrnSaver )
+ jingle? ( net-libs/farsight2[python] )
+ networkmanager? (
+ dev-python/dbus-python
+ || ( >=net-misc/networkmanager-0.7.1 net-misc/networkmanager[gnome] )
+ )
+ srv? (
+ || (
+ dev-python/libasyncns-python
+ net-dns/bind-tools )
+ )
+ spell? ( app-text/gtkspell )
+ xhtml? ( dev-python/docutils )"
+
+pkg_setup() {
+ if ! use dbus; then
+ if use libnotify; then
+ eerror "The dbus USE flag is required for libnotify support"
+ die "USE=\"dbus\" needed for libnotify support"
+ fi
+ if use avahi; then
+ eerror "The dbus USE flag is required for avahi support"
+ die "USE=\"dbus\" needed for avahi support"
+ fi
+ fi
+ python_pkg_setup
+}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/0.14-python-version.patch \
+ "${FILESDIR}"/0.14.1-testing.patch
+ echo '#!/bin/sh' > config/py-compile
+
+}
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ $(use_with X x) \
+ --docdir="/usr/share/doc/${PF}" \
+ --enable-site-packages
+}
+
+src_test() {
+ testing() {
+ emake \
+ GENTOOPY="$(PYTHON)" \
+ test || die
+ }
+# not implemented
+# python_execute_function testing
+}
+
+src_install() {
+ installation() {
+ emake \
+ GAJIM_SRCDIR="$(python_get_sitedir)"/${PN} \
+ pythondir="$(python_get_sitedir)" \
+ pyexecdir="$(python_get_sitedir)" \
+ DESTDIR="${D}" \
+ install || die
+ }
+
+ python_execute_function installation
+
+ rm "${D}/usr/share/doc/${PF}/"{README.html,COPYING} || die
+ dohtml README.html || die
+}