summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorWolfram Schlich <wschlich@gentoo.org>2007-06-21 06:10:52 +0000
committerWolfram Schlich <wschlich@gentoo.org>2007-06-21 06:10:52 +0000
commit00e8a890fc44fdb7a62e1878a86984b0e5ff3181 (patch)
tree60a41f906883540c19c25745b31b79878541a2dc /net-im
parentStable on arm wrt bug 130922. (diff)
downloadgentoo-2-00e8a890fc44fdb7a62e1878a86984b0e5ff3181.tar.gz
gentoo-2-00e8a890fc44fdb7a62e1878a86984b0e5ff3181.tar.bz2
gentoo-2-00e8a890fc44fdb7a62e1878a86984b0e5ff3181.zip
version bump
(Portage version: 2.1.3_rc3)
Diffstat (limited to 'net-im')
-rw-r--r--net-im/mcabber/ChangeLog7
-rw-r--r--net-im/mcabber/files/digest-mcabber-0.9.33
-rw-r--r--net-im/mcabber/mcabber-0.9.3.ebuild85
3 files changed, 94 insertions, 1 deletions
diff --git a/net-im/mcabber/ChangeLog b/net-im/mcabber/ChangeLog
index bb6a88b9a5ea..135048f55fbe 100644
--- a/net-im/mcabber/ChangeLog
+++ b/net-im/mcabber/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-im/mcabber
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/mcabber/ChangeLog,v 1.15 2007/06/12 23:28:27 wschlich Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/mcabber/ChangeLog,v 1.16 2007/06/21 06:10:52 wschlich Exp $
+
+*mcabber-0.9.3 (20 Jun 2007)
+
+ 20 Jun 2007; Wolfram Schlich <wschlich@gentoo.org> +mcabber-0.9.3.ebuild:
+ version bump
*mcabber-0.9.2 (12 Jun 2007)
diff --git a/net-im/mcabber/files/digest-mcabber-0.9.3 b/net-im/mcabber/files/digest-mcabber-0.9.3
new file mode 100644
index 000000000000..f592ff1bd4fb
--- /dev/null
+++ b/net-im/mcabber/files/digest-mcabber-0.9.3
@@ -0,0 +1,3 @@
+MD5 26bc2d698c1311e1ef4eec5109a45c39 mcabber-0.9.3.tar.bz2 437100
+RMD160 5bc5d28442fe287ed2591154b7183fa0020b7f7a mcabber-0.9.3.tar.bz2 437100
+SHA256 ee5bc81da96b958aee7b277bb6fdeeace1a8fff5e41ec61053c63cdb63016406 mcabber-0.9.3.tar.bz2 437100
diff --git a/net-im/mcabber/mcabber-0.9.3.ebuild b/net-im/mcabber/mcabber-0.9.3.ebuild
new file mode 100644
index 000000000000..70468e0bb69c
--- /dev/null
+++ b/net-im/mcabber/mcabber-0.9.3.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/mcabber/mcabber-0.9.3.ebuild,v 1.1 2007/06/21 06:10:52 wschlich Exp $
+
+DESCRIPTION="A small Jabber console client with various features, like MUC, SSL, PGP"
+HOMEPAGE="http://www.lilotux.net/~mikael/mcabber/"
+SRC_URI="http://www.lilotux.net/~mikael/${PN}/files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="ssl crypt"
+
+LANGS="de en fr nl pl uk ru"
+# localized help versions are installed only, when LINGUAS var is set
+for i in ${LANGS}; do
+ IUSE="${IUSE} linguas_${i}"
+done;
+
+DEPEND="ssl? ( >=dev-libs/openssl-0.9.7-r1 )
+ crypt? ( >=app-crypt/gpgme-1.0.0 )
+ >=dev-libs/glib-2.0.0
+ sys-libs/ncurses"
+
+src_compile() {
+ econf \
+ $(use_enable crypt gpgme) \
+ $(use_with ssl) \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ make install DESTDIR=${D} || die "make install failed"
+ # clean unneeded language documentation
+ for i in ${LANGS}; do
+ ! use linguas_${i} && rm -rf ${D}/usr/share/${PN}/help/${i}
+ done
+
+ dodoc AUTHORS ChangeLog NEWS README TODO mcabberrc.example
+ dodoc doc/README_PGP.txt
+
+ # contrib themes
+ insinto /usr/share/${PN}/themes
+ doins ${S}/contrib/themes/*
+
+ # contrib generic scripts
+ exeinto /usr/share/${PN}/scripts
+ doexe ${S}/contrib/*.{pl,py,rb}
+
+ # contrib event scripts
+ exeinto /usr/share/${PN}/scripts/events
+ doexe ${S}/contrib/events/*
+}
+
+pkg_postinst() {
+ elog
+ elog "MCabber requires you to create a subdirectory .mcabber in your home"
+ elog "directory and to place a configuration file there."
+ elog "An example mcabberrc was installed as part of the documentation."
+ elog "To create a new mcabberrc based on the example mcabberrc, execute the"
+ elog "following commands:"
+ elog
+ elog " mkdir -p ~/.mcabber"
+ elog " bzcat ${ROOT}usr/share/doc/${PF}/mcabberrc.example.bz2 >~/.mcabber/mcabberrc"
+ elog
+ elog "Then edit ~/.mcabber/mcabberrc with your favorite editor."
+ elog
+ elog "As of MCabber version 0.8.2, there is also a wizard script"
+ elog "with which you can create all necessary configuration options."
+ elog "To use it, simply execute the following command:"
+ elog
+ elog " ${ROOT}usr/share/${PN}/scripts/mcwizz.rb"
+ elog
+ elog "See the CONFIGURATION FILE and FILES sections of the mcabber"
+ elog "manual page (section 1) for more information."
+ elog
+ elog "From version 0.9.0 on, MCabber supports PGP encryption of messages."
+ elog "See README_PGP.txt for details."
+ elog
+ elog "Check out ${ROOT}usr/share/${PN} for contributed themes and event scripts."
+ elog
+}