summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2011-06-04 17:38:34 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2011-06-04 17:38:34 +0000
commitc8c1b98bc3659e330ee2d8251c824c0f3bfedfcd (patch)
treeaa65af68d4bef60ade53b54f863a0b98dd46255d /net-im/skype
parentMove count function out of global scope. (diff)
downloadgentoo-2-c8c1b98bc3659e330ee2d8251c824c0f3bfedfcd.tar.gz
gentoo-2-c8c1b98bc3659e330ee2d8251c824c0f3bfedfcd.tar.bz2
gentoo-2-c8c1b98bc3659e330ee2d8251c824c0f3bfedfcd.zip
Version bump. Bug #369827. Drop stable amd64 keyword. Bug #357475
(Portage version: 2.2.0_alpha37/cvs/Linux x86_64)
Diffstat (limited to 'net-im/skype')
-rw-r--r--net-im/skype/ChangeLog8
-rw-r--r--net-im/skype/skype-2.1.0.81.ebuild4
-rw-r--r--net-im/skype/skype-2.2.0.35.ebuild118
3 files changed, 127 insertions, 3 deletions
diff --git a/net-im/skype/ChangeLog b/net-im/skype/ChangeLog
index b6708e473c26..60cb6180793d 100644
--- a/net-im/skype/ChangeLog
+++ b/net-im/skype/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-im/skype
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/skype/ChangeLog,v 1.115 2011/04/07 09:24:46 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/skype/ChangeLog,v 1.116 2011/06/04 17:38:34 hwoarang Exp $
+
+*skype-2.2.0.35 (04 Jun 2011)
+
+ 04 Jun 2011; Markos Chandras <hwoarang@gentoo.org> skype-2.1.0.81.ebuild,
+ +skype-2.2.0.35.ebuild:
+ Version bump. Bug #369827. Drop stable amd64 keyword. Bug #357475
*skype-2.2.0.25 (07 Apr 2011)
diff --git a/net-im/skype/skype-2.1.0.81.ebuild b/net-im/skype/skype-2.1.0.81.ebuild
index a0635890c96a..b5911c6d80ab 100644
--- a/net-im/skype/skype-2.1.0.81.ebuild
+++ b/net-im/skype/skype-2.1.0.81.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/skype/skype-2.1.0.81.ebuild,v 1.9 2011/03/06 11:58:17 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/skype/skype-2.1.0.81.ebuild,v 1.10 2011/06/04 17:38:34 hwoarang Exp $
EAPI=3
inherit gnome2-utils eutils qt4 pax-utils
@@ -15,7 +15,7 @@ SRC_URI="!qt-static? ( http://download.skype.com/linux/${DFILENAME} )
LICENSE="skype-eula"
SLOT="0"
-KEYWORDS="amd64 ~x86"
+KEYWORDS="~amd64 ~x86"
IUSE="qt-static"
RESTRICT="mirror strip" # Bug 299368
diff --git a/net-im/skype/skype-2.2.0.35.ebuild b/net-im/skype/skype-2.2.0.35.ebuild
new file mode 100644
index 000000000000..452777ca7b3d
--- /dev/null
+++ b/net-im/skype/skype-2.2.0.35.ebuild
@@ -0,0 +1,118 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/skype/skype-2.2.0.35.ebuild,v 1.1 2011/06/04 17:38:34 hwoarang Exp $
+
+EAPI=4
+inherit gnome2-utils eutils qt4-r2 pax-utils
+
+SFILENAME=${PN}_static-${PV}.tar.bz2
+DFILENAME=${P}.tar.bz2
+
+DESCRIPTION="A P2P-VoiceIP client."
+HOMEPAGE="http://www.skype.com/"
+SRC_URI="!qt-static? ( http://download.skype.com/linux/${DFILENAME} )
+ qt-static? ( http://download.skype.com/linux/${SFILENAME} )"
+
+LICENSE="skype-eula"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="qt-static"
+
+RESTRICT="mirror strip" # Bug 299368
+EMUL_VER=20091231
+
+RDEPEND="
+ amd64? ( >=app-emulation/emul-linux-x86-xlibs-${EMUL_VER}
+ >=app-emulation/emul-linux-x86-baselibs-${EMUL_VER}
+ >=app-emulation/emul-linux-x86-soundlibs-${EMUL_VER}
+ >=app-emulation/emul-linux-x86-opengl-${EMUL_VER}
+ !qt-static? ( >=app-emulation/emul-linux-x86-qtlibs-${EMUL_VER} ) )
+ x86? ( >=media-libs/alsa-lib-1.0.11
+ x11-libs/libXScrnSaver
+ x11-libs/libXv
+ qt-static? ( media-libs/alsa-lib
+ x11-libs/libXv
+ x11-libs/libXScrnSaver
+ x11-libs/libSM
+ x11-libs/libICE
+ x11-libs/libXi
+ x11-libs/libXrender
+ x11-libs/libXrandr
+ media-libs/freetype
+ media-libs/fontconfig
+ x11-libs/libXext
+ x11-libs/libX11
+ dev-libs/glib:2 )
+ !qt-static? ( media-libs/alsa-lib
+ x11-libs/libXv
+ x11-libs/libXScrnSaver
+ x11-libs/qt-gui:4[accessibility,dbus]
+ x11-libs/qt-dbus:4
+ x11-libs/libXext
+ x11-libs/libX11 ) )
+ virtual/ttf-fonts"
+
+# Required for lrelease command at buildtime
+DEPEND="!qt-static? ( x11-libs/qt-core:4 )"
+
+QA_EXECSTACK="opt/skype/skype"
+QA_WX_LOAD="opt/skype/skype"
+QA_DT_HASH="opt/skype/skype"
+# QA_PRESTRIPPED="opt/skype/skype"
+
+pkg_setup() {
+ :
+}
+
+src_install() {
+ local MY_S="${S}"
+ use qt-static && MY_S="${WORKDIR}/${PN}_static-${PV}"
+ cd "${MY_S}"
+
+ exeinto /opt/skype
+ doexe skype || die
+ fowners root:audio /opt/skype/skype
+ make_wrapper skype ./skype /opt/skype /opt/skype
+
+ insinto /opt/skype/sounds
+ doins sounds/*.wav || die
+
+ if ! use qt-static; then
+ insinto /etc/dbus-1/system.d
+ doins skype.conf || die
+ fi
+
+ if ! use qt-static; then
+ lrelease lang/*.ts
+ fi
+
+ insinto /opt/skype/lang
+ doins lang/*.qm || die
+
+ insinto /opt/skype/avatars
+ doins avatars/*.png || die
+
+ local res
+ for res in 16 32 48; do
+ insinto /usr/share/icons/hicolor/${res}x${res}/apps
+ newins icons/SkypeBlue_${res}x${res}.png skype.png || die
+ done
+
+ dodoc README
+
+ make_desktop_entry skype "Skype VoIP" skype "Network;InstantMessaging;Telephony"
+
+ dosym /opt/skype /usr/share/skype #Fix for disabled sound notification
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}