summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrej Kacian <ticho@gentoo.org>2007-08-22 05:13:56 +0000
committerAndrej Kacian <ticho@gentoo.org>2007-08-22 05:13:56 +0000
commit7984dc11d83c75871ca7a3dea6cde3395cef5945 (patch)
tree9aaf0f230089416a82c0377c01eb7df49d94a193 /net-im/silc-plugin
parentadd restrict=test again as it still breaks (diff)
downloadgentoo-2-7984dc11d83c75871ca7a3dea6cde3395cef5945.tar.gz
gentoo-2-7984dc11d83c75871ca7a3dea6cde3395cef5945.tar.bz2
gentoo-2-7984dc11d83c75871ca7a3dea6cde3395cef5945.zip
Version bump. Bug #182066.
(Portage version: 2.1.3_rc8)
Diffstat (limited to 'net-im/silc-plugin')
-rw-r--r--net-im/silc-plugin/ChangeLog7
-rw-r--r--net-im/silc-plugin/files/digest-silc-plugin-1.1.23
-rw-r--r--net-im/silc-plugin/silc-plugin-1.1.2.ebuild87
3 files changed, 96 insertions, 1 deletions
diff --git a/net-im/silc-plugin/ChangeLog b/net-im/silc-plugin/ChangeLog
index a4ed8f2f72d0..71060cd5593d 100644
--- a/net-im/silc-plugin/ChangeLog
+++ b/net-im/silc-plugin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-im/silc-plugin
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/silc-plugin/ChangeLog,v 1.24 2007/06/24 11:55:52 ticho Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/silc-plugin/ChangeLog,v 1.25 2007/08/22 05:13:56 ticho Exp $
+
+*silc-plugin-1.1.2 (22 Aug 2007)
+
+ 22 Aug 2007; Andrej Kacian <ticho@gentoo.org> +silc-plugin-1.1.2.ebuild:
+ Version bump. Bug #182066.
*silc-plugin-1.0.4.1 (24 Jun 2007)
diff --git a/net-im/silc-plugin/files/digest-silc-plugin-1.1.2 b/net-im/silc-plugin/files/digest-silc-plugin-1.1.2
new file mode 100644
index 000000000000..2dc6fff038d5
--- /dev/null
+++ b/net-im/silc-plugin/files/digest-silc-plugin-1.1.2
@@ -0,0 +1,3 @@
+MD5 6e440bbfd9a746cf33c020c31ab95a30 silc-client-1.1.2.tar.bz2 1622496
+RMD160 ac08152f7d49a0e14c2b900c3983d5e97992f29a silc-client-1.1.2.tar.bz2 1622496
+SHA256 6c03bf28c87eef31c2058acfa132542cc088ae819f2233d520b042eb916d89f4 silc-client-1.1.2.tar.bz2 1622496
diff --git a/net-im/silc-plugin/silc-plugin-1.1.2.ebuild b/net-im/silc-plugin/silc-plugin-1.1.2.ebuild
new file mode 100644
index 000000000000..3cf249aee1b5
--- /dev/null
+++ b/net-im/silc-plugin/silc-plugin-1.1.2.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/silc-plugin/silc-plugin-1.1.2.ebuild,v 1.1 2007/08/22 05:13:56 ticho Exp $
+
+inherit eutils perl-module
+
+IRSSI_PV="0.8.10a"
+
+DESCRIPTION="A SILC plugin for Irssi"
+HOMEPAGE="http://penguin-breeder.org/silc/"
+SRC_URI="http://www.silcnet.org/download/client/sources/silc-client-${PV}.tar.bz2"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+# All necessary dependencies are pulled in by irssi.
+DEPEND="=dev-libs/glib-1.2*
+ www-client/lynx" # this is for .html -> .txt docs convert
+RDEPEND=">=net-irc/irssi-${IRSSI_PV%a}
+ >=dev-perl/MIME-tools-5.413
+ dev-perl/File-MMagic
+ dev-perl/MailTools"
+
+S="${WORKDIR}/silc-client-${PV}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ sed -i -e "s:-g -O2:${CFLAGS}:g" configure
+ use amd64 && sed -i -e 's:felf\([^6]\):felf64\1:g' configure
+}
+
+src_compile() {
+
+ econf \
+ ${myflags} \
+ --with-silc-plugin \
+ --without-silc-includes \
+ --with-pic \
+ || die
+
+ emake || die
+}
+
+src_install() {
+ local myflags
+
+ R1="s/installsitearch='//"
+ R2="s/';//"
+ perl_sitearch="`perl -V:installsitearch | sed -e ${R1} -e ${R2}`"
+ myflags="${myflags} INSTALLPRIVLIB=/usr/$(get_libdir)"
+ myflags="${myflags} INSTALLARCHLIB=${perl_sitearch}"
+ myflags="${myflags} INSTALLSITELIB=${perl_sitearch}"
+ myflags="${myflags} INSTALLSITEARCH=${perl_sitearch}"
+
+ make DESTDIR="${D}" ${myflags} install || die
+
+ dodoc ${D}/usr/share/doc/silc-client/*
+ rm -rf ${D}/usr/share/doc/silc-client
+
+ fixlocalpod
+}
+
+pkg_postinst() {
+ elog "You can load the plugin with following command in Irssi:"
+ elog
+ elog "\t/LOAD silc"
+ elog
+ elog "It will automatically generate a new key pair for you. You will be asked to"
+ elog "enter a passphrase for this keypair twice. If you leave the passphrase"
+ elog "empty, your key will not be stored encrypted."
+ elog
+ elog "To make full use of silc-plugin, you should load the following perl scripts"
+ elog "into irssi:"
+ elog
+ elog "\t/SCRIPT LOAD silc"
+ elog "\t/SCRIPT LOAD silc-mime"
+ elog
+ elog "To connect to the SILCNet, you can use following command in Irssi:"
+ elog
+ elog "\t/CONNECT -silcnet SILCNet silc.silcnet.org"
+ elog
+ elog "Have fun."
+}