summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChuck Short <zul@gentoo.org>2004-01-03 04:11:42 +0000
committerChuck Short <zul@gentoo.org>2004-01-03 04:11:42 +0000
commitf18a27bfd7732ad2b51652519e841973aef98b46 (patch)
tree8923f064b07e378e99eabbac28514f91a929b75d /net-im/silc-client/silc-client-1.0.ebuild
parentMarked stable, updated copyright years, version bump (diff)
downloadgentoo-2-f18a27bfd7732ad2b51652519e841973aef98b46.tar.gz
gentoo-2-f18a27bfd7732ad2b51652519e841973aef98b46.tar.bz2
gentoo-2-f18a27bfd7732ad2b51652519e841973aef98b46.zip
Marked stable, updated copyright years, version bump
Diffstat (limited to 'net-im/silc-client/silc-client-1.0.ebuild')
-rw-r--r--net-im/silc-client/silc-client-1.0.ebuild64
1 files changed, 64 insertions, 0 deletions
diff --git a/net-im/silc-client/silc-client-1.0.ebuild b/net-im/silc-client/silc-client-1.0.ebuild
new file mode 100644
index 000000000000..40899efe8e3e
--- /dev/null
+++ b/net-im/silc-client/silc-client-1.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/silc-client/silc-client-1.0.ebuild,v 1.1 2004/01/03 04:11:28 zul Exp $
+
+DESCRIPTION="IRSSI-based text client for Secure Internet Live Conferencing"
+SRC_URI="http://www.silcnet.org/download/client/sources/${P}.tar.bz2"
+HOMEPAGE="http://silcnet.org/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc"
+IUSE="ipv6 perl socks5"
+
+DEPEND="=dev-libs/glib-1.2*
+ perl? ( dev-lang/perl )
+ socks5? ( net-misc/dante )
+ sys-libs/ncurses"
+
+src_compile() {
+ local myconf
+ use ipv6 && myconf="${myconf} --enable-ipv6"
+ use socks5 && myconf="${myconf} --with-socks5"
+
+ econf \
+ --prefix=/usr \
+ --datadir=/usr/share/${PN} \
+ --with-datadir=/usr/share/${PN} \
+ --with-docdir=/usr/share/doc/${PN} \
+ --with-helpdir=/usr/share/${PN}/help \
+ --with-logsdir=/var/log/${PN} \
+ --with-simdir=/usr/lib/${PN} \
+ --with-mandir=/usr/share/man \
+ --with-ncurses \
+ --without-silcd \
+ ${myconf} \
+ || die "./configure failed"
+
+ make || die "make failed"
+}
+
+src_install() {
+ myflags=""
+ if [ "`use perl`" ]
+ then
+ R1="s/installsitearch='//"
+ R2="s/';//"
+ perl_sitearch="`perl -V:installsitearch | sed -e ${R1} -e ${R2}`"
+ myflags="${myflags} INSTALLPRIVLIB=${D}/usr/lib"
+ myflags="${myflags} INSTALLARCHLIB=${D}/${perl_sitearch}"
+ myflags="${myflags} INSTALLSITELIB=${D}/${perl_sitearch}"
+ myflags="${myflags} INSTALLSITEARCH=${D}/${perl_sitearch}"
+ fi
+
+ make DESTDIR=${D} ${myflags} install || die "make install failed"
+ mv ${D}/usr/libsilc.a ${D}/usr/lib/
+ mv ${D}/usr/libsilcclient.a ${D}/usr/lib/
+ mv ${D}/usr/libsilcclient.la ${D}/usr/lib/
+ mv ${D}/usr/libsilc.la ${D}/usr/lib/
+ rmdir ${D}/usr/share/silc/
+ rmdir ${D}/usr/include
+
+ dodir /usr/share/man
+ mv ${D}/man1 ${D}/usr/share/man
+}