summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2003-04-24 22:31:26 +0000
committerAlastair Tse <liquidx@gentoo.org>2003-04-24 22:31:26 +0000
commit4dea10196f3bdfeadd1a0b41f07bc3675c841909 (patch)
tree5a6eda0c61d45621ef7312fce70a517293710f7a /net-im/silc-client/silc-client-0.9.11.ebuild
parentnew version (diff)
downloadgentoo-2-4dea10196f3bdfeadd1a0b41f07bc3675c841909.tar.gz
gentoo-2-4dea10196f3bdfeadd1a0b41f07bc3675c841909.tar.bz2
gentoo-2-4dea10196f3bdfeadd1a0b41f07bc3675c841909.zip
fix stray man dir
Diffstat (limited to 'net-im/silc-client/silc-client-0.9.11.ebuild')
-rw-r--r--net-im/silc-client/silc-client-0.9.11.ebuild26
1 files changed, 20 insertions, 6 deletions
diff --git a/net-im/silc-client/silc-client-0.9.11.ebuild b/net-im/silc-client/silc-client-0.9.11.ebuild
index 1988cb679aef..0fe94d12e0d4 100644
--- a/net-im/silc-client/silc-client-0.9.11.ebuild
+++ b/net-im/silc-client/silc-client-0.9.11.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/silc-client/silc-client-0.9.11.ebuild,v 1.5 2003/03/11 21:11:46 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/silc-client/silc-client-0.9.11.ebuild,v 1.6 2003/04/24 22:31:18 liquidx Exp $
+
+inherit libtool
DESCRIPTION="IRSSI-based text client for Secure Internet Live Conferencing"
SRC_URI="http://www.silcnet.org/download/client/sources/${P}.tar.bz2"
@@ -9,20 +11,25 @@ HOMEPAGE="http://silcnet.org/"
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="x86 ppc"
-IUSE="ipv6 perl"
+IUSE="ipv6 perl ncurses"
DEPEND="=dev-libs/glib-1.2*
perl? ( dev-lang/perl )
- sys-libs/ncurses"
+ ncurses? ( sys-libs/ncurses )"
src_compile() {
+ elibtoolize
+
econf \
- --mandir=${D}/usr/share/man \
+ --mandir=/usr/share/man \
--with-helpdir=/usr/share/silc/help \
--with-docdir=/usr/share/doc/${P} \
--with-simdir=/usr/lib/silc/modules \
--with-logsdir=/var/log/silc \
- --with-ncurses \
+ --with-etcdir=/etc/silv \
+ --with-libdir=/usr/lib \
+ --without-libtoolfix \
+ `use_with ncurses` \
`use_with ipv6` \
|| die "./configure failed"
@@ -30,7 +37,8 @@ src_compile() {
}
src_install() {
- myflags=""
+ local myflags
+
if [ "`use perl`" ]
then
R1="s/installsitearch='//"
@@ -41,7 +49,13 @@ src_install() {
myflags="${myflags} INSTALLSITELIB=${D}/${perl_sitearch}"
myflags="${myflags} INSTALLSITEARCH=${D}/${perl_sitearch}"
fi
+
+ myflags="${myflags} mandir=${D}/usr/share/man"
make DESTDIR=${D} ${myflags} install || die "make install failed"
+
+ # screwed up libtool installs things in the wrong place
+ mv ${D}/usr/libsilc* ${D}/usr/lib
+
rmdir ${D}/usr/include
}